Hi the lotus
You can achieve this using the ignore option in you custom rule like:
<group name="Office365">
<rule id="100004" level="5" ignore="3600">
<if_sid>81634</if_sid>
<field name="policyid">\.+</field>
<description>This is a test of a custom ruleset for detecting SharePoint file-sharing events</description>
<options>no_full_log</options>
</rule>
</group>
The alert will trigger once and then ignore this rule for the next 3600 seconds. However, it will start triggering the rule-id mentioned in if_sid (91544), as this is the parent rule. Then you need to suppress that rule by changing its rule level from less than 3 so it won't trigger alerts wazuh-dashboard using the tag overwrite ="yes".
You can use negate= yes as shown below so the rule
81634 won't triggered if the there policyid Make sure that you have to modify the default rule by adding the overwrite="yes" tag. Please paste the default rule at /var/ossec/etc/rules/local_rules.xml and then edit the rule.
<rule id="81634" level="5">
<if_sid>81603</if_sid>
<match>subtype="app-ctrl"|subtype=app-ctrl</match>
<action>block</action>
<field name="policyid" negate="yes">\.+</field>
<description>Fortigate: App blocked by firewall.</description>
<group>firewall_drop,gdpr_IV_35.7.d,hipaa_164.312.b,nist_800_53_AU.6,pci_dss_10.6.1,</group>
</rule>
To know how to change the existing rule please follow:
https://documentation.wazuh.com/current/user-manual/ruleset/custom.html#changing-an-existing-ruleHope this will help.
Regrads.
For that, you can refer to
https://documentation.wazuh.com/current/user-manual/ruleset/rules/custom.html#changing-existing-rulesRefer:
https://documentation.wazuh.com/current/user-manual/ruleset/ruleset-xml-syntax/rules.html#rules-optionsHoppe this helps