Flooded with new alerts since upgrade

315 views
Skip to first unread message

Franck Ehret

unread,
May 6, 2022, 2:49:45 AM5/6/22
to Wazuh mailing list
Dear all,

Since the update to 4.3 (production release), I'm flooded with new level 15 alerts from event ID 4624 :

alerts since update.png

Thing is, once I started to dig a little (I was pretty scared when I opened my mailbox this morning!), such events are there since a while and are not RDP related (at least I can't correlate with it) :

event 4624 90 days.png
Details of one :

"An account was successfully logged on.

Subject:
    Security ID:        S-1-0-0
    Account Name:        -
    Account Domain:        -
    Logon ID:        0x0

Logon Information:
    Logon Type:        3
    Restricted Admin Mode:    -
    Virtual Account:        No
    Elevated Token:        Yes

Impersonation Level:        Impersonation

New Logon:
    Security ID:        S-1-5-18
    Account Name:        MYSERVERNAME$
    Account Domain:        MYDOMAIN.LOCAL
    Logon ID:        0x3C50766
    Linked Logon ID:        0x0
    Network Account Name:    -
    Network Account Domain:    -
    Logon GUID:        {theguidofaccount}

Process Information:
    Process ID:        0x0
    Process Name:        -

Network Information:
    Workstation Name:    -
    Source Network Address:    127.0.0.1
    Source Port:        51314

Detailed Authentication Information:
    Logon Process:        Kerberos
    Authentication Package:    Kerberos
    Transited Services:    -
    Package Name (NTLM only):    -
    Key Length:        0

This event is generated when a logon session is created. It is generated on the computer that was accessed.

The subject fields indicate the account on the local system which requested the logon. This is most commonly a service such as the Server service, or a local process such as Winlogon.exe or Services.exe.

The logon type field indicates the kind of logon that occurred. The most common types are 2 (interactive) and 3 (network).

The New Logon fields indicate the account for whom the new logon was created, i.e. the account that was logged on.

The network fields indicate where a remote logon request originated. Workstation name is not always available and may be left blank in some cases.

The impersonation level field indicates the extent to which a process in the logon session can impersonate.

The authentication information fields provide detailed information about this specific logon request.
    - Logon GUID is a unique identifier that can be used to correlate this event with a KDC event.
    - Transited services indicate which intermediate services have participated in this logon request.
    - Package name indicates which sub-protocol was used among the NTLM protocols.
    - Key length indicates the length of the generated session key. This will be 0 if no session key was requested."


data.win.eventdata.logonType is 3 which means "Network". 
Also, a lot of those events are created by Exchange Health Mailboxes.

Should I start to worry or is it a false positive ?
PS: don't mind the time of start of the alerts, update was done automatically.

Thanks in advance for you help/advice & kind regards
Franck

Jose Antonio Izquierdo

unread,
May 6, 2022, 3:44:06 AM5/6/22
to Wazuh mailing list
Hi Franck, 

This looks like a false positive. 

The rule 92656 that is matching must have as parent rule the id 92653 and not the 60106. I will open an issue to verify my assumption and modify the ruleset.

  <rule id="92656" level="15">
    <if_sid>
92653</if_sid>
    <field name="win.eventdata.ipAddress" type="pcre2">::1|127\.0\.0\.1</field>
    <description>User: $(win.eventdata.subjectDomainName)\$(win.eventdata.targetUserName) logged using Remote Desktop Connection (RDP) from loopback address, possible exploit over reverse tunneling using stolen credentials.</description>
    <mitre>
      <id>T1021.001</id>
      <id>T1078.002</id>
    </mitre>
  </rule>


To solve the flood by now, you can modify the rule in file 0840-win_event_channel.xml by adding 92653 as the if_sid rule id or comment on the rule. Ping me if you need more info or help. I will provide feedback about the issue later today,

Thanks 
Jose.

Jose Antonio Izquierdo

unread,
May 6, 2022, 9:18:27 AM5/6/22
to Wazuh mailing list
Hi Franck, 

This is the issue we will track the false positive resolution:


Please, let us know any questions you may have.

Franck Ehret

unread,
May 9, 2022, 3:59:46 PM5/9/22
to Wazuh mailing list
Hi Jose,

Thanks again for your great reactivity, I didn't get any email alert and answering to you "late"!
I think I found the right file and updated it directly in the file system, since then I didn't get any new alert!

Thanks again and glad I could help correcting this.

Kind regards
Franck
Reply all
Reply to author
Forward
0 new messages