--
You received this message because you are subscribed to the Google Groups "Wazuh mailing list" group.
To unsubscribe from this group and stop receiving emails from it, send an email to wazuh+un...@googlegroups.com.
To post to this group, send email to wa...@googlegroups.com.
Visit this group at https://groups.google.com/group/wazuh.
To view this discussion on the web visit https://groups.google.com/d/msgid/wazuh/67f6e6a1-37a6-4942-984e-de7c439a5f65%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.
Hi Louis,Here you can read a blog post publish a while ago, it is using CDB lists and create one of them from the scratch: https://blog.wazuh.com/cdb-lists/ (Using OSINT to create CDB lists and block malicious IPs)You can check as well this thread: https://groups.google.com/forum/#!topic/wazuh/JnV-IHanV7E.Let me know if it is what you are looking for.I hope it helps,Pedro 'snaow' Sanchez.
On Mon, Sep 3, 2018 at 9:51 AM Louis Bernardo <lo...@louisbernardo.com> wrote:
Hi All,--Does anyone have a working CDB example for me (lists, ossec.conf, and a rule)? It seems no matter what I do it simply won't read my list and insert the text.Thanks,L
You received this message because you are subscribed to the Google Groups "Wazuh mailing list" group.
To unsubscribe from this group and stop receiving emails from it, send an email to wazuh+unsubscribe@googlegroups.com.
<decoder name="forcepoint-proxy-traffic"> <parent>forcepoint-proxy</parent> <prematch offset="after_parent">product=Security</prematch> <regex offset="after_prematch">\.*action=(\S+) severity=(\d+) category=(\d+) user=(\.*) loginID=(\.*) src_host=(\S+) src_port=(\d+) dst_host=(\.*) dst_ip=(\S+) dst_port=(\d+) bytes_out=(\d+) bytes_in=(\d+) http_response=(\d+) http_method=(\S+) http_content_type=(\.*) http_user_agent=(\.*) http_proxy_status_code=(\d+) reason=(\w+) disposition=(\d+) policy=(\.*) role=(\d+) duration=(\d+) url=(\.*)</regex> <order>action,severity,category,user,loginid,srcip,srcport,dsthost,dstip,dstport,bytes_out,bytes_in,http_response,http_method,http_content_type,http_user_agent,http_proxy_status_code,reason,disposition,policy,role,duration,url</order></decoder>
<group name="forcepoint,syslog,"> <rule id="120000" level="0"> <decoded_as>forcepoint-proxy</decoded_as> <description>Forcepoint proxy messages grouped.</description> </rule>
<rule id="120001" level="0"> <if_sid>120000</if_sid> <list field="category" lookup="match_key">/etc/lists/forcepoint/forcepoint-category</list> <description>Forcepoint: $(category)</description> <group>proxy_drop,Forcepoint,</group> </rule>
</group>
<list>etc/lists/forcepoint/forcepoint-category</list>
76:Information Technology - Search Engines and Portals
<159>Aug 28 10:21:02 10.10.10.10 vendor=Forcepoint product=Security product_version=8.4.0 action=blocked severity=7 category=76 user=LDAP://thisisfake.com OU\=Desktop Users,OU\=Users,OU\=IT Service Desk,DC\=com/Akuna Matata loginID=AM99 src_host=10.10.10.20 src_port=53728 dst_host=clients1.google.com dst_ip=216.58.223.46 dst_port=443 bytes_out=0 bytes_in=0 http_response=0 http_method=CONNECT http_content_type=- http_user_agent=Mozilla/5.0_(Windows_NT_6.1)_AppleWebKit/537.36_(KHTML,_like_Gecko)_Chrome/61.0.3163.79_Safari/537.36 http_proxy_status_code=403 reason=- disposition=1031 policy=**WWW_Casual_Time_Policy**Authenticated_User_access role=8 duration=5 url=https://clients1.google.com
**Phase 2: Completed decoding. decoder: 'forcepoint-proxy' action: 'blocked' severity: '7' category: '76' dstuser: 'LDAP://thisisfake.com OU\=Desktop Users,OU\=Users,OU\=IT Service Desk,DC\=com/Akuna Matata' loginid: 'AM99' srcip: '10.10.10.20' srcport: '53728' dsthost: 'clients1.google.com' dstip: '216.58.223.46' dstport: '443' bytes_out: '0' bytes_in: '0' http_response: '0' http_method: 'CONNECT' http_content_type: '-' http_user_agent: 'Mozilla/5.0_(Windows_NT_6.1)_AppleWebKit/537.36_(KHTML,_like_Gecko)_Chrome/61.0.3163.79_Safari/537.36' http_proxy_status_code: '403' reason: '-' disposition: '1031' policy: '**WWW_Casual_Time_Policy**Authenticated_User_access' role: '8' duration: '5' url: 'https://clients1.google.com'
**Phase 3: Completed filtering (rules). Rule id: '120000' Level: '0' Description: 'Forcepoint proxy messages grouped.'
Hi Louis,
thanks for all the files and the information.
I'm not sure about what you are trying to achieve, but there might be several reasons why it isn't working.
There is a mistake in this line of the rule 120001
<list field="category" lookup="match_key">/etc/lists/forcepoint/forcepoint-category</list>
It should be
<list field="category" lookup="match_key">etc/lists/forcepoint/forcepoint-category</list>
without the initial "/" . Because the manager uses a relative path to the list file starting from /var/ossec/.
Also, in order to work, the CDB list need to be compiled using the binary
/var/ossec/bin/ossec-makelists
Make sure you execute the command after any change in the list file to update the .cdb file.
Hope it solves the problem.
Best regards.