ERROR: the above CMVS command failed

4094 views
Skip to first unread message

LEI LIU

unread,
May 21, 2015, 5:34:56 PM5/21/15
to vs...@googlegroups.com
hello  

when I run the "Dense Reconstruction" ,it showed the "ERROR: the above CMVS command failed!
here is the errors , someone can tell me how to resove 


Running Yasutaka Furukawa's CMVS tool...
cmvs "C:\Users\ll\Desktop\Nouveau dossier\Modele\exemple\dense.nvm.cmvs\00\\" 50 8
ERROR: the above CMVS command failed!

Williams Bukret

unread,
May 30, 2015, 6:48:30 PM5/30/15
to vs...@googlegroups.com
Hello,
I,m dealing with the same problem. Did you solved it?
Thank you!

Changchang Wu

unread,
Jun 1, 2015, 2:13:35 AM6/1/15
to Williams Bukret, VisualSFM
The URL in the log did not help?

--
You received this message because you are subscribed to the Google Groups "VisualSFM" group.
To unsubscribe from this group and stop receiving emails from it, send an email to vsfm+uns...@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Williams Bukret

unread,
Jun 1, 2015, 8:41:51 AM6/1/15
to vs...@googlegroups.com, drbu...@drbukret.com

Dear Changchang Wu,
Thank you for your response and your wonderful work. Yes, the link helps, but now these issue..
So far I uploaded 34 pictures of a head with these features
34: IMG_4145
image_size: 2256x1504
focal_length: 3240.831
#sift count: 2897
Then I get  "58 Image Match finished, 7 sec used"

After 3D reconstruction the resume is:
2 model(s) reconstructed from 35 images;
4 modeled; 0 reused; 35 EXIF; 
1MB(1) used to store feature location.
---------------------------------------------------

########-------timing------#########
Structure-From-Motion finished, 26 sec used
24.9(24.9) seconds on Bundle Adjustment (+)
24.7(24.7) seconds on Bundle Adjustment (*)
#############################
----------------------------------------------------------------
Run full 3D reconstruction, finished
Totally 26.000 seconds used

After running CMVS 
Running Yasutaka Furukawa's CMVS tool...
cmvs C:\Users\karina\Pictures\Cara\Pm\pm.nvm.cmvs\01\ 50 4
genOption C:\Users\karina\Pictures\Cara\Pm\pm.nvm.cmvs\01\ 1 2 0.700000 7 2 4
1 cluster is generated for pmvs reconstruction.
pmvs2 C:\Users\karina\Pictures\Cara\Pm\pm.nvm.cmvs\01\ option-0000
This may take a little more time, waiting...
9 seconds were used by PMVS
Loading option-0000.ply, 626 vertices ...

#############################
You can manually remove bad MVS points:
1. Switch to dense MVS points mode;
2. Hit F1 key to enter the selection mode;
3. Select points by dragging a rectangle;
4. Hit DELETE to delete the selected points.

#############################
Save to pm.nvm ... done
Save C:\Users\karina\Pictures\Cara\Pm\pm.1.ply ...done
----------------------------------------------------------------
Run dense reconstruction, finished
Totally 14.000 seconds used

1. I guess there are insufficient features or points to reconstruct the image?
2. Should I get more views with less than 1MB?
3. What do you recommend for faces?

I apologize for so many questions

Thank you so much for your help

Will

Changchang Wu

unread,
Jun 3, 2015, 12:34:35 AM6/3/15
to vs...@googlegroups.com, drbu...@drbukret.com
Right. You can achieve this either by using more detailed photos (close-up views so you can see detailed points), or using photos with textured background.
2. Should I get more views with less than 1MB?
Not sure what you mean by 1MB. It certainly helps with more photos from various viewpoints.
3. What do you recommend for faces?
I do not have much experience with face reconstruction, and there are dedicated research on this topic. I do not know about softwares. 
You might be able to get it done with sfm softwares by feeding good photos. You should also try alternative softwares that can generate mesh directly (instead of PMVS). I have a few pointers on the website.

Kristen Starfish

unread,
Aug 6, 2017, 10:46:38 PM8/6/17
to VisualSFM
Hello,

I am also trying to run VisualSFM but having problem with the dense reconstruction...

Running Yasutaka Furukawa's CMVS tool...
cmvs "/Users/jc238416/Documents/Research/Central GBR/kk2/kk2.nvm.cmvs/01/" 50 8

ERROR: the above CMVS command failed!
FAQ: http://ccwu.me/vsfm/doc.html#errors


In the terminal lines for Visual SFM it says
sh cmvs: command not found.

I am not sure how to get the programs to talk to eachother.

I am running a macOX Sierra and also have very little knowledge of programming. If you can give me any advice that would be greatly appreciated. I feel like I am so close to getting this working.

Best,
Kristen

ARJUN M

unread,
Feb 23, 2018, 5:55:56 AM2/23/18
to VisualSFM
Dear Changchang Wu,

We are students from India working on the project of reconstructing medical images into a 3_D structure using VSFM.

The problem we are currently facing is:

We used 60 images as input and CMVS phase has failed.
22 cams, 1746 pts (3+: 631)
7221 projections (3+: 3745)
---------------------------------------------------
2 model(s) reconstructed from 60 images;
60 modeled; 0 reused; 0 EXIF; 
10MB(9) used to store feature location.
---------------------------------------------------

########-------timing------#########
Structure-From-Motion finished, 15 sec used
12.8(12.4) seconds on Bundle Adjustment (+)
11.8(11.8) seconds on Bundle Adjustment (*)
#############################
----------------------------------------------------------------
Run full 3D reconstruction, finished
Totally 15.000 seconds used


Run dense reconstruction, begin...
Save to gyufg.nvm ... done

#############################
Undistorting 22 images in model #1
param_undistortion_thread_num = 0
NOTE: using 4 threads...
#02: entropy06 -> 00000003.jpg, 0.595 sec
#01: entropy07 -> 00000002.jpg, 0.605 sec
#01: entropy01 -> 00000007.jpg, 0.002 sec
#00: entropy05 -> 00000000.jpg, 0.629 sec
#01: entropy12 -> 00000008.jpg, 0.019 sec
#01: entropy13 -> 00000009.jpg, 0.002 sec
#03: entropy04 -> 00000004.jpg, 0.645 sec
#03: entropy10 -> 00000011.jpg, 0.003 sec
#03: entropy14 -> 00000012.jpg, 0.002 sec
#03: entropy11 -> 00000013.jpg, 0.002 sec
#01: entropy09 -> 00000010.jpg, 0.020 sec
#03: entropy15 -> 00000014.jpg, 0.006 sec
#01: entropy16 -> 00000015.jpg, 0.043 sec
#03: entropy18 -> 00000017.jpg, 0.038 sec
#01: entropy17 -> 00000016.jpg, 0.003 sec
#03: entropy19 -> 00000018.jpg, 0.002 sec
#01: entropy20 -> 00000019.jpg, 0.003 sec
#03: entropy22 -> 00000021.jpg, 0.027 sec
#01: entropy21 -> 00000020.jpg, 0.023 sec
#02: entropy03 -> 00000005.jpg, 0.428 sec
#00: entropy08 -> 00000001.jpg, 0.414 sec
#02: entropy02 -> 00000006.jpg, 0.336 sec
----------------------------------------------------------------
Running Yasutaka Furukawa's CMVS tool...
cmvs "F:\AI PROJECTS\dataset\dataWithentropy\gyufg.nvm.cmvs\01\\" 50 4
genOption "F:\AI PROJECTS\dataset\dataWithentropy\gyufg.nvm.cmvs\01\\" 1 2 0.700000 7 3 4
1 cluster is generated for pmvs reconstruction.
pmvs2 "F:\AI PROJECTS\dataset\dataWithentropy\gyufg.nvm.cmvs\01\\" option-0000
This may take a little more time, waiting...
ERROR: the above CMVS command failed!
----------------------------------------------------------------
Run dense reconstruction, finished
Totally 10.000 seconds used





Our Questions are :

1. Is this a case of bad input?
2.If so, how is the input classified as bad?

 

Steven Meyers

unread,
Mar 28, 2018, 2:24:40 PM3/28/18
to VisualSFM
Has anyone found a solution or otherwise how to deal with this error?  I am getting it too.

Flavius Cuc

unread,
Jul 4, 2018, 9:43:17 AM7/4/18
to VisualSFM
Yeah you need to copy the binaries from https://github.com/pmoulon/CMVS-PMVS

to the folder where visualSFM is.

ns.ob...@gmail.com

unread,
Oct 18, 2018, 12:11:09 PM10/18/18
to VisualSFM


Am Mittwoch, 4. Juli 2018 15:43:17 UTC+2 schrieb Flavius Cuc:
Yeah you need to copy the binaries from https://github.com/pmoulon/CMVS-PMVS

to the folder where visualSFM is.

Thank you!

geek_kid

unread,
Oct 22, 2018, 4:00:48 AM10/22/18
to VisualSFM
Sorry to hijack the thread but I had this problem but the binaries don't work for me as the Linux ones are 32 bit only and I'm 64 bit

Khalil Khalaf

unread,
Jan 4, 2020, 4:46:27 PM1/4/20
to VisualSFM
Which binaries exactly? And where exactly?

I have VSFM under Desktop\VisualSFM, and it has a bunch of files that came with it:

1.PNG



Then I unzip cmvs which looked like this:

2.PNG


Then I move this cmvs folder into vsfm folder like this:

3.PNG


Now what? Which binaries go in which folder? Please and thanks!
Reply all
Reply to author
Forward
0 new messages