virtual server 2 doesn't work

5 views
Skip to first unread message

ronaldlw

unread,
Jul 27, 2009, 3:38:11 PM7/27/09
to vmsbackup
I am trying to use this script with vmware server 2 and get "failed to
login: vim.fault.NoPermission" for everything. I scanned through the
script and see that you don't ever actually use the VMUSER or VMPASS
variables when making calls to vmware-vim-cmd for example. I was able
to get it to at least add a vm and list the vms after adding -U
$VMUSER -P $VMPASS to the script where vmware-vim-cmd lines exist.
I'm going to keep looking through the script to see if I can figure
out where else this is needed. Is this just me or is this a major
problem with the script?

ronaldlw

unread,
Jul 27, 2009, 4:40:19 PM7/27/09
to vmsbackup
I have been able to get the backup script to not give me the
NoPermission errors, but the snapshot always fails and I mentioned a
couple of other issues in another post.

ronaldlw

unread,
Jul 27, 2009, 4:49:49 PM7/27/09
to vmsbackup
Snapshot fails because the "INSTALL.TXT" instructions for creating the
backup script role did not include the requirement for Virtual Machine
-> State -> create snapshot privileges.

What other privileges are needed? I'll try to figure out from the
script..

Ron

Par_Tojkander

unread,
Jul 28, 2009, 3:34:15 AM7/28/09
to vmsbackup
Could you create an issue in the issue tracker, describing what went
wrong and any error messages you received? That way we can collaborate
on solving the issue.

http://code.google.com/p/vmsbackup/issues/list

Best regards,

Pär
Reply all
Reply to author
Forward
0 new messages