Java Version and Visone

39 views
Skip to first unread message

Sebastian Haunss

unread,
May 16, 2024, 1:10:53 PMMay 16
to visone-users
Dear Visone developers,
what is the highest java version with which you can still run Visone?
I noticed that Visone 2.27.1 no longer runs with my default java version (openjdk 21.0.3 on MacOS 14.5), but works with the Oracle Java version 1.8.0_341.
Interestingly, Visone 2.26 runs with both Java versions without problems.
Best
Sebastian


Müller Julian

unread,
May 19, 2024, 2:36:30 PMMay 19
to visone...@googlegroups.com
Hi Sebastian,

There is an incompatibility between visone 2.27(.1) and OpenJDK >= 21, causing visone to hang when some specific operations are performed (like the quick layout). So this incompatibility can be avoided if you downgrade visone or the JDK.

A change to resolve this issue made it into the main branch of the internal repository a few days ago, so this problem will be gone with the next release (probably in June or July).

Best wishes,
Julian


Reply all
Reply to author
Forward
Message has been deleted
0 new messages