VineLnux6.5 Webminがインストールできない件

388 views
Skip to first unread message

Yoshihiro Toyota

unread,
May 27, 2017, 10:17:56 PM5/27/17
to Vine Linux ユーザーフォーラム
apt-get でもパッケージマネージャーでもWebminがインストールできません。

インストール準備中に:

Unable to identify operating system
エラー: %pre(webmin-1.560-1vl6.noarch) scriptlet failed, exit status 2
エラー:   install: スクリプト %pre の実行に失敗しました (2)。webmin-1.560-1vl6 をスキップします。
W: Some errors occurred while running transaction

上記の様にエラーになります。
解決方法を教えてください。

hasu

unread,
May 28, 2017, 5:15:41 AM5/28/17
to Vine Linux ユーザーフォーラム
こんにちは。

このWebページの頭から4割ぐらいの所に、
「Frequently Asked Questions - Webmin」
    http://www.webmin.com/faq.html

次の文章が載っていました。

・When installing the Webmin RPM, I get the error message Unable to
  identify operating system

  This happens if Webmin cannot identify your OS by looking at your
  /etc/issue file, possibly because it has been changed from the default
  contents. The best solution is to install the .tar.gz version of
  Webmin, which asks for the OS name and version manually.


それで、VineLinux6.5の/etc/issueを見てみました。

[hoge@xxxx ~]$ cat /etc/issue

Vine Linux 6.5 (Poupille)
Kernel 4.4.52-2vl6 on an i686


行の先頭に 行番号を付けて 表示させてみると、次のようになりました。

[hoge@xxxx ~]$ cat /etc/issue | nl -b a
     1   
     2    Vine Linux 6.5 (Poupille)
     3    Kernel 4.4.52-2vl6 on an i686
     4   


1行目と4行目に 空白の行が入っています。
テキストエディタで、この1行目と4行目を削除してみたら
どうなるかと思いました。

/etc/issueを修正してから、
Webminのインストールをしてみたらどうかなと思いました。



Yoshihiro Toyota

unread,
May 28, 2017, 7:47:53 AM5/28/17
to Vine Linux ユーザーフォーラム
お返事ありがとうございます。
テキストエディタで空白部分は削除しましたが、下記の様にエラーになります。


[root@static ~]# cat /etc/issue | nl -b a

     1   
     2    Vine Linux 6.5 (Poupille)
     3    Kernel 4.4.52-2vl6 on a 2-processor x86_64
     4   
[root@static ~]# cat /etc/issue | nl -b a
     1    Vine Linux 6.5 (Poupille)
     2    Kernel 4.4.52-2vl6 on a 2-processor x86_64
[root@static ~]# apt-get install webmin
パッケージリストを読みこんでいます... 完了
依存情報ツリーを作成しています... 完了       
以下のパッケージが新たにインストールされます:
  webmin
アップグレード: 0 個, 新規インストール: 1 個, 削除: 0 個, 保留: 0 個
0B/16.4MB のアーカイブを取得する必要があります。
展開後に 41.9MB のディスク容量が追加消費されます。
変更を適用しています...
準備中                                ############################## [100%]

Unable to identify operating system
エラー: %pre(webmin-1.560-1vl6.noarch) scriptlet failed, exit status 2
エラー:   install: スクリプト %pre の実行に失敗しました (2)。webmin-1.560-1vl6 をスキップします。
完了
W: トランザクション処理中にエラーが発生しました



Yoshihiro Toyota

unread,
May 28, 2017, 6:08:06 PM5/28/17
to Vine Linux ユーザーフォーラム
自己解決しました。
webminのサイトに行き webmin-1.840.tar.gz を取ってきて ./setup.sh でインストール出来ました。
日本語化も設定出来ました。

ありがとうございました。

hasu

unread,
May 29, 2017, 5:57:05 AM5/29/17
to Vine Linux ユーザーフォーラム
> 自己解決しました。
> webminのサイトに行き webmin-1.840.tar.gz を取ってきて
>  ./setup.sh でインストール出来ました。
> 日本語化も設定出来ました。

そういう方法で いけるのですね。



Reply all
Reply to author
Forward
0 new messages