libreoffice6.2.5が起動しません

196 views
Skip to first unread message

松田七美男

unread,
Aug 17, 2019, 9:44:10 PM8/17/19
to Vine Linux ユーザーフォーラム
ずーっとVine Linux にお世話になっています.ありがとうございます.
本題ですが,LibreOffice を6.2.5にアップしたところ以下のメッセージを出して,起動出来なくなりました.

/opt/libreoffice6.2/program/soffice.bin: /lib64/libdbus-1.so.3: no version information available (required by /opt/libreoffice6.2/program/libmergedlo.so)

Gdk-ERROR **: g_thread_init() must be called before gdk_threads_init()
aborting...

基に戻すのもしんどいのでこのバージョンを動かしたいと思います.
開発機と私の環境の差かもしれませんが,解決策がありましたらご教示ください.

武居紘史

unread,
Aug 19, 2019, 4:59:16 AM8/19/19
to Vine Linux ユーザーフォーラム
松田さま、
こんばんは、
どうも、武居紘史です。

/opt/libreoffice6.2/program/soffice.bin: /lib64/libdbus-1.so.3: no version information available (required by /opt/libreoffice6.2/program/libmergedlo.so)

Gdk-ERROR **: g_thread_init() must be called before gdk_threads_init()
aborting...

との事らしいですね。
僕はLINUX環境で、アプリをちょこちょこ書いているのですが、参考になれば。
と、思い、投稿させて頂きます。
soffice.bin というファイルで、/lib64 という場所にある、libdbus-1.so.3というバージョンの情報では、利用できない。
という、エラーの解釈になりますね。
どうやら、お使いの環境で、GDKバージョンが、libdbus-1.so.3 というdbusって、
確か、なんかのインプットメソッド??じゃなかったかなぁ?
に、対応できないよ〜、と、言っているのです。
で、要は、バージョンが新しすぎても古すぎても使えないのかな、という考えです。
参考になれば、幸いです。

武居紘史

unread,
Aug 19, 2019, 5:07:43 AM8/19/19
to Vine Linux ユーザーフォーラム
で、追記です。

required by /opt/libreoffice6.2/program/libmergedlo.so

ってのは、 libmergedlo.so を必要としているよ、
って、言っています。
ちゃんと、libmergedlo.soが含まれてるパッケージは最新ですか?
しっかり、インストールされていますか?
もし、無いようであれば、探して、入れてくる必要があるような・・・。

松田七美男

unread,
Aug 24, 2019, 4:35:17 AM8/24/19
to Vine Linux ユーザーフォーラム
武居さん,どうもありがとうございます.インストールは普通に
apt-get install install-assit-LibreOffice
で行っています.ただし,保留であったのを無視して行ったので,
バージョン不整合のという不具合が起こったのかもしれません.

現在は,1つ前の6.1.5.2に,これもかなり怪しい方法で戻して使っています.
すなわち,他のホストにある/opt/libreoffice6.1以下を全てコピーし,
/usr/bin/libreoffice へのシンボリックリンクを張り直しました.

2019年8月19日月曜日 18時07分43秒 UTC+9 武居紘史:
Reply all
Reply to author
Forward
0 new messages