Youtube videos aggregation issues

Skip to first unread message

Србољуб Лесандрић

Sep 11, 2022, 6:40:16 AM9/11/22
to Video DownloadHelper Q&A
Hi all, I am experiencing issues with YouTube downloads where I get the error message "failed aggregation" with a bunch of other information about some temporary file being corrupt and not being able to get the information from media.

One example:
Failed aggregating "(11) EDITA - STIKLA (OFFICIAL VIDEO) - YouTube"ffmpeg version N-91146-gfe84f70819-vdhcoapp Copyright (c) 2000-2018 the FFmpeg developers built with gcc 7.3-win32 (GCC) 20180312 configuration: --cross-prefix=x86_64-w64-mingw32- --sysroot=/usr/x86_64-w64-mingw32/ --extra-ldflags=-static-libgcc --target-os=mingw32 --arch=x86_64 --prefix=/home/mig/git/vdhcoapp/converter/src-build/win/64/converter-build --extra-version=vdhcoapp --extra-cflags=-I/home/mig/git/vdhcoapp/converter/src-build/win/64/deps/include --extra-ldflags='-static-libgcc -L/home/mig/git/vdhcoapp/converter/src-build/win/64/deps/lib -L/home/mig/git/vdhcoapp/converter/src-build/win/64/zlib' --extra-libs=-lpthread --pkg-config=/usr/bin/x86_64-w64-mingw32-pkg-config --enable-shared --enable-gpl --enable-pthreads --disable-w32threads --enable-libmp3lame --enable-libopenjpeg --enable-libopus --enable-libtheora --enable-libvorbis --enable-libvpx --enable-libwebp --enable-libx265 --enable-libxvid --enable-libx264 --enable-libaom --enable-avresample --disable-doc libavutil 56. 18.102 / 56. 18.102 libavcodec 58. 19.102 / 58. 19.102 libavformat 58. 16.100 / 58. 16.100 libavdevice 58. 4.100 / 58. 4.100 libavfilter 7. 24.100 / 7. 24.100 libavresample 4. 0. 0 / 4. 0. 0 libswscale 5. 2.100 / 5. 2.100 libswresample 3. 2.100 / 3. 2.100 libpostproc 55. 2.100 / 55. 2.100 <userdata>\AppData\Local\Temp\vdh-2646826wbnHmjV1B6.tmp: Invalid data found when processing input

Any suggestions???

Wild Willy

Sep 11, 2022, 7:35:56 AM9/11/22
to Video Download Helper Google Group
I suggest you post a proper problem report. Click this:

Do a search for the text "problem report" on that page. That will scroll the page to a
position where you will see 2 links. Click each one in turn, read what you find there,
and follow the advice. I recommend you spend some time reading that thread at your
leisure, over time.

When you do post that proper problem report, do so via the Reply all button. DO NOT USE
the Reply to author button. Reply all is the way to add a comment to this thread. Also,
after you search on "problem report" in the other thread, please do another search in
there using "stealth quote" as your search string. That will give you another reference
containing another link you should click. There's some important information there that
you need to know & act upon.

Србољуб Лесандрић

Sep 11, 2022, 8:30:29 AM9/11/22
to Video DownloadHelper Q&A
Licensed: YES
OS: Windows 10, Version 21H2 (OS Build 19044.1889)
Companion App: VdhCoApp 1.6.3
Video DownloadHelper: Version 7.6.0, Browser locale: en-US, Production build, Built on Wed Jun 30 2021 19:49:13 GMT+0200 (Central European Summer Time)
Build options: browser=firefox
Browser: Firefox 104.0.2 (64-bit)

Србољуб Лесандрић

Sep 11, 2022, 9:01:41 AM9/11/22
to Video DownloadHelper Q&A
I have tried uninstalling and reinstalling the Mozilla Firefox - didn't work
I tried removing the extension and adding it again - didn't work
I disabled all other exensions - didn't work
I tried reinstalling the companion app - didn't work

I have a VM running on a virtualbox with that same windows version, same firefox version, same companion app version and same license where everything works!
I am running out of ideas...


Sep 11, 2022, 9:26:11 AM9/11/22
to Video DownloadHelper Q&A
Perhaps it is the video resolution you're downloading, for example 1080p. You'd have to experiment changing video resolution and see
what works and what doesn't .

Wild Willy

Sep 11, 2022, 7:18:57 PM9/11/22
to Video Download Helper Google Group
I went to the page & without even launching playback, VDH offered me a 640x480 variant.
I downloaded it successfully & it played fine in VLC. Then I changed resolutions to
3840x2160, still without launching playback, & that also downloaded successfully & played
fine in VLC.

I'm on Windows 7 64-bit, Firefox 104.0.2 64-bit, licensed VDH 7.6.3a6 beta, CoApp 1.6.3.
Clearly, since you've got it working in one environment but not the other, there is some
sort of configuration issue in the environment that doesn't work. I'm not sure anybody
here can help you with that. I can only suggest you try to compare your 2 environments &
see what might be different. In the environment where it doesn't work, have you done the
"take ownership" thing on your boot partition? There may be some sort of permissions
issue with the directory where VDH saves intermediate temporary files.

Please look into the stealth quote issue. It can become important. It is worth the
effort. And that effort is minimal.

Србољуб Лесандрић

Sep 14, 2022, 7:13:52 AM9/14/22
to Video DownloadHelper Q&A
Thank you all for your replies, here's what I found out:

I can download without issues if I am NOT logged in youtube with my own account, and I can download once I have only one firefox window open and another in private mode, so I can basically download anything as long as I am: 1) Not logged in to and 2) am using VDH in private mode.
Now regarding private mode I thought, surely some add-ons are to blame because in private mode I activate only 2x of them, but no, I tried disabling everything except VDH add-on in normal window and it didn't help at all.
So there is some kind of workaround, I am still not really sure what could be causing these issues but I am glad I can somehow circumvent it.

@mjs: I did try every available resolution and none worked, so that's not the issue here.
@Wild Willy: My user account on my WIN 10 64-bit does not have direct ownership of the boot partition but is in the administrators group which does have the full access to everything, I don't think that is the issue because as described it does work if above 2x conditions are met. What is the "stealth quote issue"?

If you have some other ideas please do let me know!

Wild Willy

Sep 14, 2022, 8:21:13 AM9/14/22
to Video Download Helper Google Group
Go here:

Search for the text "stealth quote" in there. Click the link. Read what it says.

Others have reported this issue with being signed in or not on YouTube. I've very
briefly tried a couple of things when I've been logged in on YouTube & it doesn't stop my
downloads with VDH. Now, you must understand, my login on YouTube is just my generic
Google login. I do not have one of those premium YouTube accounts or one of those
YouTube TV accounts they're always pushing at you. I don't know if that makes any
difference. I haven't tried private browsing. I have had multiple YouTube downloads in
progress concurrently & that works fine.

The ownership thing is a bit of a shot in the dark. I'm the only user on my system as
well & I'm in the administrators group. Yet I found reason years ago to take ownership
of my boot partition anyway. I can't exactly remember now what the reason was. It was
too long ago. I believe I was encountering directories on my boot partition that Windows
kept telling me I was not allowed to access. Yes, despite my being an administrator. So
instead of fixing the permissions piecemeal directory by directory, I just did the whole
partition. There were still a few directories that it wouldn't process. I suspect those
might have been symbolic links. There are a few symbolic links on the boot partition. I
think they're intended to be aliases, alternate names by which you can refer to certain
directories. I didn't create them. They seem to be how Microsoft builds the partition.
In any case, I went through the exercise & my system still runs fine. Maybe this is a
red herring.

I'm looking again at the error message you posted in your first post upthread. I see

ffmpeg version N-91146-gfe84f70819-vdhcoapp Copyright (c) 2000-2018 the FFmpeg developers
built with gcc 7.3-win32 (GCC) 20180312

Just for grins & giggles, I just did this:

C:\Program Files\net.downloadhelper.coapp\converter\build\win\64>ffmpeg
ffmpeg version n4.1.5-vdhcoapp Copyright (c) 2000-2020 the FFmpeg developers
built with gcc 9.3-win32 (GCC) 20200320

As you can see from the prompt, this is the captive ffmpeg distributed with VDH. I have
the real ffmpeg elsewhere on my system but this is what I'm getting from my version of
ffmpeg inside VDH. I have been under the impression that the captive ffmpeg is inside
the CoApp. But I just inspected the CoApp installer application using an unzip
application & there's no ffmpeg in there. So it must be the case that the captive ffmpeg
is actually packaged with the VDH extension. I'm running the latest beta, version
7.6.3a6. You might try that. I've been using it since Michel released it a couple of
weeks ago & it hasn't given me any problems. In fact, it's solved some livestream
problems for me. There's also a few minor mainly cosmetic improvements in it. I say
it's worth a shot.
Reply all
Reply to author
0 new messages