"failed aggregating" message and no download

Skip to first unread message


Dec 9, 2022, 11:33:26 AM12/9/22
to Video DownloadHelper Q&A

Firefox 91.11-0esr on Debian Stretch. User of VDH since more than 2 yrs. Used to download YouTube videos every day, but it no longer works. The download starts, but error message near to the end : "can't assembly..." same msg as reported last night by ....

Have tested new version 7.6.6 as suggested... but the results are the same.

some difference though, download does start and goes on up to near the end, while it showed error close to beginning with later version... it ends up to same result.

Thanks for your efforts


Wild Willy

Dec 9, 2022, 1:55:21 PM12/9/22
to Video Download Helper Google Group
Surprising. Give us some URLs of videos that won't download for you. I'm running
Windows 7 64-bit & Firefox 107.0.1 64-bit with the same VDH (well, I have the beta but
it's the same). I have had no problems downloading from YouTube since it was released a
few days ago. So I'd like to try your videos to see what results I get.

Based on experience, I feel the need to add this. I do not work for VDH. I'm just
another user. Post your response via Reply all, NOT Reply to author. Put your URLs in
here as simple text strings, like https://www.youtube.com/something, If you feel so
inspired, post some screenshots of the process you go through that lead to your errors.

If you already knew all of that, that's good. But like I say, sometimes some users don't
so . . .

Jon Yank

Dec 9, 2022, 10:12:14 PM12/9/22
to Video DownloadHelper Q&A
Baker Mayfield Game Winning Drive.

Difference now is it gets to the end, but fails finalizing.  The message is the same.  I did update to latest version, tried both 1080 and 720. 

How about you giving us an example of a video - a short one - that DOES work for you, so we can compare results.  None work for me, and I've tried various. 

Can't believe he won that game, go figure. 

Wild Willy

Dec 9, 2022, 10:37:49 PM12/9/22
to Video Download Helper Google Group
You're going to love this. I downloaded both the 480p & 1080p variants of the Mayfield
video just fine. Got perfect results. No problem downloading at all.

Here's a thought. When Michel first posted the new release of VDH as a beta, it didn't
work for me. So I reinstalled the previous beta I had been using before. Then I saw
other people saying it was working fine. So I installed the new beta again. The 2
installations were different. The first installation just prompted me for the usual
permissions. The second installation prompted me for the usual permissions AND THEN it
gave me the congratulations screen. I didn't get the congratulations screen at the end
of the first installation. After I got the congratulations screen, everything worked.
When you install this, are you getting a congratulations screen? If not, then you have
not installed the extension completely.

Failing that, I have no idea what could possibly be wrong on your system. But something
has to be wrong because I am using this without problems. But I am not alone. Several
folks posted in another thread that they got it to work fine, too. Are you on Linux?
I'm on Windows so the installation is pretty easy. But I've been reading posts on here
about Linux having Snap & a sandbox & a bunch of other things I don't understand since I
have 0 experience with Linux. You'll have to get somebody else to help you if you're on


Dec 10, 2022, 4:23:50 PM12/10/22
to Video DownloadHelper Q&A
              Below is what I obtained in trying to download a short video of about 7 minutes. As usual (I mean, as it has been for a few days), lhe download goes to near the end (about 99%) then these error messages show, and nothing is downloaded.

[Effacer les rapports] Short content 1212(Détails) <#> Short content 1344(Détails) <#> Impossible d'obtenir des informations du média 'arte - YouTube' dans le fichier '/tmp/vdh-28222C7OnMUGA5lSA.tmp'. Le fichier peut être corrompu.(Détails) <#> arte - YouTube Échec de l'assemblage de « arte - YouTube »(Détails) <#> 1

Échec de l'assemblage de « arte - YouTube » /opt/net.downloadhelper.coapp/converter/build/linux/64/ffmpeg: /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.28' not found (required by /opt/net.downloadhelper.coapp/converter/build/linux/64/libavdevice.so.58) /opt/net.downloadhelper.coapp/converter/build/linux/64/ffmpeg: /lib/x86_64-linux-gnu/libm.so.6: version `GLIBC_2.29' not found (required by /opt/net.downloadhelper.coapp/converter/build/linux/64/libavfilter.so.7) /opt/net.downloadhelper.coapp/converter/build/linux/64/ffmpeg: /lib/x86_64-linux-gnu/libm.so.6: version `GLIBC_2.27' not found (required by /opt/net.downloadhelper.coapp/converter/build/linux/64/libavfilter.so.7) /opt/net.downloadhelper.coapp/converter/build/linux/64/ffmpeg: /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.27' not found (required by /opt/net.downloadhelper.coapp/converter/build/linux/64/libavformat.so.58) /opt/net.downloadhelper.coapp/converter/build/linux/64/ffmpeg: /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.28' not found (required by /opt/net.downloadhelper.coapp/converter/build/linux/64/libavformat.so.58) /opt/net.downloadhelper.coapp/converter/build/linux/64/ffmpeg: /lib/x86_64-linux-gnu/libm.so.6: version `GLIBC_2.29' not found (required by /opt/net.downloadhelper.coapp/converter/build/linux/64/libavcodec.so.58) /opt/net.downloadhelper.coapp/converter/build/linux/64/ffmpeg: /lib/x86_64-linux-gnu/libm.so.6: version `GLIBC_2.27' not found (required by /opt/net.downloadhelper.coapp/converter/build/linux/64/libavcodec.so.58) /opt/net.downloadhelper.coapp/converter/build/linux/64/ffmpeg: /lib/x86_64-linux-gnu/libm.so.6: version `GLIBC_2.29' not found (required by /opt/net.downloadhelper.coapp/converter/build/linux/64/libswresample.so.3) /opt/net.downloadhelper.coapp/converter/build/linux/64/ffmpeg: /lib/x86_64-linux-gnu/libm.so.6: version `GLIBC_2.29' not found (required by /opt/net.downloadhelper.coapp/converter/build/linux/64/libswscale.so.5) /opt/net.downloadhelper.coapp/converter/build/linux/64/ffmpeg: /lib/x86_64-linux-gnu/libm.so.6: version `GLIBC_2.29' not found (required by /opt/net.downloadhelper.coapp/converter/build/linux/64/libavutil.so.56) /opt/net.downloadhelper.coapp/converter/build/linux/64/ffmpeg: /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.28' not found (required by /opt/net.downloadhelper.coapp/converter/build/linux/64/libavutil.so.56) /opt/net.downloadhelper.coapp/converter/build/linux/64/ffmpeg: /lib/x86_64-linux-gnu/libm.so.6: version `GLIBC_2.27' not found (required by /opt/net.downloadhelper.coapp/converter/build/linux/64/libvpx.so.6) /opt/net.downloadhelper.coapp/converter/build/linux/64/ffmpeg: /lib/x86_64-linux-gnu/libm.so.6: version `GLIBC_2.29' not found (required by /opt/net.downloadhelper.coapp/converter/build/linux/64/libvpx.so.6) /opt/net.downloadhelper.coapp/converter/build/linux/64/ffmpeg: /lib/x86_64-linux-gnu/libm.so.6: version `GLIBC_2.29' not found (required by /opt/net.downloadhelper.coapp/converter/build/linux/64/libwebpmux.so.3) /opt/net.downloadhelper.coapp/converter/build/linux/64/ffmpeg: /lib/x86_64-linux-gnu/libm.so.6: version `GLIBC_2.29' not found (required by /opt/net.downloadhelper.coapp/converter/build/linux/64/libwebp.so.7) /opt/net.downloadhelper.coapp/converter/build/linux/64/ffmpeg: /lib/x86_64-linux-gnu/libm.so.6: version `GLIBC_2.27' not found (required by /opt/net.downloadhelper.coapp/converter/build/linux/64/libaom.so.0) /opt/net.downloadhelper.coapp/converter/build/linux/64/ffmpeg: /lib/x86_64-linux-gnu/libm.so.6: version `GLIBC_2.29' not found (required by /opt/net.downloadhelper.coapp/converter/build/linux/64/libaom.so.0) /opt/net.downloadhelper.coapp/converter/build/linux/64/ffmpeg: /lib/x86_64-linux-gnu/libm.so.6: version `GLIBC_2.27' not found (required by /opt/net.downloadhelper.coapp/converter/build/linux/64/libmp3lame.so.0) /opt/net.downloadhelper.coapp/converter/build/linux/64/ffmpeg: /lib/x86_64-linux-gnu/libm.so.6: version `GLIBC_2.29' not found (required by /opt/net.downloadhelper.coapp/converter/build/linux/64/libmp3lame.so.0) /opt/net.downloadhelper.coapp/converter/build/linux/64/ffmpeg: /lib/x86_64-linux-gnu/libm.so.6: version `GLIBC_2.29' not found (required by /opt/net.downloadhelper.coapp/converter/build/linux/64/libopenjp2.so.7) /opt/net.downloadhelper.coapp/converter/build/linux/64/ffmpeg: /lib/x86_64-linux-gnu/libm.so.6: version `GLIBC_2.29' not found (required by /opt/net.downloadhelper.coapp/converter/build/linux/64/libopus.so.0) /opt/net.downloadhelper.coapp/converter/build/linux/64/ffmpeg: /lib/x86_64-linux-gnu/libm.so.6: version `GLIBC_2.29' not found (required by /opt/net.downloadhelper.coapp/converter/build/linux/64/libvorbis.so.0) /opt/net.downloadhelper.coapp/converter/build/linux/64/ffmpeg: /lib/x86_64-linux-gnu/libm.so.6: version `GLIBC_2.27' not found (required by /opt/net.downloadhelper.coapp/converter/build/linux/64/libx264.so.161) /opt/net.downloadhelper.coapp/converter/build/linux/64/ffmpeg: /lib/x86_64-linux-gnu/libm.so.6: version `GLIBC_2.29' not found (required by /opt/net.downloadhelper.coapp/converter/build/linux/64/libx264.so.161) /opt/net.downloadhelper.coapp/converter/build/linux/64/ffmpeg: /lib/x86_64-linux-gnu/libm.so.6: version `GLIBC_2.29' not found (required by /opt/net.downloadhelper.coapp/converter/build/linux/64/libx265.so.188) /opt/net.downloadhelper.coapp/converter/build/linux/64/ffmpeg: /lib/x86_64-linux-gnu/libm.so.6: version `GLIBC_2.27' not found (required by /opt/net.downloadhelper.coapp/converter/build/linux/64/libxvidcore.so.4) /opt/net.downloadhelper.coapp/converter/build/linux/64/ffmpeg: /lib/x86_64-linux-gnu/libm.so.6: version `GLIBC_2.29' not found (required by /opt/net.downloadhelper.coapp/converter/build/linux/64/libxvidcore.so.4)



Dec 10, 2022, 6:21:19 PM12/10/22
to Video DownloadHelper Q&A
Looks like a GLIBC issue with your system. What version of GLIBC is in your Linux and what version of coapp was installed?

Wild Willy

Dec 10, 2022, 6:42:29 PM12/10/22
to Video Download Helper Google Group
Good eyes, mjs! I didn't look at the error messages that closely. I just went to the
page & started downloading. YouTube first presented VDH the 480p variant. For some
reason, the default resolution I get on YouTube is always 480p. After I've changed
resolutions on a video, any subsequent video I look at gets whatever resolution I changed
the first video to. But after I close all browser windows, the next YouTube video I
visit is back at 480p again. I hate it but I haven't seen any way to change that. In
any case, VDH happily downloaded the 480p variant without a problem. It played in VLC
all the way through, both video & audio, to the end, although I just sampled it. I
didn't sit & watch it. Then I changed resolution to 1080p & once again, VDH got the
whole thing. This is on Windows 7 64-bit, Firefox 107.0.1 64-bit, licensed VDH 7.6.5a3
beta, CoApp 1.6.3.


Dec 11, 2022, 4:56:05 AM12/11/22
to Video DownloadHelper Q&A
GLIBC version is 2.24-11
net.downloadhelper.coapp 1.6.3
Video DownloadHelper upgraded a few days ago to v 7.6.6 in an attempt to solve the 'not aggregating' problem that had arised a few days before.


Dec 11, 2022, 5:24:02 AM12/11/22
to Video DownloadHelper Q&A
There are a few Linux installers of the companion app and they all have different versions of GLIBC. You must have installed one with a higher version than 2.24 and when that happens it encounters a problem. There is a version with GLIBC 2.23 which you should install and see if it helps.


Dec 11, 2022, 1:05:14 PM12/11/22
to Video DownloadHelper Q&A
Thanks mjs for your reply. But I don't know where to find the companion app installer that would comply with GLIBC 2.23. The only one that I've been able to find so far is the one that I have installed a few days ago

Wild Willy

Dec 11, 2022, 2:52:48 PM12/11/22
to Video Download Helper Google Group
Installing the CoApp on Linux is not particularly straightforward or clear. We had a
lengthy discussion of it elsewhere rather a while ago. To find it, start here:


There are 2 references in there that I want to point out. You will be doing string
searches for 2 different strings within the text of that web page.

First, do a search for "various pieces" within the text of that web page. That will
reposition the page on a reference that contains a link. Click the link & read what you
find. That will allow you to find a link to a page for installing the latest version of
the CoApp. That may be most helpful. That will also allow you to find a link to a page
the contains a more concise listing of all the CoApp versions, current & past.

Second, do another string search for "byzantine" within the text of that same web page.
That will reposition the page on a reference that contains a link. Click the link & see
if anything in there makes any sense to you.


Dec 11, 2022, 7:19:58 PM12/11/22
to Video DownloadHelper Q&A
Then click other system installers. Look for Linux 64 bits deb. It might be hard to see, there is one labelled GLIBC 2.23
That's the one to install.

Wild Willy

Dec 11, 2022, 8:12:12 PM12/11/22
to Video Download Helper Google Group
I feel compelled to explain something. I don't usually just hand out a straight answer
around here. It's not because I'm being a smart-ass. Let me explain myself.

I like to include a reference to the Table of Contents thread whenever I possibly can.
The truth is that the VDH web site has basically useless documentation on how to use VDH.
Their examples are based on a version that is several years out of date. At least the
Table of Contents points you to a tutorial that uses a version that looks like what you
would get using the current version. I want to put the Table of Contents into the hands
of the most people possible so they have the next best thing to the user's manual that
doesn't exist.

Beyond that, this is an international self help cooperative of volunteers. Self help.
Self. People should get in the habit of helping themselves. Some people have spent
great amounts of time, put in great effort, to explain things so others can benefit from
their experience. Newbies coming in here should learn to put in some effort themselves.
The effort is simply to find the answers to their problems by searching this group. The
group is hosted . . . where? What site is this? What is the bread & butter of this
site? Do some searches. Don't flatter yourself that you have discovered a brand new
problem. It is almost certain that somebody else has already encountered your problem &
the solution to your problem is already given here. Don't insult the people who did all
that work. Look for their answers. That's why this site exists: so you can find your
answers that are already here. There are over 9000 threads on here as of the moment I
write this. You have to believe that the answers you seek are already here.

My philosophy behind this is inspired by the old proverb. Give a man a fish & he won't
be hungry today. Teach a man to fish & he won't be hungry for the rest of his life.
That's why I don't just hand out answers. I'm trying to teach people how to fish for
their own answers to their VDH problems.


Dec 13, 2022, 6:32:10 AM12/13/22
to video-download...@googlegroups.com
I did just that and installed the coApp meant for my version of GLIBC...
and it solved the problem. This was done a few days ago, but for some
reason I can no longer write into the google group, so I am mailing this
message, hoping that it gets there.
Thanks a lot for your help.

Wild Willy

Dec 13, 2022, 1:19:09 PM12/13/22
to Video Download Helper Google Group
That is excellent news that you solved your problem. But it is not so excellent news
that you're having trouble posting. E-mail is how I post almost all the time, this post
being an example. I don't usually log in here unless I'm posting something in which I
want to alternate text with embedded images. You can't do that via E-mail. But you can
attach files to posts via E-mail.

I wonder if your problems posting have anything to do with stealth quoting. You can get
rid of stealth quotes by following another reference in that Table of Contents thread.
Search for "stealth quote" within the text of the Table of Contents & you'll find a
reference with a link. Go read that & you'll learn about stealth quoting, a particularly
annoying procedure that Google foists upon you, usually without your knowledge.

pooya khan

Jan 27, 2023, 11:44:27 PMJan 27
to Bernard, video-download...@googlegroups.com
I have re installed it but had no luck. Thanks for writing

You received this message because you are subscribed to the Google Groups "Video DownloadHelper Q&A" group.
To unsubscribe from this group and stop receiving emails from it, send an email to video-downloadhelper...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/video-downloadhelper-q-and-a/b640a8cd-d2e3-73a2-4042-29961568f70c%40teaser.fr.
Reply all
Reply to author
0 new messages