Needs To Be Updated

72 views
Skip to first unread message

Smallwheels

unread,
May 8, 2022, 8:24:58 AMMay 8
to Video DownloadHelper Q&A
May 8 2022. I use the Brave Browser and the Firefox browser on PoP!_OS (GNU/Linux). On all systems and computers today the DownloadHelper didn't work. It wants the companion app installed. I downloaded it in Deb and GZ. Neither worked. When using the Tar it was required to enter the information into the terminal. I tried all commands and all failed. 

I even went to use this on my Chromebook. The same message happened. It wants the companion app installed. ON BOTH computers this app previously worked. Something has changed and now it is not working. Please look into this and make the changes that will get this working. I really love the extension when it works. Thanks. 

Wild Willy

unread,
May 8, 2022, 4:01:33 PMMay 8
to Video Download Helper Google Group
You might find some help over here:

https://groups.google.com/g/video-downloadhelper-q-and-a/c/BzPLK2YyL-s

There are many links in there that you will probably find useful over time. Specific to
this problem, first let's talk about Brave. Brave is not a supported browser. Click the
link I just gave & do a string search on "philosophy" in there. You'll find a link to a
discussion of the VDH license in there. Along the way, you'll see that Brave is not
supported. If you have it working, great, but you're on your own with that. Firefox is
supported.

Next, do a string search on "linux" in that other thread. There are several hits on that
search key so don't just stop on the first one. Each hit gives you a link which you
should click. Read up on what's there. Perhaps there will be some useful help in one of
those discussions.

Do please post here again telling us what progress you make.

McBobby

unread,
May 10, 2022, 1:46:07 AMMay 10
to Video DownloadHelper Q&A
Now, I'm just a user, not an expert, but why not just install the companion app? It's safe, small, barely uses any  system resources and frankly, downloads faster than most browsers do.

If this isn't the issue, then feel free to disregard, but I honestly don't get what some users have against installing the companion app.

mjs

unread,
May 10, 2022, 3:04:37 AMMay 10
to Video DownloadHelper Q&A
I think that is what they want to do , but they haven't done the right thing by leaving important information out in order to work out what the problem is. They haven't stated : what version of Pop_OS is in use, what package manager it uses and what processor architecture the computer
uses. So I looked it up myself.

Versions 17.10 and 18.04 used both DEB (apt) and snap for package management. The Coapp doesn't work with snap apps.
Those versions are old now from 2017 and 2018.

The two most recent versions 21.10 and 22.04  are DEB (apt) only so it should work. But the processor architecture says ARM64 and x86_64
I'm not sure the Coapp is designed for ARM64 , now it's up to the original poster provide the required information.
--
A vdh user

Wild Willy

unread,
May 10, 2022, 9:07:16 AMMay 10
to Video Download Helper Google Group
Are we looking at yet another of these drive-by problem reports? Is this another among
the disappointingly large number of users who drop reports on here & then don't post
again after getting advice? I hope not.

On the subject of processor architecture, Intel vs AMD vs ARM vs whatever else there may
be, it is my understanding that one of the purposes of an operating system is that it
insulates any application from such worries. I do not believe there are any processor
dependencies within VDH or the CoApp. They run on Windows/Max/Linux on any CPU type
there is. The file names that have certain character strings in them that seem to imply
some processor dependency are, I believe, misleading. I would love it if Michel would
come in here & either confirm or deny what I'm saying.

mig

unread,
May 11, 2022, 4:56:15 AMMay 11
to Video DownloadHelper Q&A
It's not exactly that but i'll try to explain compatibilities and incompatibilities.

The overall Video DownloadHelper product is made of 2 parts, the browser extension and the coapp. In very simple cases (the web site provides an URL to download the complete video), the coapp is not necessary but given the evolution of web streaming technologies, this now happens rather seldomly.

The extension itself is only browser-dependent. Officially, it runs on Firefox (Windows, Linux, Mac, not Android/iOS), Chrome (Windows, Linux, Mac, not Android/iOS) and Edge (Windows). It might run on other browser/platform combinations (Brave, Edge/Linux, TorBrowser, ...) sometimes with a little bit of tuning (setting up manifest files to access the coapp). But it is processor-agnostic, i.e if the browser is supported, it will be able to run the extension whatever processor it is running on. The reason is that browsers run extensions written in a high level language, javascript, and have the ability to execute javascript programs.

The companion app is both OS and processor dependent. The only supported processors are Intel/AMD, 32 and 64 bits. There is a special case of Apple ARM M1 processor that is supported because Apple provides some kind of processor bridge called Rosetta.

On Windows, the installer file contains both 32 and 64 versions and is smart enough to automatically pick the correct one at install time.

On Mac, there is only Intel/AMD 64 bits and ARM M1 (through Rosetta). The coapp installer exists in 2 versions, PKG (the preferred way) and DMG (which requires an additional step to setup the manifest files at the correct locations).

On Linux, both Intel/AMD 32 and 64 bits versions exist and you have to pick the correct one. The install packages might be in .deb (for Ubuntu and Debian) and .tar.gz (all distributions). One tricky thing may be the GLIBC (the main general purpose OS library) version: if you try to execute a version of the coapp that has been compiled with a certain version of the GLIBC, on a old Linux distro that has a former GLIB version, it won't work. This is why, for those users, we provide builds of the coapp for GLIBC 2.23 and 2.27. Assuming you are running an up-to-date Linux, the default coapp runs with GLIBC 2.31.

There is currently an issue with latest distributions of Ubuntu. The latest distro version, 22.04, installs Firefox using a new method called snap. It makes the browser run in an isolated sandboxed environment. This might be good for security but then, the browser cannot access the coapp (which is installed out of this sandbox). Mozilla is aware of this issue and should be working on a fix. For now, the workaround consists of installing Firefox manually from a package downloaded from https://ftp.mozilla.org/pub/firefox/releases/

Hope this helped understanding what works with what.
Reply all
Reply to author
Forward
0 new messages