Filters not working for VersionOne JIRA interface

63 views
Skip to first unread message

Michael Stewart

unread,
Mar 27, 2014, 2:24:33 PM3/27/14
to version...@googlegroups.com
Successfully configured VersionOne Interface 8.3 with JIRA 5.1.2.  However, when using a Filter for Story and Defect, the interface fails to start up when an issue is in one of the filters.  If the Filters contain no issues, the interface starts just fine.  Below is the Error.  Notice how the first filter succeeds and the second filter fails.  This is the because the first filter contains no issues.  Any assistance would be greatly appreciated!

C:\V1JiraIntegration.8.3>VersionOne.ServiceHost.exe
Loaded VersionOne.ServiceHost.Core.Logging.LogService, VersionOne.ServiceHost.Core.
Loaded VersionOne.ServiceHost.Core.Services.TimePublisherService,VersionOne.ServiceHost.Core.
Loaded VersionOne.ServiceHost.JiraServices.JiraHostedService, VersionOne.ServiceHost.JiraServices.
Loaded VersionOne.ServiceHost.Core.Services.TimePublisherService, VersionOne.ServiceHost.Core.
Loaded VersionOne.ServiceHost.WorkitemServices.WorkitemWriterHostedService, VersionOne.ServiceHost.WorkitemServices.
[INFO] 27-03-2014 18:10:43 Initialized LogService
[INFO] 27-03-2014 18:10:43 Initializing ProfileFlushTimer
[INFO] 27-03-2014 18:10:43 Initialized ProfileFlushTimer
[INFO] 27-03-2014 18:10:43 Initializing JiraHostedService
[INFO] 27-03-2014 18:10:44 Initialized JiraHostedService
[INFO] 27-03-2014 18:10:44 Initializing TimePublisherService
[INFO] 27-03-2014 18:10:44 Initialized TimePublisherService
[INFO] 27-03-2014 18:10:44 Initializing WorkitemWriterHostedService
[INFO] 27-03-2014 18:10:44 Initialized WorkitemWriterHostedService
[INFO] 27-03-2014 18:10:44 Validating connection to VersionOne
[INFO] 27-03-2014 18:10:44     VersionOne URL: https://www5.v1host.com/Ooyala/
[INFO] 27-03-2014 18:10:44     Using proxy server: False, Integrated authentication: False
[INFO] 27-03-2014 18:10:44     VersionOne Meta version: 14.0.6.6700
[INFO] 27-03-2014 18:10:44     VersionOne Member OID: Member:4558
[INFO] 27-03-2014 18:10:44     VersionOne Member default role: Project Lead
[INFO] 27-03-2014 18:10:44 Connection to VersionOne is established successfully
[INFO] 27-03-2014 18:10:45 Checking JIRA Project mappings.
[INFO] 27-03-2014 18:10:45 JIRA Project mappings are checked.
[INFO] 27-03-2014 18:10:45 Checking JIRA Priority mappings.
[INFO] 27-03-2014 18:10:45 JIRA Priority mappings are checked.
[INFO] 27-03-2014 18:10:45 Checking VersionOne projects
[INFO] 27-03-2014 18:10:45 All projects are checked
[INFO] 27-03-2014 18:10:45 Checking custom fields.
[INFO] 27-03-2014 18:10:46 Checking customfield_13241 field.
[INFO] 27-03-2014 18:10:46 All fields checked.
[INFO] 27-03-2014 18:10:46 Checking JIRA filter.
[INFO] 27-03-2014 18:10:47 JIRA filter is checked.
[INFO] 27-03-2014 18:10:47 Checking JIRA filter.
[ERROR] 27-03-2014 18:10:48 Can't find 20554 filter.
[ERROR] 27-03-2014 18:10:48 Event Manager Caught Unhandled Exception
VersionOne.ServiceHost.Core.StartupValidation.ValidationException: Validation error during service initialization.
   at VersionOne.ServiceHost.Core.StartupValidation.ValidationSimpleStep.Run()
   at VersionOne.ServiceHost.Core.StartupValidation.StartupCheckerBase.Run(Object obj)
   at VersionOne.ServiceHost.Eventing.EventDelegate.Invoke(Object pubobj)
   at VersionOne.ServiceHost.Core.Eventing.EventManager.Publish(Object pubobj)
[INFO] 27-03-2014 18:10:49 Validation error during service initialization.
VersionOne.ServiceHost.Core.StartupValidation.ValidationException: Validation error during service initialization.
   at VersionOne.ServiceHost.Core.StartupValidation.ValidationSimpleStep.Run()
   at VersionOne.ServiceHost.Core.StartupValidation.StartupCheckerBase.Run(Object obj)
   at VersionOne.ServiceHost.Eventing.EventDelegate.Invoke(Object pubobj)
   at VersionOne.ServiceHost.Core.Eventing.EventManager.Publish(Object pubobj)
   at VersionOne.ServiceHost.CommonMode.Startup()
   at VersionOne.ServiceHost.ConsoleMode.InternalRun()
   at VersionOne.ServiceHost.ConsoleMode.Run()
Press enter to close...

Nivedita Nair

unread,
Jul 29, 2014, 1:59:24 PM7/29/14
to version...@googlegroups.com
Hi,

Could you let me know if this issue was resolved and how you got it working? I am currently facing this same error.

Thank you.
Regards,
Nivi

Nivedita Nair

unread,
Jul 30, 2014, 3:56:10 PM7/30/14
to version...@googlegroups.com
We were facing this same issue with our VersionOne Jira Integration Service.

To Debug:
We started the service and examined the response XML from JIRA and saw that it was malformed. The description tags were broken. We logged into the GUI and verified the 'description' field for all queued JIRA issues looking for anything strange.We found one JIRA issue with random special characters in the 'description' field. JIRA was not parsing those correctly resulting in malformed XML responses which was causing the integration service to fail.
Solution:
Once we removed the special characters we were able to successfully restart the integration service.


Regards,
Nivi

On Thursday, March 27, 2014 11:24:33 AM UTC-7, Michael Stewart wrote:
Reply all
Reply to author
Forward
0 new messages