utgb-shell-1.2.0 再インストールしてのエラー

46 views
Skip to first unread message

Nakazato T.

unread,
Feb 27, 2009, 1:45:04 AM2/27/09
to utgb-u...@googlegroups.com
なかざと です。

別マシンに utgb を入れて動かしてみようと思い、やってみたのですが、
compile などする際にエラーになるので報告します。

MacでもLinux(CentOS)でも出ました。

$ wget http://maven.utgenome.org/repository/artifact/org/utgenome/utgb-shell/1.2.0/utgb-shell-1.2.0-package.zip
して、unzip
環境変数など設定
$ utgb create hoge
(これはうまくいく)
$ utgb compile
java.io.IOException: Cannot run program
"/Users/nakazato/local/utgb-shell-1.2.0/maven/bin/mvn": error=13,
Permission denied
(Java 1.6の場合)
java.io.IOException:
/Users/nakazato/local/utgb-shell-1.2.0/maven/bin/mvn: cannot execute
(Java 1.5の場合)

Ctrl-C で止めないと行けない状況に

clean, eclipse でも同様でした


昔に(12月)ダウンロードしたのがあってそれでは動くので、一応、自分は先に進められますが。

自分の設定が悪いのかもしれませんが、一応、ご報告まで。

Taro L. Saito

unread,
Feb 27, 2009, 2:03:57 AM2/27/09
to utgb-u...@googlegroups.com
中里さん

報告ありがとうございます。こちらでも同様の現象が確認できました。

> chmod +x /Users/nakazato/local/utgb-shell-1.2.0/maven/bin/mvn
としてみると良いようです。



Taro L. Saito
<l...@cb.k.u-tokyo.ac.jp>
University of Tokyo
Tel. +81-47-136-4065 (64065)




2009/2/27 Nakazato T. <chal...@gmail.com>:

Nakazato T.

unread,
Feb 27, 2009, 2:17:41 AM2/27/09
to utgb-u...@googlegroups.com
さいとうさん

素早い対応、ありがとうございます。
動きました。

すごく単純な理由で恐縮です。



2009/02/27 16:03 Taro L. Saito <l...@cb.k.u-tokyo.ac.jp>:

Taro L. Saito

unread,
Feb 27, 2009, 2:23:59 AM2/27/09
to utgb-u...@googlegroups.com
中里さんに報告してもらったものも含め、いくつかバグの修正があったので、
utgb-shell-1.2.1をリリースしました。

http://utgenome.org/releases.html

こちらを使うと、utgb-track-baseのversionを1.4.4から1.4.6に直すなどの作業が不要です。

Taro L. Saito
<l...@cb.k.u-tokyo.ac.jp>
University of Tokyo
Tel. +81-47-136-4065 (64065)




2009/2/27 Taro L. Saito <l...@cb.k.u-tokyo.ac.jp>:

Taro L. Saito

unread,
Feb 27, 2009, 2:27:50 AM2/27/09
to utgb-u...@googlegroups.com
>すごく単純な理由で恐縮です。

ビルドの自動化システムが、utgb-shell-1.2.0-pacakge.zipのファイルで、
リリース時(1月)には正常に動いていたものを、2月に上書きしてしまい、
おかしなことになってしまったようです。

新しくリリースしたutgb-shell 1.2.1を使うようにしてください。

Nakazato T.

unread,
Feb 27, 2009, 2:53:41 AM2/27/09
to utgb-u...@googlegroups.com
Mac でコンパイル → サーバー立ち上げ まで動きました。 :)


2009/02/27 16:27 Taro L. Saito <l...@cb.k.u-tokyo.ac.jp>:

Taro L. Saito

unread,
Feb 27, 2009, 2:58:00 AM2/27/09
to utgb-u...@googlegroups.com
動作確認ありがとうございます。

今回の報告のように、どのような手順でエラーが再現できたかを報告してくれると、
とても助かります。

# 良いプログラマと同じくらい、良いテスターの存在も大切です
Reply all
Reply to author
Forward
0 new messages