Activation of Amara's new subtitle editor - heaps of subtitles deleted

27 views
Skip to first unread message

Claude Almansi

unread,
Jun 29, 2013, 9:13:06 AM6/29/13
to universal-subt...@googlegroups.com
Today, Amara was "unavailable for scheduled maintenance" for several hours.
When it became available again:
  1. the option to use the beta new subtitle editor had been added to the "Sync" phase of the widget
  2. heaps of subtitles, or of the later revisions of subtitles, had been deleted.

I can't be sure that 1 caused 2, but it certainly looks like it, in view of what Dean Jansen wrote on June 17, 2013 about a new data model that makes the new editor possible in the Amara: please address severe longstanding issues discussion, in spite of his previous affirmation on June 14 that "We are done with the data model and are basically ready to launch, but are waiting on a few partners to make the necessary confirmation tests and modifications to ensure a smooth transition".

A My subtitles are gone thread was started by Mami Kawade on the Amara help forum 5 hours ago, reporting about deleted last revisions in a TED team video. Since then, 5 other users have reported deletions, either of last revisions or of whole subtitles.

As Amara developers are responsible for these deletions, could they please immediately go and explain what happened and how they're fixing it in that My subtitles are gone  thread? Or possibly, Dean Jansen, if the developers are too busy fixing that mess. But the developers would be better.

And then, make an announcement about the deletions on top of all Amara pages, linking to the My subtitles are gone  thread on top of ALL Amara pages.

Also: if a maintenance is scheduled as this one purported to be, announce it in the Updates and News board of the help forum with an explanation of what it will involve, as Jules Rincón used to do and again, link to the announcement on top of all Amara pages.

In general: when Amara developers are cooking up new stuff, stop doing so behind Amara users' back, tell them in the help forum and involve them in the testing, please!

Claude

Nicholas Reville

unread,
Jun 29, 2013, 10:16:58 AM6/29/13
to universal-subt...@googlegroups.com
Hi Claude,

The upgrade went well over night but we're still restoring some of the data-- stay posted and sorry for the inconvenience!

npr





--
You received this message because you are subscribed to the Google Groups "Amara – Deaf & Hard of Hearing Discussion List" group.
To unsubscribe from this group and stop receiving emails from it, send an email to universal-subtitles-...@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.
 
 

Claude Almansi

unread,
Jun 29, 2013, 10:33:02 AM6/29/13
to universal-subt...@googlegroups.com
On Sat, Jun 29, 2013 at 4:16 PM, Nicholas Reville wrote:
> Hi Claude,
>
> The upgrade went well over night but we're still restoring some of the
> data-- stay posted and sorry for the inconvenience!
>

Please go post that yourself in the
http://support.amara.org/support/discussions/topics/24667 help forum
thread, Nicholas.

I've messaged the Captions Requested and Music Captioning teams about
it: Esther Garau had re-started the original Italian subs of an over
3-hour long video (added to Captions Requested) where these and other
complete subs in 4 more languages had been deleted.

And for hell's sake, in future, ANNOUNCE your scheduled maintenances
and what glitches they might entail beforehand.

Best

Claude

Claude Almansi

unread,
Jul 6, 2013, 11:14:18 AM7/6/13
to universal-subt...@googlegroups.com


On Saturday, June 29, 2013 4:33:02 PM UTC+2, Claude Almansi wrote:
On Sat, Jun 29, 2013 at 4:16 PM, Nicholas Reville  wrote:
> Hi Claude,
>
> The upgrade went well over night but we're still restoring some of the
> data-- stay posted and sorry for the inconvenience!
>

Please go post that yourself in the
http://support.amara.org/support/discussions/topics/24667 help forum
thread, Nicholas.

(...)

Thanks for the resoration  of the apparently deleted subtitles and for having sent "Janet" to reply as "PCF Support" to the relevant thread on the help forum.

However, the last upgrade also deleted all line breaks in existing subtitles, banging together the words before and after the former line brea, and made it more difficult to insert new ones. Heaps of subtitles have been affected, including those Darren Bridenbeck uploaded to the videos of the Indepedent Film Workgroup team. See CC's What happened to all the LINE BREAKS within subtitles? They're all gone now. Does it have to do with the upgrade?  topic on the help forum.

Please fix this issue and again, if you have comments or questions about it, don't write them in a reply here but in a comment to CC's topic on the help forum: that's where issue potentially affecting all Amara users must be discussed.

Nicholas Reville

unread,
Jul 10, 2013, 5:56:55 PM7/10/13
to universal-subt...@googlegroups.com
Hi Everyone,

The linebreaks issues should be fixed now.

Thanks,

nicholas

Claude Almansi

unread,
Jul 11, 2013, 2:44:07 AM7/11/13
to universal-subt...@googlegroups.com
Hi Nicholas

Re:

On Wed, Jul 10, 2013 at 11:56 PM, Nicholas Reville wrote:
>
> Hi Everyone,
>
> The linebreaks issues should be fixed now.

Thanks for trying. However line breaks are still replaced by banged
together words in the English subtitles -both in the player and in the
generated transcripts appearing in the English subtitle pages - of

1. http://www.amara.org/videos/mR3iGd5jpr0w/info/part-1-evolving-role/
(the example mentioned by CC in the
http://support.amara.org/support/discussions/topics/25104 topic I
mentioned in the 1st message of this thread - all revisions that had
linebreaks are also affected)

2. "BigGayMusical 178 16x9 2398 en8CH source V1 H1 PROXY WMProxy"

I can't give the URL for that second one because it is a video of the
private Independent Film - Workgroup team. The issue also seems to
persist for all other English subtitles Darren Bridenbeck uploaded to
other videos of that team (I only checked the generated transcripts in
their English subtitles pages).

Interesting thing, maybe: I now checked the English subs for
http://www.amara.org/videos/WycX2RjvQgz3/info/jonathan-coulton-first-of-may-asl-song/
and their revisions.
When the video was added to Amara on May 2, 2012, Amara didn't yet
support line breaks, so the original line breaks got deleted in the
subs pumped from YouTube.
Then on July 22, 2012, I noticed that Amara had started supporting
line breaks - see
http://support.amara.org/support/discussions/topics/5525 - so on the
same day, I reintroduced the line breaks in these English subtitles.
And these line breaks were not deleted by the last upgrade.

So it seems that the line break deletion of the last upgrade did not
affect all subtitles that had them, and that maybe it only affected
those made after a certain date. Maybe this can be of help in really
fixing this issue?

It doesn't really matter for the English subtitles uploaded to videos
of the private Independent Film - Workgroup team because they'll never
get shown publicly - or at least, one should hope not, as they already
had several other issues. But it does a lot for other subtitles where
the Amara videos are public, and at times embedded in web pages: not
good for users. nor for Amara's image.

Claude Almansi

unread,
Jul 28, 2013, 8:03:25 PM7/28/13
to universal-subt...@googlegroups.com
New help forum about the line breaks issue: Subtitles missing spaces?, about for instance the English subtitles of "Capitalism and Socialism: Crash Course World History #33".


On Wed, Jul 10, 2013 at 11:56 PM, Nicholas Reville  wrote:
Reply all
Reply to author
Forward
0 new messages