To support operations on certain quantities like Temperature we want to introduce a classification to improve and correct calculations on particular quantities.
So far we have one vote each. The general naming pattern by the JDK itself and other frameworks would suggest "MeasurementLevel", but in documents it is often referred as "Level of Measurement". So both could work, but the Wikipedia article itself start with a big caveat: "Not to be confused with Units of measurement
" thus I would also prefer MeasurementLevel here, although we used SystemOfUnits for another SPI element, but that explicitly deals with multiple units rather than just a single unit.
Please vote, I know there is Oracle Code One coming up next week, so unless a large number of votes for either option makes it clear where preferences lie, let's keep the vote up till the end of next week after OC1 and ECE.