Console output garbled

13 views
Skip to first unread message

don...@lue-forsyth.co.uk

unread,
Sep 25, 2022, 1:58:25 PMSep 25
to UniBone
Hi all,

I have my unibone working and I have worked through the memory checks on my memory card and all was ok.

I have been logging on using SSH. But next I wanted to emulate a cpu using the memory card and so tried to logon via the serial console.  After waiting the usual time I get nothing but garbage on the screen.

I have tried using serial tools on my MacBook, using PuTTy on Windows and using a VT132. The result is always the same.

I tried logging on with no other card on the backplane with no change.

I tried varying the stop bits, parity and baud rate - but nothing made any difference.

I have checked out the connections to the Maxim3232 and the voltages are correct and the connections to the BBB from the Max3232 are also ok. I cannot see from the schematics that there is anything else in the circuit.

I have tried different cables but again no difference

I have a serial cable connected to UART1 with a nul modem connector.

I have attached photos of the output on the MacBook and on the VT132.  

How do others have this setup - do I have to do this via Linux.  I have linux but couldn't get minicom to respond. 

Can anyone throw any light on this?

thanks for any help
donald
IMG_6482.jpg
IMG_6481.jpg

Jay Jaeger

unread,
Sep 25, 2022, 4:29:28 PMSep 25
to UniBone
Normally UART1 is running a Linux "getty" process, automaticall logged in.  If you do

ps -ef | grep getty

You should see it (ttyS1).

Terminal should be set for 9600 bps, NO parity, ONE stop bit.  (9600 8 N 1)

The null modem is correct

Note that the pinouts on the two UART 10 pin connectors are NOT, I say NOT "PC Typical".  I made my own.  

Ribbon Pin  =>   DB9: 1=>1,   2=> 6,   3=> 2,   4 => 7,   5 => 3,   6 => 8,  7 => 4,  8 => 9,  9 => 5

Suggest you check that particular cable, against the PC-standard DB9 connector and the pinouts on the schematic.

JRJ

cub...@gmail.com

unread,
Sep 25, 2022, 4:37:07 PMSep 25
to don...@lue-forsyth.co.uk, UniBone
Also note that if you are emulating a DL11 running on the unibone PDP 1120 then you use UART number two And you run the demo Scripts that have DL 11 in their names.

Sent from my iPad

On Sep 25, 2022, at 12:58, don...@lue-forsyth.co.uk <don...@lue-forsyth.co.uk> wrote:

Hi all,
--
You received this message because you are subscribed to the Google Groups "UniBone" group.
To unsubscribe from this group and stop receiving emails from it, send an email to unibone+u...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/unibone/f39e8f7a-320f-40e0-86ea-be12a15f33b6n%40googlegroups.com.
IMG_6482.jpgIMG_6481.jpg

Joerg Hoppe

unread,
Sep 26, 2022, 1:39:57 AMSep 26
to UniBone
Hi,

this looks strange.

seems you excluded all the typical RS232 error sources.
More testing ideas:
- Yes, the RS232 is not "PC-style", instead made with crimp connectors and flat cable.
- Start with a fresh SDcard image, from http://files.retrocmp.com/qunibone/sdcard_unibone_2021_03_05.dd.gz
The Linux-login on UART1 is 96008N1
- Test the RS232-signal path including the Maxims:  plugout the BeagleBone, apply 3.3V to the Unibone,
connect MAX3232 pins 11 and 12. Then UART1 should loopback whatever you type into your MacBook-Terminal.
- If possible, change the BeagleBone.

Joerg

donald forsyth

unread,
Sep 26, 2022, 5:42:18 AMSep 26
to Joerg Hoppe, Jay Jaeger, UniBone
Joerg, Jay,

It was the cable.  I had built the cable from the kit, but I didn’t have a male-female null modem connector so I used a pc cable.

I have the right null modem connector now and it worked straight away.

many thanks for your assistance
donald

-- 
You received this message because you are subscribed to the Google Groups "UniBone" group.
To unsubscribe from this group and stop receiving emails from it, send an email to unibone+u...@googlegroups.com.
Reply all
Reply to author
Forward
0 new messages