Self assembbled QBone does not boot BBB

31 views
Skip to first unread message

Dennis McAvr

unread,
Jul 13, 2022, 10:22:40 AMJul 13
to UniBone
Hello all,

I have finished assembling my QBone board, but it seem to have an issue
when applying power - the BBB does not boot for unknown reason.

I tried to check simple things first without having inserted the board into a backplane yet, so only +5V Power is applied via the Connector J8 and LAN is connected to BBB.

What happens:
Power consumption is about 170mA, I hear relay clicking after about 1 second, D2/3.3V lights for about 0.5 seconds, also the blue power LED on the BBB,
then both LEDs go off and nothing happens anymore (relay is not switching off).

If I apply additionaly power to the BBB via its USB connector,
the BBB boots up into the custom Debian, and I can run these
./update-*.sh scripts with no errors.

But It looks that I then cannot access the EEPROM:

root@qbone:~# hexdump -C /sys/bus/i2c/devices/2-0054/eeprom  
00000000  ff ff ff ff ff ff ff ff  ff ff ff ff ff ff ff ff  |................|
*
00008000

This seems to be not correct content according to acceptance test page.

The board LEDs can be switched on and off with the tg tool.

TG>>>1 0
 1) LED0        = 0  ||   2) LED1        = 1  ||   3) LED2        = 1
 4) LED3        = 1  ||   5) SW0         = 0  ||   6) SW1         = 0
 7) SW2         = 0  ||   8) SW3         = 0  ||   9) BUTTON      = 0
10) REG_ENABLE  = 1  ||  11) BUS_ENABLE  = 0  ||  12) PANEL_RESET = 0
13) QUNIBUS_LED = 1

TG>>>1 1
 1) LED0        = 1  ||   2) LED1        = 1  ||   3) LED2        = 1
...

Maybe I have not inserted all required jumpers correctly?
Here is an image of jumpers I have added (attaching to the post failed somehow):

http://www.spurtikus.de/posts/misc/IMG_20220713_153829.jpg

Any ideas or hints what to check next?
Dennis

Dennis McAvr

unread,
Jul 14, 2022, 9:22:45 AMJul 14
to UniBone
Hi again, 
meanwhile I found out that I can access EEPROM, it is just empty and have loaded the cape.eeprom file into it.
After a reboot that works:

root@qbone:~# cat /sys/devices/platform/bone_capemgr/slots
0: P-----  -1 UniBone,00B0,Hoppe,UniBone
1: PF----  -1  
2: PF----  -1  
3: PF----  -1  
4: P-O-L-   0 Override Board Name,00B0,Override Manuf,UniBone

But still the issue that the board is not booting with power on connector J8 only. Booting is only possible when applying power to both J8 and the Mini-USB of BBB. 

Dennis

Dennis McAvr

unread,
Jul 15, 2022, 2:44:47 AMJul 15
to UniBone
Problem solved, was my fault.
I had the current limiting of my power supply to 200 mA, which is not enough for the boot. After setting it to a higher value, everything worked well.
During boot I see values of up to 580 mA, and when the boot process is finished, of about 460 mA. Just for the records.
Dennis

Reply all
Reply to author
Forward
0 new messages