Qbone

34 views
Skip to first unread message

Cliff Miller

unread,
Oct 1, 2022, 10:34:30 AMOct 1
to UniBone
Trying to decide if the Qbone is the best present I ever gave myself and I haven't even put it in a backplane yet - having a ball connecting via ssh and the uart connector, testing the i/o's and so forth, digging through the Qbone and Unibone web pages - oh, yeah.
The target system is my Micro PDP11/23+ - still mulling over the steps to approach that installation.  It's never had a working hard drive so that's the golden fleece - booting i

Cliff Miller

unread,
Oct 1, 2022, 4:56:00 PMOct 1
to UniBone
I got the qbone into the MicroPDP11/23+.  The CPU is in slot 1, Memory board is in slot 2, and the Floppy/Hard Drive controller was in slot 3.  The motherboard is a 9278 so these slots are all Qbus-C/D.  From slot 4 they are Qbus-Qbus.  That's significant because the CD Grant Continuity jumpers have to be opened if the Qbone is placed in slots 1-3, otherwise they are left closed (as shipped - the way I installed the board).

I elected to remove the drive controller and place a 9047 Grant Continuity card in slot 3 for physical clearance and the Qbone in slot 4. There was some discussion here of configuration changes required for the computer to have both a Qbone emulated drive and the RQDX board installed at the same time - it seemed simpler to remove the RQDX but if I want to format a hard drive or make floppies I'll have to resolve that problem.

Again, what fun!  I followed the Unibone instructions on Retrocmp to determine the current memory size and then emulate the rest possible with 22 bits - worked great - the computer thought it had 4 megs as far as I could tell.  
I then (tried) following the Unibone instructions on emulating an RL02 and booting RT11.  That was less than successful - either there are differences in the Qbone  v. Unibone software or more likely, my screen on the Ubuntu computer is too small and swapping from Firefox to terminal windows involved too much window shifting given the learning curve I was enjoying*.  I did see the drive on the MicroPDP boot screen finally, a small victory.

Throwing caution to the wind, I ran some of the scripts in the base directory of the Beaglebone - I successfully booted RT11v3 and then re-started the PDP/Qbone and booted RT11v5.5, both with minimum end-of-script finagling.

An afternoon of fun and enough success to experiment further.  

* There are two consoles running - the Beaglebone/Qbone via ssh over the network to run the configuration scripts and the PDP11 console via serial port on the CPU card.  Running the card outside the computer at first was valuable experience for the real thing.

Some of my explanation is possibly a bit elementary for the group but hopefully helpful to anyone starting out.  The group's assistance and encouragement have been amazing.  And thanks to Joerg Hoppe for making this possible at all.

Cliff Miller

unread,
Oct 11, 2022, 7:57:08 AMOct 11
to UniBone
I discovered the problem in my initial experiment running "demo.sh" to emulate an RL02 drive.  I followed the instructions on the Retrocmp webpage in the Unibone section but pushing the runstopbutton in software failed to spin up the drive as speed remained stubbornly at zero.  Reading again and re-reading, I realized I'd not enabled the controller!  Re-running the steps but first "EN"-ing the "RL" device and it worked as described-

Another fundamental upon which I stumbled is proper handling of the machine, a BA23 Micro PDP11 with 11-23+ processor.  There may be a better way but this sequence works reliably:

1. Turn on the machine.  I think the sound level rivals that of modern supersonic aircraft.
2.  Push the 'Halt" button. I believe this stops the CPU? More research -
3. Perform Qbone setup to establish emulation, whether individually or via the scripts provided.
4. Push the 'Halt' button again to re-establish CPU operation. 

At present my CPU is configured to boot the DU device.  If that's not what is emulated, the machine gives an error and asks if I want to try again.  I generally say 'No' and return to the machine menu.  It then permits me to select the correct boot device.

I'd appreciate comments and corrections on the above.  I've not gotten this far without your help

Jay Jaeger

unread,
Oct 11, 2022, 12:24:10 PMOct 11
to UniBone
Yes, the halt button stops the cpu.

I have been considering whether or not to add a circuit that will close the BR and NPG circuits until the unibone code gets initialized.  Presumably would only take a flip flop, a handful of gates and one of the available BBB ports that are on the board but not used on my UNIBONE.  Then maybe one would not have to go through this wait / halt / restart sequence.  I'd expect something similar could be done on a QBone.

Thoughts?

Reply all
Reply to author
Forward
0 new messages