Found a 1581 disc it don't run right with.

3 views
Skip to first unread message

Raymond

unread,
Jul 11, 2016, 9:08:10 AM7/11/16
to µIEC Users Discussion Group
I converted them to d81 my 2 picture disk and have "DKCOMPR/FOX" as the 1st program because on a real 1581 or FD-2000/4000 it will show all the pictures can pick and display.

But on the uIEC when I press return to read disk it just goes back to ready.

Tested the same flash card on the SD2IEC and at lest it shows and works with about 10 pictures on them. But just does not work with them all.

I attached the 2 .D81 disk here. If any one wants to test them out.

Maybe have to edit the "DKCOMPR/FOX" file some how to work with it. Or some update to the uIEC don't know.

Tested it with C64 Forever on my Windows PC and it works on that.

-Raymond Day
picture disk 1 and 2.zip

David Witmer

unread,
Jul 14, 2016, 4:36:43 AM7/14/16
to µIEC Users Discussion Group
I confirmed it is not working with my uIEC as well. I copied it over to my ramlink using a file copy and ran fine. It seems the point of problem lies with the directory and how it is accessed. If I get the directory from the ramlink then do a drive swap with the uIEC it is able to load the picture files fine. There is likely some code in the directory retrieval causing the problem.

Snogpitch

Raymond Day

unread,
Jul 14, 2016, 11:41:16 AM7/14/16
to uIEC-...@googlegroups.com

Thank you for checking it. At lest a little work around copying it to RAMLink.

It be nice if it worked on the uIEC. I guess could re-wright the program that displays it.

Or is there any other program that works like this to show photos on a disk?

-Raymond Day

On Thu, Jul 14, 2016 at 4:36 AM, David Witmer <snog...@prodigy.net> wrote:
I confirmed it is not working with my uIEC as well.  I copied it over to my ramlink using a file copy and ran fine. It seems the point of problem lies with the directory and how it is accessed.  If I get the directory from the ramlink then do a drive swap with the uIEC it is able to load the picture files fine. There is likely some code in the directory retrieval causing the problem.

Snogpitch

--
You received this message because you are subscribed to a topic in the Google Groups "µIEC Users Discussion Group" group.
To unsubscribe from this topic, visit https://groups.google.com/d/topic/uIEC-users/rExa9lIzSaM/unsubscribe.
To unsubscribe from this group and all its topics, send an email to uIEC-users+...@googlegroups.com.
To post to this group, send email to uIEC-...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/uIEC-users/4f0b1356-90c2-477f-818a-84bf56a266a8%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Reply all
Reply to author
Forward
0 new messages