Got Stereo Menace on a 1581 but uIEC can't load the levels the other can!

5 views
Skip to first unread message

Raymond

unread,
Aug 2, 2016, 9:37:29 AM8/2/16
to µIEC Users Discussion Group
Went to record a stereo video of this Menace I did long ago. But it just locks up putting the SD card in the uIEC when it goes to load the other levels on the 1581 partition.

The video is here:

https://youtu.be/JBYgUorusFA

But when I use the SD2IEC it works and loads the levels just like if it was on a real 1581 but a lot faster.

Maybe I need to update my uIEC.

Don't know but would the same firmware work in the uIEC as the SD2IEC?

-Raymond Day

RETRO Innovations

unread,
Aug 2, 2016, 10:12:48 AM8/2/16
to uIEC-...@googlegroups.com

What version of firmware does the other sd2iec have?


On powerup, read the error channel, as the version should be listed.


Jim


--
You received this message because you are subscribed to the Google Groups "µIEC Users Discussion Group" group.
To unsubscribe from this group and stop receiving emails from it, send an email to uIEC-users+...@googlegroups.com.
To post to this group, send email to uIEC-...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/uIEC-users/e7dd344f-b51a-45ac-a13c-ae4919255855%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Raymond

unread,
Aug 2, 2016, 11:16:01 AM8/2/16
to µIEC Users Discussion Group
"73,UIEC V0.10.3.00,00"

-Raymond Day

RETRO Innovations

unread,
Aug 2, 2016, 12:35:49 PM8/2/16
to uIEC-...@googlegroups.com
On 8/2/2016 10:16 AM, Raymond wrote:
"73,UIEC V0.10.3.00,00"

-Raymond Day
--
You received this message because you are subscribed to the Google Groups "µIEC Users Discussion Group" group.
To unsubscribe from this group and stop receiving emails from it, send an email to uIEC-users+...@googlegroups.com.
To post to this group, send email to uIEC-...@googlegroups.com.

For more options, visit https://groups.google.com/d/optout.

OK, so you need to download 0.10.3 of sd2iec from sd2iec.de and "downgrade" your uIEC from 1.0.0 to 0.10.3 and try to load the same games.


If the load now works, we need to get more details to Ingo as there would be a regression in 0.10.3 to 1.0.0


Jim


-- 
RETRO Innovations, Contemporary Gear for Classic Systems
www.go4retro.com
store.go4retro.com

Greg King

unread,
Aug 2, 2016, 6:40:45 PM8/2/16
to µIEC Users Discussion Group
I asume that Raymond is talking about an actual SD2IEC (all upper-case name) device.  Shouldn't its power-on message say "SD2IEC" instead of "UIEC"?

Eric Christopherson

unread,
Aug 3, 2016, 10:47:13 AM8/3/16
to uIEC-...@googlegroups.com
On Tue, Aug 2, 2016 at 5:40 PM, Greg King <greg....@verizon.net> wrote:
I asume that Raymond is talking about an actual SD2IEC (all upper-case name) device.  Shouldn't its power-on message say "SD2IEC" instead of "UIEC"?

Not to put words in Raymond's mouth, but he said previously he has both a uIEC and an SD2IEC; it's the uIEC he's having trouble with. 

--
        Eric Christopherson

RETRO Innovations

unread,
Aug 3, 2016, 11:35:13 AM8/3/16
to uIEC-...@googlegroups.com

No, I believe the firmware is called "sd2iec", and I think Ingo changed the code a while ago to report the firmware not, not the hardware variant.


Jim


--
You received this message because you are subscribed to the Google Groups "µIEC Users Discussion Group" group.
To unsubscribe from this group and stop receiving emails from it, send an email to uIEC-users+...@googlegroups.com.
To post to this group, send email to uIEC-...@googlegroups.com.

silv...@wfmh.org.pl

unread,
Aug 3, 2016, 12:12:27 PM8/3/16
to uIEC-...@googlegroups.com

> On 2016-08-03, at 17:35, RETRO Innovations <go4r...@go4retro.com> wrote:
>
> No, I believe the firmware is called "sd2iec", and I think Ingo changed the code a while ago to report the firmware not, not the hardware variant.

I just have similar problem with the latest (unstable) IDE64 firmware. IMHO the convention we should follow was established by CBM: FIRMWARE|DOS [EXTRAS|NIL] DEVICE. With "DEVICE" being a rather important part of the pattern. Hence the firmware should be one part and hardware another. We wouldn't have any doubt here either if this convention was followed. I agree that at first it may look somewhat strange when both the DOS/firmware and device is called the same but it's still much better than the lack of hardware identification.

--
SD!

Ingo Korb

unread,
Aug 3, 2016, 6:45:29 PM8/3/16
to uIEC-...@googlegroups.com

> On 2016-08-03, at 17:35, RETRO Innovations <go4r...@go4retro.com> wrote:
>> No, I believe the firmware is called "sd2iec", and I think Ingo
>> changed the code a while ago to report the firmware not, not the
>> hardware variant.

I did that because people started writing programs that tried to detect
sd2iec, but checked only for "sd2iec" or "uiec".

silv...@wfmh.org.pl writes:

> I agree that at first it may look somewhat strange when both the
> DOS/firmware and device is called the same but it's still much better
> than the lack of hardware identification.

Actually I could insert the hardware code there instead of calling it
sd2iec yet again - e.g. Jim's devices would report "uiec3" there and
most eBay specials would report either "larsp" or "sw2".

The information was already available in the extended version string
("X?"), but most users wouldn't need to know that detail because the
bootloader is overly user-friendly[1]. ;)

(Implementation will need to wait until I'm done messing with my Wii
though)

-ik
[1] "But which of the firmware files do I have to copy to the card?" -
"Just copy all of them and let the software decide."

Raymond

unread,
Aug 4, 2016, 7:53:24 AM8/4/16
to µIEC Users Discussion Group
Put the sd2iec-1.0.0alpha0-98-gaa8395c-uIEC3-m1281.bin on it.

Now when I load the 

As soon as it goes to the drive it says "?DEVICE NOT PRESENT   ERROR IN 0" with the green LED just flashing.

Just Attached the MENACE ST.D81 here as menace st.zip. Has other files on it too but the first on is "STEREO MENACE !" With all the levels that work good on the other SD device. The one that looks like a little 1541 drive I have.

But it just don't on the uIEC that one with the 2 drive plugs on the back of it.

Now it will say:

73,SD2IEC V1.0.0ALPHA0-98-GAA8395C,00.00

Wanted to test other binaries but now each one when I put the SD card in and turn on my 128 in 64 mode the green LED just flashes 2 times. I put like 6 other binarie files on it but none will change it now looks like.

The one that works on the little 1541 type case is:

73,SD2IEC V1.0.0ALPHA0-94-G342CA72,00,00

Put the uIEC on my C64c and just using the 1 foot seral cable only thing plug in I could not get it to see it. Just says Device not present!

On my 128 some times it will do that too and I have to press reset and then it works. I did a reset on the C64c too but that did not help.

Not sure but maybe something is wrong with my uIEC?

-Raymond Day
menace st.zip

silv...@wfmh.org.pl

unread,
Aug 4, 2016, 8:01:59 AM8/4/16
to uIEC-...@googlegroups.com

> On 2016-08-04, at 00:45, Ingo Korb <m...@akana.de> wrote:
>
>> I agree that at first it may look somewhat strange when both the
>> DOS/firmware and device is called the same but it's still much better
>> than the lack of hardware identification.
>
> Actually I could insert the hardware code there instead of calling it
> sd2iec yet again - e.g. Jim's devices would report "uiec3" there and
> most eBay specials would report either "larsp" or "sw2".

Something along the lines of the original convention would be highly welcome.

For example something like - say - "SDDOS V1.0.0[EXTRAS] SD2IEC" or "SDDOS V1.0.0[EXTRAS] UIEC", etc.

Obviously "SDDOS" is an example. Something that would allow to distinguish between SD2IEC (DOS) and SD2IEC (device). It's not /that/ important as device recognition can be done from the end of the string anyway but would still make it easier and less error-prone.

> The information was already available in the extended version string
> ("X?"), but most users wouldn't need to know that detail because the
> bootloader is overly user-friendly[1]. ;)

:-)

In any case we need a solution that is compatible with other devices.

--
SD!

RETRO Innovations

unread,
Aug 4, 2016, 10:16:35 AM8/4/16
to uIEC-...@googlegroups.com

I think you should put 0.10.3 uIEC3 on the root, and let the drive load that.  Then, try your game.


If 0.10.3 works with the game on uIEC, since it works on the sd2iec device, that narrows down the issue.

Jim

--
You received this message because you are subscribed to the Google Groups "µIEC Users Discussion Group" group.
To unsubscribe from this group and stop receiving emails from it, send an email to uIEC-users+...@googlegroups.com.
To post to this group, send email to uIEC-...@googlegroups.com.

Raymond

unread,
Aug 5, 2016, 5:50:27 AM8/5/16
to µIEC Users Discussion Group
Used the "sd2iec-0.10.3-uIEC3-m1281.bin" now it will say "73,UIEC V0.10.3,00,00"
Tested the game again and the screen goes blank now and the green LED flashes about the same speed as a 1541 drive error.

So still not working.

I attach the D81 in a post before this. Has any one tested this on there uIEC? It loads the 1st part but as soon as you go to play it, it don't work.

-Raymond Day
 

Raymond

unread,
Aug 5, 2016, 5:54:19 AM8/5/16
to µIEC Users Discussion Group
O yes got to set the uIEC as device 8 else it will do this same thing. I use @"u0>Ctrl-h" and it switches to device 8 then. But the levels still don't load on it from with in the game.

Chris Syntichakis

unread,
Aug 5, 2016, 7:51:19 AM8/5/16
to uiec-...@googlegroups.com
>I attach the D81 in a post before this. Has any one tested this on there uIEC? It loads the 1st >part but as soon as you go to play it, it don't work.

Works fine on me, at least I managed to play the first stage till the boss (then died there..) 
(my uiec's f/w is  the 1.0.0alpha0-98)

chris

Raymond

unread,
Aug 5, 2016, 10:10:18 AM8/5/16
to µIEC Users Discussion Group
Wow I got it working!

I put the "sd2iec-1.0.0alpha0-94-g342ca72-uIEC3-m1281.bin" on it same one I have on the other one the sd2iec that looks like a small 1541 drive. I got this one and the one that use to not work from Jim here. now that one works because it has the same .bin file from the sd2iec.

Raymond

unread,
Aug 5, 2016, 10:13:43 AM8/5/16
to µIEC Users Discussion Group

Raymond

unread,
Aug 5, 2016, 10:21:09 AM8/5/16
to µIEC Users Discussion Group
The file that is Attach MENACE ST.D81 I made it stereo it auto finds the 2nd SID chip on Real SID chips.

F7 pause it.
F5 switches the sides of the stereo sounds and music.
F3 turn on invincibility
F1 turn off invincibility

I added them long ago when I added the stereo to the game.

-Raymond Day
Reply all
Reply to author
Forward
0 new messages