Locking Down UbuntuLite

0 views
Skip to first unread message

Antikx

unread,
Apr 7, 2006, 4:51:50 PM4/7/06
to Ubuntu Lite
Hello,

First off, I appreciate all the work done to provide Ubuntu Lite.
I've started using Ubuntu Lite on Celeron 400's in a computer lab I
look after. It's a great solution for aging machines.
I've got most of the interface and OS locked down so students can't
mess things up. I can post some of the things I did if anyone is
interested.

I'm requesting help on a couple issues.

When the X starts up, students can press Ctrl + Alt + F1 to go to the
first tty and press Control + C to kill X and drop to a command prompt.
I do not want students to have access to the command line.

I would appreciate any advice on solving this issue or any advice on
locking down Linux/Ubuntu Lite.

Thank you.

Colin M

unread,
Apr 8, 2006, 4:38:29 AM4/8/06
to ubunt...@googlegroups.com
In Ubuntu and Ulite there are the getty's that run the command prompt. In
Ulite we only have three starting when the computer starts. You can disable
excessive getty's on startup. These are located in the /etc/inittab file.
You can use the command sudo nano (or vi) /etc/inittab to edit the file.

1:2345:respawn:/sbin/getty 38400 tty1
2:23:respawn:/sbin/getty 38400 tty2
3:23:respawn:/sbin/getty 38400 tty3

You can trim off excess Getty's here.

Now for your security Question. I will try something before I post the
solution, but I believe that it was solved in Ulite 1.1 but I will check.

Antikx

unread,
Apr 12, 2006, 12:20:38 PM4/12/06
to Ubuntu Lite
Thanks Colin M.
I had previously trimmed away all but two tty's.
The first one looked like this:
1:2345:respawn:/bin/bash -login > /dev/tty1 2>&1 < /dev/tty1
I changed it to what you listed in your message and it fixes the
problem of being able to drop to a shell with a Ctrl+C press, but now X
does not start.
It gives this message:
Id "1" respawing too fast: disabled for 5 minutes

Antikx

unread,
Apr 17, 2006, 3:45:55 PM4/17/06
to Ubuntu Lite
A bit more info to add.
I noticed that ~.bash_profile is where X server starts up.
I tried to put a Control C trap in ~.bash_profile, ~.bashrc,
/etc/profile /etc/bash.bashrc by putting this line it:
trap "" 2
It works after the X server has been killed but doesn't seem to stop my
from pressing Control C to kill it.

Maybe I'm going about this all wrong.
If I run /sbin/getty in the inittab how do I get it to start X?

Reply all
Reply to author
Forward
0 new messages