EACCES, permission denied '/root/.config/configstore/insight-bower.yml'

1841 views
Skip to first unread message

Thorsten Rintelen

unread,
Sep 25, 2014, 5:06:36 AM9/25/14
to twitte...@googlegroups.com
i have installed nodejs, npm and bower as root.
if i try "bower install" as root, it works.

If i try "bower install --allow-root" as bamboo user from bamboo i got:

Andy Idea?
Error: EACCES, permission denied '/root/.config/configstore/insight-bower.yml'
25-Sep-2014 10:54:55You don't have access to this file.
25-Sep-2014 10:54:55
25-Sep-2014 10:54:55    at Object.fs.openSync (evalmachine.<anonymous>:438:18)
25-Sep-2014 10:54:55    at Object.fs.readFileSync (evalmachine.<anonymous>:289:15)
25-Sep-2014 10:54:55    at Object.create.all.get (/usr/lib/node_modules/bower/node_modules/insight/node_modules/configstore/configstore.js:33:29)
25-Sep-2014 10:54:55    at Object.Configstore (/usr/lib/node_modules/bower/node_modules/insight/node_modules/configstore/configstore.js:26:44)
25-Sep-2014 10:54:55    at new Insight (/usr/lib/node_modules/bower/node_modules/insight/lib/index.js:26:34)
25-Sep-2014 10:54:55    at ensureInsight (/usr/lib/node_modules/bower/lib/util/analytics.js:14:19)
25-Sep-2014 10:54:55    at Object.setup (/usr/lib/node_modules/bower/lib/util/analytics.js:29:9)
25-Sep-2014 10:54:55    at Object.<anonymous> (/usr/lib/node_modules/bower/bin/bower:72:11)
25-Sep-2014 10:54:55    at Module._compile (module.js:456:26)
25-Sep-2014 10:54:55    at Object.Module._extensions..js (module.js:474:10)
25-Sep-2014 10:54:55There was an error while executing bower.

deepak kaithwas

unread,
Jan 7, 2015, 4:34:18 AM1/7/15
to twitte...@googlegroups.com

I just fixed it in Windows. I have done three things, which one have fixed it I am not sure.

1. Run cmd prompt as administrator.

2. takeown /? this command is equivalent to chown (linux) but for windows.

3. cacls -cacls /E /T /G :F

4. simply go in $USER /Users/calvin/.config/configstore/ and make files unhidden.

it worked for me like charm. I have been trying to fix this since many days.

庞存洪

unread,
Apr 18, 2016, 8:20:17 AM4/18/16
to bower

If you get this following error,

Error: EACCES, permission denied '.config/configstore/insight-bower.yml'
You don't have access to this file.

changing ownner .config

sudo chown -R [user name] ~/.config

在 2014年9月25日星期四 UTC+8下午5:06:36,Thorsten Rintelen写道:
Reply all
Reply to author
Forward
0 new messages