Unicode Problems

61 views
Skip to first unread message

X-Site

unread,
Apr 4, 2012, 5:11:02 PM4/4/12
to Tweecode
Hi,
I love this great and simple tool for creating Storys. Sadly the
editor becomes a lot less helpful as you use ä, ö, ü which a prominent
in German. As you use one character of those, all links after the
character are broken, and the marked text is being shifted.

Is there a way you could fix this?
Id love to start out with some German story, as my English is by far
not as good.

Hopefully
X-Site

X-Site

unread,
Apr 4, 2012, 5:29:31 PM4/4/12
to Tweecode
Well,
just what I said before was not quite correct, simple links seem to
stay intact. Makros like this one break though:

<<choice "folgen" "folge" >>

Philip Sutton

unread,
Apr 6, 2012, 6:36:54 AM4/6/12
to Tweecode
Hi Rasmus,

We are definitely planning to modify Twine/Twee to handle letters that
are not in the standard English alphabet but we are not sure how long
it will take us. If there are any people with Python skills who could
help with this task, your assistance would be very welcome! :)

Cheers, Philip

----

Bo Daley

unread,
Apr 6, 2012, 6:57:48 AM4/6/12
to twee...@googlegroups.com
Hi Rasmus,

yes a couple of us are looking into this at the moment, but could
certainly use some help if you have some python background:

https://github.com/tweecode/twine/issues/19

bo.

> --
> You received this message because you are subscribed to the Google Groups "Tweecode" group.
> To post to this group, send email to twee...@googlegroups.com.
> To unsubscribe from this group, send email to tweecode+u...@googlegroups.com.
> For more options, visit this group at http://groups.google.com/group/tweecode?hl=en.
>

X-Site

unread,
Apr 13, 2012, 12:24:58 PM4/13/12
to twee...@googlegroups.com
Sadly, I have never used python otherwise I would have done some research already.
As I see it, the structure does work well with Unicode.
It seems though that some escape strings are being counted together with the actual characters.
This then shifts all positions based on the amount of escape strings used.


X-Site

unread,
Apr 15, 2012, 6:08:00 PM4/15/12
to twee...@googlegroups.com
Ah, I see this problem has got quite a tail.
I'll check back here from time to time and if you get it working, I promise, I'll make good use of it!
(Or maybe I check out phyton one day if I find the sparetime.)

Thanks Guys!
Reply all
Reply to author
Forward
0 new messages