Sobre fstab

3 views
Skip to first unread message

Paulo Carvalho

unread,
Nov 4, 2015, 10:05:44 AM11/4/15
to tu...@googlegroups.com
Boa Tarde, Gente

Resolvi me aventurar com o Linux Manjaro e até agora estou gostando muito do sistemas que é baseado no ArchLinux.

Estou tendo alguns problemas com o fstab. Não sei se de permissão! Não estou conseguindo entender.

Uso esse arquivo fstab no ubuntu e monta as partições corretamente, mas no manjaro não rola.

Seguinte: 

O fstab não consegue montar no boot o compartilhamento abaixo.
A pasta run existe, porém a pasta media só aparece quando coloco um pendrive.
Consigo criar a pasta IEL_COMPI usando o sudo, porém ao reiniciar a máquina a pasta some, pois como falei, a pasta media não é montada no fstab, o que ao meu ver, era para ser montada no boot.

Crio a pasta dou todas as permissões possíveis e depois monto. Aí sim funciona, mas no boot não funciona.
 O meu usuário faz parte do grupo wheel, admin, users. Mesmo assim, não estou conseguindo entender. 

Alguém poderia me ajudar?

//10.11.0.21/iel_compi /run/media/pauloadriano/IEL_COMPI cifs noauto,noperm,users,username=pcarvalho,password=xxxx,domain=workgroup,rw,exec,uid=1000,gid=100,dir_mode=0777,file_mode=0777,iocharset=utf8

Geyslan Gregório Bem

unread,
Nov 4, 2015, 10:11:38 AM11/4/15
to tu...@googlegroups.com
Olá Paulo,

Qual o motivo de você querer montar em media? Acredito que ela seja
para dispositivos móveis/unidades de disco.

Em 4 de novembro de 2015 12:05, Paulo Carvalho
<pauloac...@hotmail.com> escreveu:
> --
> --
> Comunidade Tux-CE - Comunidade Cearense de Software Livre
> Para postar neste grupo, envie um e-mail para tu...@googlegroups.com
> Para cancelar a sua inscrição neste grupo, envie um e-mail para
> tuxce-un...@googlegroups.com
> Maiores informações: http://groups.google.com/group/tuxce ou
> http://www.tux-ce.org
> ---
> Você recebeu essa mensagem porque está inscrito no grupo "Comunidade Tux-CE"
> dos Grupos do Google.
> Para cancelar inscrição nesse grupo e parar de receber e-mails dele, envie
> um e-mail para tuxce+un...@googlegroups.com.
> Para mais opções, acesse https://groups.google.com/d/optout.



--
Regards,

Geyslan G. Bem
hackingbits.com

Paulo Carvalho

unread,
Nov 4, 2015, 10:13:06 AM11/4/15
to tu...@googlegroups.com
Também tentei montar no mnt e não rolou..


> Date: Wed, 4 Nov 2015 12:11:37 -0300
> Subject: Re: [Tux-CE] Sobre fstab
> From: gey...@gmail.com
> To: tu...@googlegroups.com
> Você está recebendo esta mensagem porque se inscreveu no grupo "Comunidade Tux-CE" dos Grupos do Google.

> Para cancelar inscrição nesse grupo e parar de receber e-mails dele, envie um e-mail para tuxce+un...@googlegroups.com.
> Para obter mais opções, acesse https://groups.google.com/d/optout.

Geyslan Gregório Bem

unread,
Nov 4, 2015, 10:18:19 AM11/4/15
to tu...@googlegroups.com
De qualquer forma, tenta com estas configurações:
https://wiki.archlinux.org/index.php/Samba#Add_Share_to_.2Fetc.2Ffstab


Em 4 de novembro de 2015 12:11, Geyslan Gregório Bem
<gey...@gmail.com> escreveu:

Paulo Carvalho

unread,
Nov 4, 2015, 10:26:51 AM11/4/15
to tu...@googlegroups.com
Via Wiki, segui o exemplo e segue linha no fstab:

//10.11.0.21/iel_compi /mnt/IEL_COMPI cifs username=pcarvalho,password=xxx,domain=sfiec 0 0

Depois: sudo mount -a. 

E nada acontece !!!!


> Date: Wed, 4 Nov 2015 12:18:18 -0300

> Subject: Re: [Tux-CE] Sobre fstab
> From: gey...@gmail.com
> To: tu...@googlegroups.com
>
> Você está recebendo esta mensagem porque se inscreveu no grupo "Comunidade Tux-CE" dos Grupos do Google.

> Para cancelar inscrição nesse grupo e parar de receber e-mails dele, envie um e-mail para tuxce+un...@googlegroups.com.
> Para obter mais opções, acesse https://groups.google.com/d/optout.

Geyslan Gregório Bem

unread,
Nov 4, 2015, 10:31:24 AM11/4/15
to tu...@googlegroups.com
Então tenta o https://wiki.archlinux.org/index.php/Autofs

Em 4 de novembro de 2015 12:26, Paulo Carvalho
<pauloac...@hotmail.com> escreveu:

Geyslan Gregório Bem

unread,
Nov 4, 2015, 10:32:19 AM11/4/15
to tu...@googlegroups.com
Ou https://wiki.archlinux.org/index.php/Samba#Automatic_mounting


Em 4 de novembro de 2015 12:31, Geyslan Gregório Bem

Paulo Carvalho

unread,
Nov 4, 2015, 1:54:09 PM11/4/15
to tu...@googlegroups.com
Consegui resolver criando os diretórios no home do usuário. Porém, ainda acho que tem alguma coisa a ver com as permissões do sistema em relação ao usuário, pois criei os diretórios no mnt e mesmo assim, quando reinicio, os diretórios somem.
Mas deu certo.

Vou para um novo desafio.

Driver Nvidia.



> Date: Wed, 4 Nov 2015 12:32:05 -0300

Geyslan Gregório Bem

unread,
Nov 4, 2015, 6:02:41 PM11/4/15
to tu...@googlegroups.com
Esqueci de te enviar: http://unix.stackexchange.com/a/1988/47040

Em 4 de novembro de 2015 15:54, Paulo Carvalho
<pauloac...@hotmail.com> escreveu:

Paulo Carvalho

unread,
Nov 5, 2015, 6:29:04 AM11/5/15
to tu...@googlegroups.com
Hoje, o sistema montou normalmente. Como havia falado, configurei para usar o home do usuário como ponto de montagem. Mas acho que isso não esteja correto.

Vamos para outro problema agora.

Uso dois monitores na minha máquina e toda vez que inicio a área de trabalho está na tela da direita e quero que fica na tela da esquerda. Configuro o nvidia e fica correto, porém, ao reiniciar a máquina volta a configuração original.



> Date: Wed, 4 Nov 2015 20:02:40 -0300

Geyslan Gregório Bem

unread,
Nov 5, 2015, 6:38:48 AM11/5/15
to tu...@googlegroups.com
Em 5 de novembro de 2015 08:29, Paulo Carvalho
<pauloac...@hotmail.com> escreveu:
> Hoje, o sistema montou normalmente. Como havia falado, configurei para usar
> o home do usuário como ponto de montagem. Mas acho que isso não esteja
> correto.

Bom, como no link, os pontos de montagem /mnt e /media são para uso
provisório. Para persistência o ideal é usar algum outro diretório a
partir do / (root).

>
> Vamos para outro problema agora.
>
> Uso dois monitores na minha máquina e toda vez que inicio a área de trabalho
> está na tela da direita e quero que fica na tela da esquerda. Configuro o
> nvidia e fica correto, porém, ao reiniciar a máquina volta a configuração
> original.

Qual o ambiente visual, (desktop environment ou window manager),
gnome, kde, i3, xmonad?

Se forem os desktop env, você vai poder persistir a posição por meio
configuração neles mesmo. Se forem window managers, você vai precisar
o xrandr. Eu criei um wrapper do xrandr chamado xrasengan
(https://github.com/geyslan/xrasengan) para me ajudar a religar um
monitor display port que eu tenho. O problema é que ele ao entrar em
standby não retorna a imagem, para isso precisei de um workaround no
xrandr e sintetizei no xrasengan.

Mas diz aí qual seu ambiente.

Paulo Carvalho

unread,
Nov 5, 2015, 3:05:20 PM11/5/15
to tu...@googlegroups.com
Manjaro Linux Bellatrix 15.09
Cinnamon

Segue: 

Toda manhã ao ligar a máquina, aparece como na imagem tela1 e tenho que configurar toda vez para tela2, que é o corrento.
Tela1

 
 

 


> Date: Thu, 5 Nov 2015 08:38:47 -0300
tela1.png

Geyslan Gregório Bem

unread,
Nov 5, 2015, 3:21:40 PM11/5/15
to tu...@googlegroups.com
Você vai ter que testar o xrandr então. Ou isso ou você configura o xorg.conf.

Humberto Fraga

unread,
Nov 5, 2015, 3:28:39 PM11/5/15
to Tux-Ce
Não existe uma tela do próprio cinnanon que tenha esta configuração? Sei que o Gnome tem. Se o seu desktop environment tiver, pode ser uma alternativa realizar a configuração lá.
Reply all
Reply to author
Forward
0 new messages