Installing TG on Windows - pysqlite problems

7 views
Skip to first unread message

Thomas

unread,
Jan 30, 2007, 6:23:49 AM1/30/07
to TurboGears
Hi there!

Installing TG out-of-the-box on Windows doesn't work because I can't
compile the extensions needed for pysqlite.
When I install the Windows-binary package of pysqlite manually before
installing TG this also doesn't work, because easy_install doesn't
know anything of my fresh installed pysqlite and tries to install the
egg from cheeseshop (with the error above . . .).

Suggestions to get beyond this?
For the application I'm intending to build I don't even need pysqlite :
(

Ed Singleton

unread,
Jan 30, 2007, 8:00:23 AM1/30/07
to turbo...@googlegroups.com

Thomas

unread,
Jan 30, 2007, 8:25:04 AM1/30/07
to TurboGears
Hi Ed,

>There are some suggested solutions in this recent thread:

> http://groups.google.co.uk/group/turbogears/browse_thread/thread/1a61...

thx for yout pointer, but I've already read this thread and followed
Christopher's "option 2".
Unfortunately TG seems to *require* (as of "EGG-INFO/requires.txt")
the pysqlite egg to be installed and the windows binary-package I
installed didn't came as an egg.
But (as I'm quite new to python) maybe I missed an important point?
Is it possible to "tweak" the TG installation so that it won't try to
"easy_install pysqlite"?

Thomas

Christopher Arndt

unread,
Jan 31, 2007, 8:40:35 AM1/31/07
to turbo...@googlegroups.com
Thomas schrieb:

> Unfortunately TG seems to *require* (as of "EGG-INFO/requires.txt")
> the pysqlite egg to be installed

The latest released version (1.0.1) in the 1.0 branch does not seem to require
pysqlite for the standard install, only for the "testtools" extension. See

http://trac.turbogears.org/browser/branches/1.0/setup.py (line 101)

Are you sure you are using the latest version? Or maybe the tgsetup.py script
wants to install the testtools extension? Have you tried installing with this
command?

easy_install TurboGears==1.0.1

Chris

Thomas

unread,
Jan 31, 2007, 9:40:30 AM1/31/07
to TurboGears
Thx Christopher,

> The latest released version (1.0.1) in the 1.0 branch does not seem to require
> pysqlite for the standard install, only for the "testtools" extension. See
>

> http://trac.turbogears.org/browser/branches/1.0/setup.py(line 101)


>
> Are you sure you are using the latest version? Or maybe the tgsetup.py script
> wants to install the testtools extension? Have you tried installing with this
> command?
>
> easy_install TurboGears==1.0.1

Your assumption (tgsetup.py wanting to install the testtools) seems to
be right.
In fact tgsetup.py downloaded the right version 1.0.1 of TurboGears,
but somehow managed to leave these testtools-artifacts in EGG-INFO/
requires.txt, so my first try with a plain "easy_install
TurboGears==1.0.1" didn't refresh the locally available files and
failed like the (tgsetup.py) ones before.

But "easy_install --upgrade TurboGears==1.0.1" did the job (at least
the hardest part) :)
On the following "tg-admin info" I got a message complaining about a
missing module "sqlobject" which I got fixed by "easy_install
SQLObject".

Now everything seems to be up and running :)

Thx,

Thomas

Reply all
Reply to author
Forward
0 new messages