OAuth failing everywhere

385 views
Skip to first unread message

Zach B

unread,
Feb 8, 2018, 7:59:53 AM2/8/18
to Tumblr API Discussion
Anyone else getting a 401 not matter what keys you use? The console doesn't even work either. It's super frustrating.

tmcyrix

unread,
Feb 8, 2018, 9:02:40 AM2/8/18
to Tumblr API Discussion
I already contact the support in an other posts.

Michael Ceyko

unread,
Feb 8, 2018, 2:43:15 PM2/8/18
to Tumblr API Discussion
Hey Zach,

I don't see any system-wide increases in 401 volume, so perhaps it is either a user authorization or signature issue? Please double check that your key and secret in code are the same as on https://www.tumblr.com/oauth/apps as well.

Regarding the API Console, it should now be working, so you may want to try logging in with it again as well.

After looking into these other things, let me know if you have any specific requests that seem like they should be working but are still not, and I can check into them some more.

Regards,
Mike

alex baldwin

unread,
Feb 12, 2018, 2:06:41 PM2/12/18
to Tumblr API Discussion
Hey all- I also found that starting late last week OAuth was failing for me for some reason. I discovered that the OAuth library I was using (grant) was using http for OAuth requests by default, which up until recently worked fine for Tumblr. Changing the OAuth endpoints to use https solved the problem for me. 

Michael, not sure if you have any control over this, but it would be nice in the future to get a deprecation notice for changes like that.
Reply all
Reply to author
Forward
0 new messages