before_id paramter in http://api.tumblr.com/v2/user/dashboard removed?

105 views
Skip to first unread message

David Strippgen

unread,
Oct 18, 2017, 5:24:57 AM10/18/17
to Tumblr API Discussion
Hi there,
I used the "before_id" parameter, in "http://api.tumblr.com/v2/user/dashboard".
That has been working -though undocumented- for several years, but now it seems like this is does not work anymore.
Has anybody the same experience, or am I doing something wrong (since recently...)

Thanks and best,
David

Michael Ceyko

unread,
Oct 18, 2017, 1:47:33 PM10/18/17
to Tumblr API Discussion
Hi David,

Are you by chance making a POST request to `/v2/user/dashboard`? We recently fixed a bug where we were mistakenly reading in parameters from the body instead of the query.

If so, if you switch your request to a GET, it should work correctly again. If not, can you send me the specific requests you're making, and I'll take a closer look.

Sorry for the confusion.

Regards,
Mike

David Strippgen

unread,
Oct 19, 2017, 2:50:23 AM10/19/17
to Tumblr API Discussion
Hi Mike,
thanks for your quick -and helpful- reply. I will look into it ASAP...

Best,
David

Alexander Lozada

unread,
Nov 6, 2017, 6:27:26 PM11/6/17
to Tumblr API Discussion
I could be incorrect, but I remember investigating this issue.  IIRC I used a proxy to discover what the official Tumblr apps routes did.  I discovered an undocumented parameter called "after_id" that actually did what the API documented "before_id" would do.

Of course, this was a while ago so I could be wrong.
Reply all
Reply to author
Forward
0 new messages