default ticket reports 1-5 work, 6-8 fail

6 views
Skip to first unread message

z00m1n

unread,
Dec 15, 2006, 12:21:43 AM12/15/06
to Trac Users
Hi all,

I am using Trac with the MySQL backend. The default ticket report
queries used to work fine on a Win XP test system, but they now fail on
the FreeBSD production system.

I get the following error messages in trac.log:

{6} All Tickets By Milestone (Including closed)
Report execution failed: (1064, "You have an error in your SQL syntax;
check the manual that corresponds to your MySQL server version for the
right syntax to use near ' '<my user name>', ')' THEN 'font-weight:
bold' END)\n END) AS __style__,\n' at line 6")

{7} My Tickets
Report execution failed: (1064, "You have an error in your SQL syntax;
check the manual that corresponds to your MySQL server version for the
right syntax to use near ' '<my user name>', ')'\n ORDER BY (status =
'assigned') DESC, p.value, miles' at line 9")

{8} Active Tickets, Mine first
Report execution failed: (1064, "You have an error in your SQL syntax;
check the manual that corresponds to your MySQL server version for the
right syntax to use near ' '<my user name>', ')' THEN 'My Tickets' \n
ELSE 'Active Tickets' \n EN' at line 3")


AFAICT, these 3 reports uses dynamic variables, but I seem to lack the
SQL skills to diagnose the actual root cause myself. It further puzzles
me that these reports used to work on Win XP.

Can someone help me ?


TIA,

CU z00m1n

Sid Wiesner

unread,
Dec 15, 2006, 7:46:46 AM12/15/06
to trac-...@googlegroups.com
z00m1n wrote:
> I am using Trac with the MySQL backend. The default ticket report
> queries used to work fine on a Win XP test system, but they now fail on
> the FreeBSD production system.
>
> AFAICT, these 3 reports uses dynamic variables, but I seem to lack the
> SQL skills to diagnose the actual root cause myself. It further puzzles
> me that these reports used to work on Win XP.

Looks like this was fixed yesterday. See
http://trac.edgewall.org/ticket/4387 for more details.

Sid

z00m1n

unread,
Dec 17, 2006, 5:24:09 PM12/17/06
to Trac Users
GREAT!

All it took was to remove the single quotes around $USER in those three
reports, now they work.

Thanks a lot !

CU Z>

Reply all
Reply to author
Forward
0 new messages