Cant install TracHoursPlugin with PipEnv - dependency problem with TicketSidebarProviderPlugin

25 views
Skip to first unread message

Rob Hills

unread,
Jun 25, 2022, 5:35:26 AMJun 25
to Trac Users
I am using PipEnv to install Trac on my new server  This has worked well so far but I have run into a problem with the TracHoursPlugin

Despite having installed the dependencies, including TicketSidebarProviderPlugin, PipEnv keeps complaining it can't find it:

pipenv install
Pipfile.lock (2aa3a9) out of date, updating to (6c3baa)...
Locking [dev-packages] dependencies...
Locking [packages] dependencies...
Building requirements...
Resolving dependencies...
✘ Locking Failed!
[pipenv.exceptions.ResolutionFailure]: Warning: Your dependencies could not be resolved. You likely have a mismatch in your sub-dependencies.
First try clearing your dependency cache with $ pipenv lock --clear, then try the original command again.
Alternatively, you can use $ pipenv install --skip-lock to bypass this mechanism, then run $ pipenv graph to inspect the situation.
Hint: try $ pipenv lock --pre if it is a pre-release dependency.
ERROR: Could not find a version that matches ticketsidebarprovider (from -r /tmp/pipenvWTqrx6requirements/pipenv-l8ICnG-constraints.txt (line 28))
No versions found

I think this might be because the version specified in TicketSidebarProviderPlugin's setup.py is 0.0.  AFAICT, this should be set to 0.11, the current version.

Is there any reason the version should still be specified as 0.0?

Cheers,

Rob Hills
Waikiki, Western Australia

Jun Omae

unread,
Jun 25, 2022, 11:53:35 AMJun 25
to trac-...@googlegroups.com
On Sat, Jun 25, 2022 at 6:35 PM Rob Hills <rcp....@gmail.com> wrote:
> I think this might be because the version specified in TicketSidebarProviderPlugin's setup.py is 0.0. AFAICT, this should be set to 0.11, the current version.
> Is there any reason the version should still be specified as 0.0?

No. The "0.11" means supports for Trac 0.11 (and maybe later). The
"0.0" version has no issues.

TicketSidebarProviderPlugin is unable to install via pip because the
plugin is not published on PyPI. Instead, required plugins should be
explicitly installed like:

$ pip install svn+https://trac-hacks.org/svn/tracsqlhelperscript/1.2/ \
svn+https://trac-hacks.org/svn/ticketsidebarproviderplugin/0.11/ \
svn+https://trac-hacks.org/svn/trachoursplugin/trunk/



--
Jun Omae <jun...@gmail.com> (大前 潤)

Rob Hills

unread,
Jun 25, 2022, 9:51:51 PMJun 25
to Trac Users
Hi Jun,

Many thanks for your reply.  Unfortunately it does not resolve my problem.

Pipenv also permits installation from SVN repositories and even zipped filesets.  In my installation, I have already installed TracSqlHelperScript and TicketSidebarProviderPlugin.  Here are the relevant entries from my Pipfile:


I've checked my .venv/lib/python2.7/site-packages/ folder and both those pre-requisite packages seem to be installed:

$ ls -al .venv/lib/python2.7/site-packages/
drwxr-sr-x   3 admin webapps   4096 Jun 25 16:34 ticketsidebarprovider
drwxr-sr-x   2 admin webapps   4096 Jun 25 16:34 TicketSidebarProvider-0.0.dist-info
<..>
drwxr-sr-x   2 admin webapps   4096 Jun 25 16:39 tracsqlhelper
drwxr-sr-x   2 admin webapps   4096 Jun 25 16:39 TracSQLHelper-0.3.1.dist-info

When I remove TracHours from my build, Pipenv builds it all without an error.  When I try and add Trachours, Pipenv complains with the error I detailed in my OP.   For the record, I have tried the suggestions outlined in the Pipenv error message, they haven't changed anything.

Has anybody else built, using Pipenv, a Trac project that includes the TracHours plugin?

TIA,

Rob
Waikiki, Western Australia

Jun Omae

unread,
Jun 25, 2022, 10:14:15 PMJun 25
to trac-...@googlegroups.com
If the version "0.0" leads the issue, that is a pipenv issue. Please ask on pipenv community rather than here.

--
You received this message because you are subscribed to the Google Groups "Trac Users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to trac-users+...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/trac-users/4f31a124-6f2e-407c-a1f1-10eba38796b8n%40googlegroups.com.

Rob Hills

unread,
Jun 25, 2022, 11:45:33 PMJun 25
to Trac Users
It appears that I'm going to have to abandon my Pipenv setup and start again from scratch using the more traditional virtualenv setup.  I've run into another issue with Pipenv which is due to the Python 2.7 environment I'm  currently locked in to and which the Pipenv developer isn't interested in addressing because Python 2.7 is EOL.

It's a shame as I've found with my other Python projects (albeit all Python 3) that Pipenv provides much simpler installation/deployment work environment management than the older virtualenv+pip system.

Cheers,

RjOllos

unread,
Jun 28, 2022, 8:18:20 PMJun 28
to Trac Users
On Saturday, June 25, 2022 at 8:45:33 PM UTC-7 rcp....@gmail.com wrote:
It appears that I'm going to have to abandon my Pipenv setup and start again from scratch using the more traditional virtualenv setup.  I've run into another issue with Pipenv which is due to the Python 2.7 environment I'm  currently locked in to and which the Pipenv developer isn't interested in addressing because Python 2.7 is EOL.

It's a shame as I've found with my other Python projects (albeit all Python 3) that Pipenv provides much simpler installation/deployment work environment management than the older virtualenv+pip system.

Bumped the version to 0.1, in case that helps:

RjOllos

unread,
Jun 28, 2022, 8:27:59 PMJun 28
to Trac Users
I also removed the "tag_svn_revision" attribute which had been causing some problems. I don't recall the specifics at the moment, but I think setuptools dropped support for it. 
Reply all
Reply to author
Forward
0 new messages