TracError: Unsupported database type "postgres"

11 views
Skip to first unread message

Harold Alcalde Solarte

unread,
Jun 30, 2021, 10:10:39 AMJun 30
to Trac Users
After update Postgres from 9.2.24 version to 13.0.0, python to 3.9 and pip to 3.9 I get this error:

Traceback (most recent call last): 
 File "build/bdist.linux-x86_64/egg/trac/web/api.py", line 709, in send_error data, 'text/html') File "build/bdist.linux-x86_64/egg/trac/web/chrome.py", line 1121, in render_template template = self.load_template(filename, method=method) File "build/bdist.linux-x86_64/egg/trac/web/chrome.py", line 1070, in load_template self.get_all_templates_dirs(), auto_reload=self.auto_reload, File "build/bdist.linux-x86_64/egg/trac/web/chrome.py", line 769, in get_all_templates_dirs for provider in self.template_providers: File "build/bdist.linux-x86_64/egg/trac/core.py", line 90, in extensions components = [component.compmgr[cls] for cls in classes] File "build/bdist.linux-x86_64/egg/trac/core.py", line 220, in __getitem__ component = cls(self) File "build/bdist.linux-x86_64/egg/trac/core.py", line 152, in __call__ self.__init__() File "build/bdist.linux-x86_64/egg/tracsubtickets/web_ui.py", line 119, in __init__ for tt in TicketType.select(self.env): File "build/bdist.linux-x86_64/egg/trac/ticket/model.py", line 810, in select with env.db_query as db: File "build/bdist.linux-x86_64/egg/trac/db/api.py", line 174, in __enter__ db = self.dbmgr.get_connection(readonly=True) File "build/bdist.linux-x86_64/egg/trac/db/api.py", line 463, in get_connection connector, args = self.get_connector() File "build/bdist.linux-x86_64/egg/trac/db/api.py", line 615, in get_connector scheme=scheme)) TracError: Unsupported database type "postgres"


Harold Alcalde Solarte

unread,
Jun 30, 2021, 10:10:48 AMJun 30
to Trac Users
I update Postgres from 9.2.24 version to 13.0.0 version also Python to 3.9 and pip to 3.9 after that I get this error.
I've installed psycopg2, psycopg2-binary and Genshi with Pip but it doesnt work. 
I use TRAC 1.2.2

Any suggestions?
Thanks.


Error_TRAC.PNG

RjOllos

unread,
Jun 30, 2021, 10:12:29 AMJun 30
to Trac Users
On Wednesday, June 30, 2021 at 7:10:48 AM UTC-7 haroldalca...@gmail.com wrote:
I update Postgres from 9.2.24 version to 13.0.0 version also Python to 3.9 and pip to 3.9 after that I get this error.
I've installed psycopg2, psycopg2-binary and Genshi with Pip but it doesnt work. 
I use TRAC 1.2.2

Reply all
Reply to author
Forward
0 new messages