Error R10 (Boot timeout) -> Web process failed to bind to $PORT within 60 seconds of launch

460 views
Skip to first unread message

dennis...@gmail.com

unread,
Mar 24, 2014, 2:42:34 AM3/24/14
to tot...@googlegroups.com
Hi,

I'm trying to deploy to heroku but was always getting this error:

2014-03-24T06:22:51.155570+00:00 app[web.1]: Author :
2014-03-24T06:22:51.155570+00:00 app[web.1]: Version : 1.0.0
2014-03-24T06:22:51.155066+00:00 app[web.1]: ====================================================
2014-03-24T06:22:51.155397+00:00 app[web.1]: node.js : v0.10.26
2014-03-24T06:22:51.155570+00:00 app[web.1]: total.js : v1.2.3-1
2014-03-24T06:22:51.156965+00:00 app[web.1]: Date : 2014-03-24 06:22:51
2014-03-24T06:22:51.156965+00:00 app[web.1]: Mode : release
2014-03-24T06:22:51.157373+00:00 app[web.1]: http://127.0.0.1:3246/
2014-03-24T06:22:51.157230+00:00 app[web.1]:
2014-03-24T06:22:51.157483+00:00 app[web.1]:
2014-03-24T06:22:51.157230+00:00 app[web.1]: ====================================================
2014-03-24T06:22:49.992046+00:00 heroku[api]: Scale to web=1 by xxxxxxxxx
2014-03-24T06:23:50.268779+00:00 heroku[web.1]: Error R10 (Boot timeout) -> Web process failed to bind to $PORT within 60 seconds of launch
2014-03-24T06:23:50.269031+00:00 heroku[web.1]: Stopping process with SIGKILL
2014-03-24T06:23:51.730458+00:00 heroku[web.1]: Process exited with status 137
2014-03-24T06:23:51.747305+00:00 heroku[web.1]: State changed from crashed to starting
2014-03-24T06:23:51.746332+00:00 heroku[web.1]: State changed from starting to crashed
2014-03-24T06:23:53.413687+00:00 heroku[web.1]: Starting process with command `node index.js`


I have tried to update the partial.js project to work with total.js and seems to work on my local machine if I run 'foreman start'. However, I get this R10 timeout if I try to deploy to heroku.


Any help would be appreciated

Peter Širka

unread,
Mar 24, 2014, 2:51:18 PM3/24/14
to tot...@googlegroups.com
Hi Dennis,
I must see a config-release.

Thanks.
Reply all
Reply to author
Forward
0 new messages