[BUG] Overlay icons do not appear in Vista SP2 64-bit

133 views
Skip to first unread message

Linebarger, John

unread,
Jun 8, 2009, 1:42:02 PM6/8/09
to us...@tortoisesvn.tigris.org
I am using Microsoft Vista Ultimate Edition 64-bit, with Service Pack 2 installed.  I downloaded and installed the latest 64-bit version of TortoiseSVN (1.6.2.16344).  However, I get no overlay icons at all in Windows Explorer.  I know they're possible, because TortoiseCVS displays them, but TortoiseSVN does not.  Is a fix for this planned in a future release?  I understand from Web postings that this was a problem with 1.6.1 as well.  Thanks!
 
John M. Linebarger, PhD
Sandia National Laboratories
Albuquerque, NM
 
 

Stefan Küng

unread,
Jun 8, 2009, 2:01:36 PM6/8/09
to us...@tortoisesvn.tigris.org
Linebarger, John wrote:
> I am using Microsoft Vista Ultimate Edition 64-bit, with Service Pack 2
> installed. I downloaded and installed the latest 64-bit version of
> TortoiseSVN (1.6.2.16344). However, I get no overlay icons at all in
> Windows Explorer. I know they're possible, because TortoiseCVS displays
> them, but TortoiseSVN does not. Is a fix for this planned in a future
> release? I understand from Web postings that this was a problem with
> 1.6.1 as well. Thanks!

Which web postings are you referring to? The overlays work just fine on
64-bit versions.

Stefan

--
___
oo // \\ "De Chelonian Mobile"
(_,\/ \_/ \ TortoiseSVN
\ \_/_\_/> The coolest Interface to (Sub)Version Control
/_/ \_\ http://tortoisesvn.net

------------------------------------------------------
http://tortoisesvn.tigris.org/ds/viewMessage.do?dsForumId=4061&dsMessageId=2360396

To unsubscribe from this discussion, e-mail: [users-un...@tortoisesvn.tigris.org].

signature.asc

Kurt Pruenner

unread,
Jun 8, 2009, 2:12:32 PM6/8/09
to us...@tortoisesvn.tigris.org
Linebarger, John wrote:
> I am using Microsoft Vista Ultimate Edition 64-bit, with Service Pack 2
> installed. I downloaded and installed the latest 64-bit version of
> TortoiseSVN (1.6.2.16344). However, I get no overlay icons at all in
> Windows Explorer. I know they're possible, because TortoiseCVS displays
> them, but TortoiseSVN does not. Is a fix for this planned in a future
> release? I understand from Web postings that this was a problem with
> 1.6.1 as well. Thanks!

How recent is the TCVS version you're using? Only more recent versions
of TSVN and TCVS are able to share overlay icons, and since Explorer has
a limit of 14 overlay images in total with extraneous overlay icons
simply not showing up you might have too many...

(Looks like you'll need to use the latest unstable build since the
changelog for 1.11.1 [1] says "First release using TortoiseOverlays"...)

Come to think of it - there aren't any 64-bit versions of TortoiseCVS;
so if it's overlay icons are showing up you'd have to actually be using
the 32-bit Windows Explorer, which of course means you'll have to also
install a 32-bit version of TSVN...

[1]
http://sourceforge.net/project/shownotes.php?release_id=629046&group_id=48103

--
Kurt Bernhard Pruenner --- Haendelstrasse 17 --- 4020 Linz --- Austria
.......It might be written "Mindfuck", but it's spelt "L-A-I-N".......
np: Kettel - Kingscourt Imp (Myam James 2)

------------------------------------------------------
http://tortoisesvn.tigris.org/ds/viewMessage.do?dsForumId=4061&dsMessageId=2360402

Robert Roessler

unread,
Jun 8, 2009, 3:48:27 PM6/8/09
to us...@tortoisesvn.tigris.org
Kurt Pruenner wrote:
>...

> Come to think of it - there aren't any 64-bit versions of TortoiseCVS;
> so if it's overlay icons are showing up you'd have to actually be using
> the 32-bit Windows Explorer, which of course means you'll have to also
> install a 32-bit version of TSVN...

That turns out not to be the case... ;)

My installation of TCVS (1.11.3.1) from late 2008 on my Vista SP1 x64
box is most definitely 64-bit, and it coexists happily with 64-bit TSVN.

--
Robert Roessler

------------------------------------------------------
http://tortoisesvn.tigris.org/ds/viewMessage.do?dsForumId=4061&dsMessageId=2360432

Kurt Pruenner

unread,
Jun 8, 2009, 4:17:22 PM6/8/09
to us...@tortoisesvn.tigris.org
Robert Roessler wrote:
> Kurt Pruenner wrote:
>> ...
>> Come to think of it - there aren't any 64-bit versions of TortoiseCVS;
>> so if it's overlay icons are showing up you'd have to actually be using
>> the 32-bit Windows Explorer, which of course means you'll have to also
>> install a 32-bit version of TSVN...
>
> That turns out not to be the case... ;)
>
> My installation of TCVS (1.11.3.1) from late 2008 on my Vista SP1 x64
> box is most definitely 64-bit, and it coexists happily with 64-bit TSVN.

Well, at the very least they're doing a terriffic job of hiding any
mention of a 64 bit version on their website AND SourceForge...

--
Kurt Bernhard Pruenner --- Haendelstrasse 17 --- 4020 Linz --- Austria
.......It might be written "Mindfuck", but it's spelt "L-A-I-N".......

np: Yagya - Rigning Níu (Rigning)

------------------------------------------------------
http://tortoisesvn.tigris.org/ds/viewMessage.do?dsForumId=4061&dsMessageId=2360445

Robert Roessler

unread,
Jun 9, 2009, 1:51:13 AM6/9/09
to us...@tortoisesvn.tigris.org
Kurt Pruenner wrote:
> Robert Roessler wrote:
>> Kurt Pruenner wrote:
>>> ...
>>> Come to think of it - there aren't any 64-bit versions of TortoiseCVS;
>>> so if it's overlay icons are showing up you'd have to actually be using
>>> the 32-bit Windows Explorer, which of course means you'll have to also
>>> install a 32-bit version of TSVN...
>>
>> That turns out not to be the case... ;)
>>
>> My installation of TCVS (1.11.3.1) from late 2008 on my Vista SP1 x64
>> box is most definitely 64-bit, and it coexists happily with 64-bit TSVN.
>
> Well, at the very least they're doing a terriffic job of hiding any
> mention of a 64 bit version on their website AND SourceForge...

I think you are right about them not heavily promoting their
64-bitness... :)

Take a look at

http://sourceforge.net/project/platformdownload.php?group_id=48103

and do a search on

tortoisecvs 64-bit

... and you will see that 64-bit is even supported in the current stable
1.10.10, although as I said, I am running 1.11.3.1 ("unstable", but
works fine for me).

Looking at what got installed in the filesystem and the registry, it
looks like they tried to do what I do with my Shell extensions (and
occasionally annoy Stefan with here) - install both 64 and 32 -bit
versions, so that nobody says "I don't see my overlays/menus"! ;)

Unfortunately, it looks like the registry entries for 32-bit got hosed,
so the 32-bit extension DLL, even though present, does not have the
correct registry entries.

--
Robert Roessler

------------------------------------------------------
http://tortoisesvn.tigris.org/ds/viewMessage.do?dsForumId=4061&dsMessageId=2360537

Clemens Anhuth

unread,
Jun 9, 2009, 5:15:22 AM6/9/09
to us...@tortoisesvn.tigris.org
Linebarger, John wrote:
> I am using Microsoft Vista Ultimate Edition 64-bit, with Service Pack
> 2 installed. I downloaded and installed the latest 64-bit version of
> TortoiseSVN (1.6.2.16344). However, I get no overlay icons at all in
> Windows Explorer. I know they're possible, because TortoiseCVS
> displays them, but TortoiseSVN does not. Is a fix for this planned in
> a future release? I understand from Web postings that this was a
> problem with 1.6.1 as well. Thanks!
Hello John,

I am using TSVN with exactly that Vista edition and the overlays show up
fine.

However, I have not installed any other third party software displaying
overlays (as far as I know at least).

I suggest studying these:

http://tortoisesvn.tigris.org/faq.html

http://tortoisesvn.tigris.org/faq.html#ovlnotshowing

If in doubt I suggest to deinstall TCVS and TSVN. Then install TSVN.
Maybe after installation reboot twice, not only once. And if they still
don't show up go to software control panel and choose to repair the
installation. That did the trick for me with when upgrading from the
previous to the current version.

You should probably install the TortoiseXYZ variant you plan to use
mainly first, to improve its chances to fall into one of those limited
number of overlay icons slots before the TortoiseXYZ variant you use
less. Always keep these limited number of overlay icon slots in mind
when trying to analyze malfunctions.


With best regards

Clemens Anhuth


--
www.froglogic.com - Squish - Multi-Platform GUI Testing

------------------------------------------------------
http://tortoisesvn.tigris.org/ds/viewMessage.do?dsForumId=4061&dsMessageId=2360571

Linebarger, John

unread,
Jun 9, 2009, 10:57:42 AM6/9/09
to us...@tortoisesvn.tigris.org
More information about this bug.  On my system, the following key is not present in the registry; should it have been set by the TortoiseSVN installation?
 
KEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\explorer\ShellIconOverlayIdentifiers 

From: Linebarger, John
Sent: Monday, June 08, 2009 11:42 AM
To: 'us...@tortoisesvn.tigris.org'
Subject: [BUG] Overlay icons do not appear in Vista SP2 64-bit

Stefan Küng

unread,
Jun 9, 2009, 1:51:19 PM6/9/09
to us...@tortoisesvn.tigris.org
Linebarger, John wrote:
> More information about this bug. On my system, the following key is not
> present in the registry; should it have been set by the TortoiseSVN
> installation?
>
> KEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\explorer\ShellIconOverlayIdentifiers

That depends on which registry hive you're looking at. If you installed
the x64 version, then you have to check that registry entry in the x64
hive of the registry.

And yes, the msi installer will set that registry key, unless of course
some 'security' app (virus scanner) reverts that (yes, that happens a lot).

Stefan

--
___
oo // \\ "De Chelonian Mobile"
(_,\/ \_/ \ TortoiseSVN
\ \_/_\_/> The coolest Interface to (Sub)Version Control
/_/ \_\ http://tortoisesvn.net

------------------------------------------------------
http://tortoisesvn.tigris.org/ds/viewMessage.do?dsForumId=4061&dsMessageId=2360697

signature.asc
Reply all
Reply to author
Forward
0 new messages