Tortoise SVN - Can't connect to SVN "target machine activity refused it"

25 views
Skip to first unread message

InformerHyena

unread,
Sep 22, 2021, 2:52:05 AM9/22/21
to TortoiseSVN
Hello,
My brother, my cousin and I have a server for a side project.
This server is located by my brother's house in Italy, my cousin lives in the US and I am based in germany.

We are all connected to the server via VPN, besides my brother which is in LAN of course.
The server hosts a repository made with visual svn, it's a local http repo with access enabled only to 3 users.

What is really weird is that we all are connected to the server via VPN because we all 3 can log in with desktop remote to the server, the big issue is that my brother and I managed to get the repository via SVN checkout, and shortly after it asked us the log  in details of the users from visual svn, for my cousin instead it asked nothing and directly got the error in the tortoise svn console that says "target machine activity refused it" which i think it is related to the fact you don't get a log in pop up?

Also, if I try accessing the repository via google chrome, i can get inside of the local repository, after logging in with the credential made from visual svn, while my cousin can't, getting a chrome error and the only thing he can do is reload the page (no advance option for "not secure" websites)

Again, my cousin can log in with desktop remote, so he technically is in "LAN" too, but can't access SVN?

I would appreciate any help for this topic, thanks in advance

Stefan

unread,
Sep 22, 2021, 3:00:36 AM9/22/21
to TortoiseSVN
the most common reason for no connection because the "target machine actively refused it" is in fact not that the target machine refused the connecton but a firewall/virus scanner on the client side blocked the connection.
So you should check firewalls and installed virus scanners and whitelist the svn clients.

InformerHyena

unread,
Sep 22, 2021, 3:59:54 AM9/22/21
to TortoiseSVN
Hey, thanks for the fast reply.

On my cousin's pc there is only the windows defender/firewall. We also tried yesterday by deactivating the whole thing, and yet did not work. Also, we tried adding tortoise SVN as a "trusted APP" into the firewall and that did not work.
Maybe we whitelisted it the wrong way or the wrong program, may you give me more details how to do it step by step?

Thanks in advance 

InformerHyena

unread,
Sep 24, 2021, 3:37:15 AM9/24/21
to TortoiseSVN
* SOLVED * 
Hey everyone. I solved it thanks to Stefan.

All my cousin had to do in his pc was allowing the SVN client in the firewall. By simply going into the firewall, then "allow an app through windows firewall", search where you installed SVN Client, add it. Good to go
Reply all
Reply to author
Forward
0 new messages