TortoiseGit Windows 10 context menu not visible

71 views
Skip to first unread message

John Zabroski

unread,
Jun 30, 2022, 1:53:46 PM6/30/22
to tortoisegit-users
Hi,

I've tried uninstalling and re-installing TortoiseGit several times, and each time, when the installer finishes, explorer.exe dies. I've tried force-restarting explorer.exe via running "start explorer.exe" as well as rebooting the machine, and nothing gets TortoiseGit to appear. I also tried going directly to the TortoiseGitProc.exe and clicking it, hoping to access the settings and flip some settings to see if it's a settings issue, at which point I get a dialog box telling me the only way to access TortoiseGit is via context menu.

I read the FAQ and the only thing I saw was this warning about not using "Git For Windows" due to flakiness [1] but, to the best of my knowledge, _I am using Git For Windows_.  How do I verify which one I have installed? On my path, I see C:\Program Files\Git\cmd;C:\Program Files\TortoiseGit\bin; - these appear to be the right default paths for Git For Windows and TortoiseGit.

I've included some additional information about my set-up below.  One unique thing I can think of is that since our work computers are cloud-based AWS Workspaces, we use Windows Server 2016 Datacenter Edition.


Computer Details
Amazon AWS Workspace PowerPro Instance (8 vCPU, 32 GB RAM)

> # PowerShell 7.0.1 Script to Dump OS-level info
> systeminfo | select-string "^OS"

OS Name:                   Microsoft Windows Server 2016 Datacenter
OS Version:                10.0.14393 N/A Build 14393
OS Manufacturer:           Microsoft Corporation
OS Configuration:          Member Server
OS Build Type:             Multiprocessor Free

> # PowerShell 7.0.1 Script to dump PATH variable
> $env:PATH

C:\Program Files\PowerShell\7;C:\Program Files (x86)\Common Files\Oracle\Java\javapath;C:\Program Files\PowerShell\7;C:\Windows\system32;C:\Windows;C:\Windows\System32\Wbem;C:\Windows\System32\WindowsPowerShell\v1.0\;C:\Program Files\Amazon\cfn-bootstrap\;C:\ProgramData\chocolatey\bin;C:\Program Files\TortoiseSVN\bin;C:\Program Files (x86)\Microsoft SQL Server\150\DTS\Binn\;D:\Users\John.Zabroski\AppData\Local\Microsoft\WindowsApps;D:\Users\John.Zabroski\AppData\Local\GitHubDesktop\bin;C:\Program Files\Microsoft VS Code\bin;C:\Program Files\Microsoft SQL Server\130\Tools\Binn\;C:\Program Files\Microsoft SQL Server\Client SDK\ODBC\170\Tools\Binn\;C:\Program Files\Microsoft SQL Server\Client SDK\ODBC\130\Tools\Binn\;C:\Program Files (x86)\Microsoft SQL Server\140\Tools\Binn\;C:\Program Files\Microsoft SQL Server\140\Tools\Binn\;C:\Program Files\Microsoft SQL Server\140\DTS\Binn\;C:\Program Files\PowerShell\7\;C:\Program Files (x86)\Gpg4win\..\GnuPG\bin;C:\Program Files\Azure Data Studio\bin;C:\Program Files\Amazon\AWSCLIV2\;C:\Program Files (x86)\Windows Kits\10\Windows Performance Toolkit\;C:\Program Files\Microsoft SQL Server\150\Tools\Binn\;C:\Program Files\dotnet\;C:\Program Files\Git\cmd;C:\Program Files\TortoiseGit\bin;C:\Program Files (x86)\LinqPad6;D:\Users\John.Zabroski\.dotnet\tools;D:\Users\John.Zabroski\AppData\Local\Programs\Fiddler;D:\Users\John.Zabroski\.dotnet\tools

# Hotfixes Installed
> systeminfo /FO CSV | ConvertFrom-Csv | select -ExpandProperty "Hotfix(s)" | % {$_ -Split ","}

34 Hotfix(s) Installed.
[01]: KB5014630
[02]: KB3176936
[03]: KB3186568
[04]: KB3192137
[05]: KB3199209
[06]: KB3199986
[07]: KB4013418
[08]: KB4023834
[09]: KB4035631
[10]: KB4049065
[11]: KB4089510
[12]: KB4091664
[13]: KB4093137
[14]: KB4132216
[15]: KB4465659
[16]: KB4485447
[17]: KB4486129
[18]: KB4498947
[19]: KB4503537
[20]: KB4509091
[21]: KB4512574
[22]: KB4520724
[23]: KB4521858
[24]: KB4524244
[25]: KB4535680
[26]: KB4550994
[27]: KB4562561
[28]: KB4565912
[29]: KB4589210
[30]: KB5001402
[31]: KB5005698
[32]: KB5011570
[33]: KB5014026
[34]: KB5014702
PS C:\Windows\System32>



























































































































































































































John Zabroski

unread,
Jul 4, 2022, 11:57:07 AM7/4/22
to tortoisegit-users
Hi,

Is this the right mailing list to get help?

One thing I noticed is that, after install, %APPDATA%\TortoiseGit does not exist. But, C:\Program Files\TortoiseGit does.

Additional information:

I have both TortoiseSVN and TortoiseGit installed.  TortoiseSVN works beautifully.  I also tried navigating to a git repo and SHIFT + Right Click since I found a StackOverflow post suggesting that might reveal items hidden by default [1]

1. TortoiseSVN (x64) - TortoiseSVN 1.13.1, Build 28686 - 64 Bit , 2019/10/31 18:49:38
2. TortoiseGit 2.13.0.1 (C:\Program Files\TortoiseGit\bin)
git version 2.36.1.windows.1 (C:\Program Files\Git\bin; C:\Program Files\Git\mingw64\; C:\Program Files\Git\etc\gitconfig)

John Zabroski

unread,
Jul 15, 2022, 1:26:15 PM7/15/22
to tortoisegit-users
As an update, I installed NirSoft ShellExView, and I was able to prove that TortoiseGit did register itself as a shell extension, HOWEVER, I was also able to verify that it is disabled for some reason.

Does anyone know why it wouldn't be enabled? Does this mean the installer silently failed for some reason?

I've uploaded a screenshot to Imgur of running NirSoft ShellExView, showing Tortoise Overlays, Tortoise SVN, and TortoiseGit: https://i.imgur.com/fRpadJI.png

John Zabroski

unread,
Jul 18, 2022, 10:31:02 AM7/18/22
to tortoisegit-users
I decided to report this as an issue to the TortoiseGit developers: https://gitlab.com/tortoisegit/tortoisegit/-/issues/3941
Reply all
Reply to author
Forward
0 new messages