[TW5] I lost everything. Password doesn't work anymore.

616 views
Skip to first unread message

Gerald Strickland

unread,
May 28, 2014, 5:30:09 PM5/28/14
to tiddl...@googlegroups.com
- I was using either 5.0.10 or 5.0.11
- TW5 lives on a USB stick
- Encrypted my TW5
- I use TiddlyFox
- I use it on Firefox (latest build)

Last time I used it was last night at home on my Windows 7 desktop, hit the check mark to stop editing my last entry, it then saves via TiddlyFox and I eject my USB drive. I came to work this morning, plugged in my USB, enter my TW5 password and it doesn't want to open after several attempts. I browse to my TW5 html file and notice that my file size is no longer 3MB.. instead it is 80KB. This leads me to believe I lost everything.

What are my options?

- I have an old backup prior to upgrading to 5.0.10 or 5.0.11, but that was 35 days ago. And I've added so much information to my TW5 since then.

Biggest WTF moment right here. I can't help but think of all the information I inputted for the past 35 days.

Danielo Rodríguez

unread,
May 28, 2014, 5:52:15 PM5/28/14
to tiddl...@googlegroups.com
Seems a I/O problem. I don't know if related to your usb stick or firefox. 
In my opinion TW5 should include some kind of backup option. Maybe having the option of create individual tid files like TWC does.

I'm really sorry about your lost. I don't think it could be fixed.

Stephan Hradek

unread,
May 28, 2014, 6:40:57 PM5/28/14
to tiddl...@googlegroups.com
If you didn't save anything on the stick in the meantime, try an undelete utility.

Birthe C

unread,
May 28, 2014, 6:47:04 PM5/28/14
to tiddl...@googlegroups.com
Hi Gerald Strickland

A true horror story. The change in file size you saw from 3 mb to 80 kb! I have been tricked by delated writing to usb harddrive myself. Everything looked fine, no warning. But later I saw a lot of unreadable files and corrupted files. I saved or thought I saved the files from one computer and tried to read the files on another. I am not able to explain why or how, but I tried putting the drive on the computer the files were saved from and was able to read at least some of them.
Have you tried reading your usb from your home computer?

It is very bitter...but I think you'll have to go back to your latest backup......

Danielo I totally agreee TW5 should include backup option. I love using Tiddlyspot for a lot of reasons...backups are one of them.


Birthe

Måns

unread,
May 28, 2014, 8:04:42 PM5/28/14
to tiddl...@googlegroups.com
Hi Gerald

Terrible story - it is however a common problem when saving files to usb and unmounting it manually..

This utility seems to work on/with all filetypes: http://youtu.be/L8fXMDtLhOQ

As Birthe said - tiddlyspot saves backups - so does store.php and dropbox.

Good luck!

Cheers Måns Mårtensson

Matabele

unread,
May 29, 2014, 3:13:21 AM5/29/14
to tiddl...@googlegroups.com
Hi

Sorry to hear of your loss -- I had a life changing moment when a large hard drive crashed at a critical moment.

I would also try an undelete utility on the usb stick, using your home computer -- perhaps the remnants of your old file remain intact.

I suggest saving a copy of your TW files to Dropbox (or any other suitable space in the cloud) periodically -- this acts as a q&d backup system for when disaster strikes :-(

regards

PMario

unread,
May 29, 2014, 5:28:16 PM5/29/14
to tiddl...@googlegroups.com
On Wednesday, May 28, 2014 11:30:09 PM UTC+2, Gerald Strickland wrote:
Last time I used it was last night at home on my Windows 7 desktop, hit the check mark to stop editing my last entry, it then saves via TiddlyFox and I eject my USB drive.

How did you eject your USB drive?
With the Windows button bottom right ... "safely eject ... bla bla"?  (don't know the exact text)

This is a known problem with saving to portable drives. If a software does a save, it basically saves to memory and the OS takes care, that the stuff is saved to the HD, USB ... But there can be some time in between. So if data isn't saved to the USB and you remove it, you have a corrupted file. If you use the OS function for "safe removal" it should work.

-mario

Gerald Strickland

unread,
Jun 19, 2014, 7:18:47 PM6/19/14
to tiddl...@googlegroups.com
Just a follow up to my issue last month... I tried everything suggested by all who replied to no avail. I was doubtful that anything would work to help recover my nuked TiddlyWiki and had no choice but to pick up from my recent backup which I mentioned.

What an experience. Did I like it? No. Did it have to happen? Yes. After a week of frustration I began writing in my TiddlyWiki again (I have to admit - there really is nothing quite like it). But I had to make sure I didn't face this problem of losing it. So as one of you suggested, I set my Dropbox and also have it backed up on my local server with versioning. I can sort of sleep at night. I'm now making efforts to get my server backed up remotely.

This experience was an eye opener.

Back to it!
Reply all
Reply to author
Forward
0 new messages