Chronos broken?

Skip to first unread message


Apr 17, 2012, 1:01:25 AM4/17/12
to TI Chronos Development
I have a Chronos that I haven't used in awhile, since I got it out
again it randomly resets itself, when I try to wirelessly update the
firmware it displays 'ram rfbsl' for a second then resets itself, and
trying to use sync, acc, and ppt modes it won't link to the usb access
point. Has anyone else experienced this problem?

Harri Haataja

Apr 17, 2012, 2:26:16 AM4/17/12

Could the battery be getting low. It might be a low voltage reset
whenever something (like the radio) tries to pull too much power too
quickly. I would try a fresh battery first.

Have you tried the EZ USB programmer? That should work and doesn't requre RF.

I appear to be temporarily using gmail's horrible interface. I
apologise for any failure in my part in trying to make it do the right
thing with post formatting.

Tiago Leite

Apr 20, 2012, 10:59:17 AM4/20/12
to TI Chronos Development
Hi Harri.
I have the same problem described by Orladin (watch randomly resets
itself), but the battery voltage displays 2.94v. So... the battery
should be OK, right?
Next time the watch reset's itself I will try change the battery.


PS: Orladin, did you changed you Chronos battery? Did it worked for
you? :)

On 17 Abr, 07:26, Harri Haataja <> wrote:


Apr 20, 2012, 11:22:45 PM4/20/12
to TI Chronos Development
I updated the firmware in the watch (had to do so using the usb
emulator connector) and now the watch no longer randomly resets,
however any time I try to update it using rfbsl it resets itself. It
has a brand new battery so I know that's not the problem. Another
oddity is it will not connect with the wireless USB dongle in any mode
(sync, acc, ppt). Has anyone else ran into this problem?

Christiane Ruetten

May 25, 2012, 5:23:16 PM5/25/12
I can confirm. Random reboots started out of the blue about a month into a fresh battery in a firmware that ran fine for months. Now most RF operations instantaneously reset the watch, especially RFBSL. mspdebug prog over the eZ430U works fine so far.

I get these reboots with several firmware flavors and even known-to-have-worked images. I am confident that it is a hardware defect. It's definitely not the battery, but it looks suspiciously like a problem with the power supply and regulation chain.

Christiane Ruetten

May 25, 2012, 5:34:11 PM5/25/12
Same here. Random reboots started out of the blue with a good battery in a firmware that worked flawlessly for months. Tried different OpenChronos flavors, but RF operations will reset the watch. Only flashing with the eZ430U still works.

I am confident it's a hardware defect. While it is definitely not the battery, it suspiciously looks like an issue with the power supply or regulation circuit.
Message has been deleted

Anima Sterling

Jan 8, 2014, 12:38:48 PM1/8/14
I'm experiencing something similar. My watch also resets whenever I try to use rfbsl. I can use sync, acc and ppt without problems.
I have changed the battery twice, still having the same problem. I can't get it to update via RF, which would be great. Mine production date is 12/3/2010.
It happens even if I connect via the usb dongle and execute the rfbsl powering the watch from the usb of the computer.

Jamie Jones

Feb 16, 2014, 5:31:38 AM2/16/14
Used the watch for the first time last night and worked perfectly. Come this morning and it resets whenever I try to connect to the access point. Not impressed so far!
Is it even worth changing the firmware or should I just return this asap?

Christiane Ruetten

Feb 16, 2014, 9:02:14 AM2/16/14
So you said you were using it right out of the box and it broke down the
nex day? What you describe sounds very much like a known hardware defect
that has developed in numerous Chronoses usually after a couple of
months. The cause of the defect is still unknown to the community, but
switching to a different firmware will not make it go away.

It wouldn't surprise me if stock units now came with this almost right
out of the box as it would strongly indicate that the problem indeed is
a defective component and not caused by alternate firmwares.

If you still can you should try to claim warranty on your unit.

> --
> You received this message because you are subscribed to a topic in the
> Google Groups "TI Chronos Development" group.
> To unsubscribe from this topic, visit
> To unsubscribe from this group and all its topics, send an email to
> To post to this group, send email to
> Visit this group at
> For more options, visit

Aodhan Coffey

May 24, 2014, 8:27:17 AM5/24/14
Sorry I am late to the party guys. I have been having the same problem as described, my Chronos watch would reset randomly when attempting to use the radio to transmit data. It doesn't always happen, but it happens quite frequently. Anyway, I found a solution to my problem, perhaps it might help some of you.

I checked my radio configuration and found that the I was setting the TX power to 10db. Changing this value to 0db instead solved my problems. This is in line with what Harri suggested, the watch is causing a reset when too much power is drawn to quickly.

My fix was to set the PA_TABLE0 = 0x50 // 434Mhz
Note: This value will be different for different frequencies, so use the Smart RF studio to figure out the necessary value for your watch.

Hope this helps, 

Marco Antonio Romero Valencia

Jul 14, 2015, 11:52:35 PM7/14/15
Hi Aodhan Coffey

Im having the
same issue with a 433Mhz version of the watch, can you tell me were I can edit the PA_TABLE0 value in the program?

Thanks in advance!
Reply all
Reply to author
0 new messages