Blank LCD screen

43 views
Skip to first unread message

Fabio Brolesi

unread,
Sep 3, 2016, 9:06:08 AM9/3/16
to TI Chronos Development
Hello all.

I'm new to microcontroller development, and recently I bought a EZ-430 Chronos 433. After some use (without development) I note that, after be in acc mode, pressing "V", the watch was rebooted. Reading some posts, I replaced the battery, but now, the LCD screen is off. I measured the voltage, and it's ok. Also, I tried to connect via USB like a develop device, but the screen again is blank. What I'm doing wrong? Did I break my watch?

Tamer Çelik

unread,
Sep 3, 2016, 3:29:00 PM9/3/16
to ti-chronos-...@googlegroups.com
Hello Fabio,
Had same issue with 433 model.
However i have returned it and never tested again.

Please see http://e2e.ti.com/support/microcontrollers/msp430/f/166/p/426359/1532937#1532937
Jason Kriek from TI, he recommended me to do

Can you run the watch tied into a debugger? If you run the example, and set a break point at the entry to main, you can inspect the contents of the PMMIFG register. Then look on page 102 of http://www.ti.com/lit/ug/slau259e/slau259e.pdf, and you can then see the source of the reset, then start working backwards from there. You will get to the break point immediately from launching(as expected), you will be interested in the next time it gets to this breakpoint.

Maybe it helps in your acse.

On Sat, Sep 3, 2016 at 4:06 PM, Fabio Brolesi <bro...@gmail.com> wrote:
Hello all.

I'm new to microcontroller development, and recently I bought a EZ-430 Chronos 433. After some use (without development) I note that, after be in acc mode, pressing "V", the watch was rebooted. Reading some posts, I replaced the battery, but now, the LCD screen is off. I measured the voltage, and it's ok. Also, I tried to connect via USB like a develop device, but the screen again is blank. What I'm doing wrong? Did I break my watch?

--
You received this message because you are subscribed to the Google Groups "TI Chronos Development" group.
To unsubscribe from this group and stop receiving emails from it, send an email to ti-chronos-development-+unsub...@googlegroups.com.
To post to this group, send email to ti-chronos-development-@googlegroups.com.
Visit this group at https://groups.google.com/group/ti-chronos-development-.
For more options, visit https://groups.google.com/d/optout.

Fabio Brolesi

unread,
Sep 4, 2016, 6:10:41 PM9/4/16
to TI Chronos Development
Hello Tamer,

thank you. I didn't say, but also connected in an USB port, the watch don't show anything. Is it normal in this case? I watched some youtube videos with a watch connected in an USB port but with the LCD active.

See ya!


On Saturday, September 3, 2016 at 4:29:00 PM UTC-3, Tamer Çelik wrote:
Hello Fabio,
Had same issue with 433 model.
However i have returned it and never tested again.

Please see http://e2e.ti.com/support/microcontrollers/msp430/f/166/p/426359/1532937#1532937
Jason Kriek from TI, he recommended me to do

Can you run the watch tied into a debugger? If you run the example, and set a break point at the entry to main, you can inspect the contents of the PMMIFG register. Then look on page 102 of http://www.ti.com/lit/ug/slau259e/slau259e.pdf, and you can then see the source of the reset, then start working backwards from there. You will get to the break point immediately from launching(as expected), you will be interested in the next time it gets to this breakpoint.

Maybe it helps in your acse.
On Sat, Sep 3, 2016 at 4:06 PM, Fabio Brolesi <bro...@gmail.com> wrote:
Hello all.

I'm new to microcontroller development, and recently I bought a EZ-430 Chronos 433. After some use (without development) I note that, after be in acc mode, pressing "V", the watch was rebooted. Reading some posts, I replaced the battery, but now, the LCD screen is off. I measured the voltage, and it's ok. Also, I tried to connect via USB like a develop device, but the screen again is blank. What I'm doing wrong? Did I break my watch?

--
You received this message because you are subscribed to the Google Groups "TI Chronos Development" group.
To unsubscribe from this group and stop receiving emails from it, send an email to ti-chronos-development-+unsub...@googlegroups.com.
To post to this group, send email to ti-chronos-...@googlegroups.com.

Tamer Çelik

unread,
Sep 4, 2016, 6:15:30 PM9/4/16
to ti-chronos-...@googlegroups.com
Hey Fabio,
As far as i remember, LCD wasn't working with USB connection.
You may try to use SmartRF Studio and connect to your watch to read some registers. That may help you to see if watch is dead or not.
All the best.

On Mon, Sep 5, 2016 at 1:10 AM, Fabio Brolesi <bro...@gmail.com> wrote:
Hello Tamer,

thank you. I didn't say, but also connected in an USB port, the watch don't show anything. Is it normal in this case? I watched some youtube videos with a watch connected in an USB port but with the LCD active.

See ya!

On Saturday, September 3, 2016 at 4:29:00 PM UTC-3, Tamer Çelik wrote:
Hello Fabio,
Had same issue with 433 model.
However i have returned it and never tested again.

Please see http://e2e.ti.com/support/microcontrollers/msp430/f/166/p/426359/1532937#1532937
Jason Kriek from TI, he recommended me to do

Can you run the watch tied into a debugger? If you run the example, and set a break point at the entry to main, you can inspect the contents of the PMMIFG register. Then look on page 102 of http://www.ti.com/lit/ug/slau259e/slau259e.pdf, and you can then see the source of the reset, then start working backwards from there. You will get to the break point immediately from launching(as expected), you will be interested in the next time it gets to this breakpoint.

Maybe it helps in your acse.
On Sat, Sep 3, 2016 at 4:06 PM, Fabio Brolesi <bro...@gmail.com> wrote:
Hello all.

I'm new to microcontroller development, and recently I bought a EZ-430 Chronos 433. After some use (without development) I note that, after be in acc mode, pressing "V", the watch was rebooted. Reading some posts, I replaced the battery, but now, the LCD screen is off. I measured the voltage, and it's ok. Also, I tried to connect via USB like a develop device, but the screen again is blank. What I'm doing wrong? Did I break my watch?

--
You received this message because you are subscribed to the Google Groups "TI Chronos Development" group.
To unsubscribe from this group and stop receiving emails from it, send an email to ti-chronos-development-+unsubscr...@googlegroups.com.
To post to this group, send email to ti-chronos-...@googlegroups.com.
Visit this group at https://groups.google.com/group/ti-chronos-development-.
For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "TI Chronos Development" group.
To unsubscribe from this group and stop receiving emails from it, send an email to ti-chronos-development-+unsub...@googlegroups.com.
To post to this group, send email to ti-chronos-development-@googlegroups.com.

Fernando Ginez da Silva

unread,
Sep 11, 2016, 4:47:25 PM9/11/16
to ti-chronos-...@googlegroups.com
Hi Fabio,

I had this same issue when trying to update firmware thru wireless link...

When you've connected to USB port, have you tried to re-write flash contents?

Does the download utility recognize the watch?

Regards,

Fernando Ginez.



_____________________________________________
Fernando Ginez da Silva
>>>> an email to ti-chronos-develo...@googlegroups.com.
>>>> To post to this group, send email to ti-chronos-...@googlegroups.com.
>>>> Visit this group at
>>>> https://groups.google.com/group/ti-chronos-development-.
>>>> For more options, visit https://groups.google.com/d/optout.
>>>
>>>
>> --
>> You received this message because you are subscribed to the Google Groups
>> "TI Chronos Development" group.
>> To unsubscribe from this group and stop receiving emails from it, send an
>> email to ti-chronos-develo...@googlegroups.com.
>> To post to this group, send email to
>> ti-chronos-...@googlegroups.com.
>> Visit this group at
>> https://groups.google.com/group/ti-chronos-development-.
>> For more options, visit https://groups.google.com/d/optout.
>
>
> --
> You received this message because you are subscribed to the Google Groups
> "TI Chronos Development" group.
> To unsubscribe from this group and stop receiving emails from it, send an
> email to ti-chronos-develo...@googlegroups.com.

Fabio Brolesi

unread,
Sep 24, 2016, 2:30:45 PM9/24/16
to TI Chronos Development
Hello all!

I can see the device in USB list and in SmartRF Studio 7.

How can I try to reset the firmware? I'm completly new in this area.

Thanks in advice!
>>>> To post to this group, send email to ti-chronos-...@googlegroups.com.
>>>> Visit this group at
>>>> https://groups.google.com/group/ti-chronos-development-.
>>>> For more options, visit https://groups.google.com/d/optout.
>>>
>>>
>> --
>> You received this message because you are subscribed to the Google Groups
>> "TI Chronos Development" group.
>> To unsubscribe from this group and stop receiving emails from it, send an
>> To post to this group, send email to
>> ti-chronos-...@googlegroups.com.
>> Visit this group at
>> https://groups.google.com/group/ti-chronos-development-.
>> For more options, visit https://groups.google.com/d/optout.
>
>
> --
> You received this message because you are subscribed to the Google Groups
> "TI Chronos Development" group.
> To unsubscribe from this group and stop receiving emails from it, send an

Tamer Çelik

unread,
Sep 24, 2016, 3:08:25 PM9/24/16
to ti-chronos-...@googlegroups.com
Hello Fabio,

Just deploy original software to watch.
http://www.ti.com/lit/zip/slac341

You need compser studio for this.

Please see wiki http://processors.wiki.ti.com/index.php/EZ430-Chronos



>>>> To post to this group, send email to ti-chronos-...@googlegroups.com.
>>>> Visit this group at
>>>> https://groups.google.com/group/ti-chronos-development-.
>>>> For more options, visit https://groups.google.com/d/optout.
>>>
>>>
>> --
>> You received this message because you are subscribed to the Google Groups
>> "TI Chronos Development" group.
>> To unsubscribe from this group and stop receiving emails from it, send an
>> To post to this group, send email to
>> ti-chronos-...@googlegroups.com.
>> Visit this group at
>> https://groups.google.com/group/ti-chronos-development-.
>> For more options, visit https://groups.google.com/d/optout.
>
>
> --
> You received this message because you are subscribed to the Google Groups
> "TI Chronos Development" group.
> To unsubscribe from this group and stop receiving emails from it, send an
> To post to this group, send email to
> ti-chronos-...@googlegroups.com.
> Visit this group at https://groups.google.com/group/ti-chronos-development-.
> For more options, visit https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "TI Chronos Development" group.
To unsubscribe from this group and stop receiving emails from it, send an email to ti-chronos-development-+unsub...@googlegroups.com.
To post to this group, send email to ti-chronos-development-@googlegroups.com.

Fernando Ginez da Silva

unread,
Sep 28, 2016, 12:07:49 PM9/28/16
to ti-chronos-...@googlegroups.com
Fabio,

As Tamer instructed you, the Ez430-Chronos wiki have all the
information you need.

From the software perspective you just need to install the supplied
SDK, disassemble the watch, connect it to you PC using the debug usb
stick, and finally download the original firmware.

After all these steps, if you still have problems, unfortunately maybe
it's a hardware issue.. this situation will be a bit more difficult to
resolve, and maybe it's a good idea to consider a brand new part as
replacement.

I wish you luck.

Regards,

_____________________________________________
Fernando Ginez da Silva



>>> >>>> an email to ti-chronos-develo...@googlegroups.com.
>>> >>>> To post to this group, send email to
>>> >>>> ti-chronos-...@googlegroups.com.
>>> >>>> Visit this group at
>>> >>>> https://groups.google.com/group/ti-chronos-development-.
>>> >>>> For more options, visit https://groups.google.com/d/optout.
>>> >>>
>>> >>>
>>> >> --
>>> >> You received this message because you are subscribed to the Google
>>> >> Groups
>>> >> "TI Chronos Development" group.
>>> >> To unsubscribe from this group and stop receiving emails from it, send
>>> >> an
>>> >> email to ti-chronos-develo...@googlegroups.com.
>>> >> To post to this group, send email to
>>> >> ti-chronos-...@googlegroups.com.
>>> >> Visit this group at
>>> >> https://groups.google.com/group/ti-chronos-development-.
>>> >> For more options, visit https://groups.google.com/d/optout.
>>> >
>>> >
>>> > --
>>> > You received this message because you are subscribed to the Google
>>> > Groups
>>> > "TI Chronos Development" group.
>>> > To unsubscribe from this group and stop receiving emails from it, send
>>> > an
>>> > email to ti-chronos-develo...@googlegroups.com.
>>> > To post to this group, send email to
>>> > ti-chronos-...@googlegroups.com.
>>> > Visit this group at
>>> > https://groups.google.com/group/ti-chronos-development-.
>>> > For more options, visit https://groups.google.com/d/optout.
>>
>> --
>> You received this message because you are subscribed to the Google Groups
>> "TI Chronos Development" group.
>> To unsubscribe from this group and stop receiving emails from it, send an
>> email to ti-chronos-develo...@googlegroups.com.
>> To post to this group, send email to
>> ti-chronos-...@googlegroups.com.
>> Visit this group at
>> https://groups.google.com/group/ti-chronos-development-.
>> For more options, visit https://groups.google.com/d/optout.
>
>
> --
> You received this message because you are subscribed to the Google Groups
> "TI Chronos Development" group.
> To unsubscribe from this group and stop receiving emails from it, send an
> email to ti-chronos-develo...@googlegroups.com.
Reply all
Reply to author
Forward
0 new messages