Grafana Chrome Processes issue related to Grafana Image Renderer Plugin

Skip to first unread message

Bruno Algarvio

Feb 7, 2023, 5:12:50 AM2/7/23
to Thruk


I'm having issues with these grafana chrome processes on OMD 4.60.0. I was hoping to upgrade to 5.0.0 to solve this issue but it seems that there are other people with the same problem on the new version.
There are hundreds of chrome processes being created automatically on my server making the memory load increase a lot and sometimes making the server crash.

My server:
-SLES 12 (in order to upgrade to 5.0.0 I know that I have upgrade the OS to SLES 15)
-Grafana version 7.5.13
-Grafana Image Renderer Plugin - 3.6.2 (I tried older versions, like 2.1.1, but still got these hundreds of chrome processes being created)

How can we fix this issue? Is it any problem with the Grafana Image Renderer plugin or any extra configuration needed on grafana?

Don't know if this is the correct channel to ask about this issue but I give it a shot.. Would be good to get some feedback on this

Also there is a opened topc about this issue on OMD GitHub but it seems they are "ignoring" this issue for a bit of time..

Thanks in advance!


Sven Nierlein

Feb 7, 2023, 5:24:29 AM2/7/23
to, Bruno Algarvio

we are not ignoring this. In fact i am working on it. It's just not that easy to reproduce here.

> --
> You received this message because you are subscribed to the Google Groups "Thruk" group.
> To unsubscribe from this group and stop receiving emails from it, send an email to <>.
> To view this discussion on the web visit <>.

Bruno Algarvio

Feb 7, 2023, 5:54:51 AM2/7/23
to Thruk
Hi Sven,

Thank you for the quick reply. I believe it's very hard to reproduce this issue... It's hard to understand why I'm having these issues and other colleagues with same Server specs, grafana/grafana plugin version don't.

From the troubleshoot I did I can only say it's related to the Image Renderer Plugin but I still didnt found the cause. I tried to add some configurations on the Rendering section of Grafana.ini config file but it did not help.

The configs I added were this:

Let me know if I can provide any more information to help you on your troubleshoot.

Thanks in advance!

Many thanks,

Bruno Algarvio

Feb 14, 2023, 7:28:46 AM2/14/23
to Thruk
Hi Sven,

Any news for this issue?

Best Regards,
Reply all
Reply to author
0 new messages