[PATCH] doc: bump required Qt/PyQt version to 5.11

4 views
Skip to first unread message

Yuya Nishihara

unread,
Apr 8, 2022, 12:37:35 AMApr 8
to thg...@googlegroups.com
# HG changeset patch
# User Yuya Nishihara <yu...@tcha.org>
# Date 1649392573 -32400
# Fri Apr 08 13:36:13 2022 +0900
# Node ID 59f05bb009e912d107390a0518ac39816b00751c
# Parent 9c993052470a9ef0617195c73c087fca6f7fc087
doc: bump required Qt/PyQt version to 5.11

According to the following comment, PyQt 5.11 is required for the scoped
enum, and requiring Qt 5.11 (or 5.12 LTS) seems reasonable.

https://github.com/qutebrowser/qutebrowser/issues/5904

diff --git a/CONTRIBUTING.txt b/CONTRIBUTING.txt
--- a/CONTRIBUTING.txt
+++ b/CONTRIBUTING.txt
@@ -14,8 +14,8 @@ if later versions of a library are found
application is still reasonably usable with the base library versions listed
below.

-PyQt: 4.7.5
-Qt: 4.6
+PyQt: 5.11
+Qt: 5.11

=== Mercurial version ===


Matt Harbison

unread,
Apr 8, 2022, 1:09:03 AMApr 8
to TortoiseHg Developers
I guess this is OK.  FTR, the Windows and macOS apps are bundled with Qt5.9.9, PyQt5.13.2, and sip 4.19.20.  The scoped enums work there.

I just pip installed on CentOS 7 from contrib/packaging/venv_py3/requirements-centos7.txt.in, and got

>>> from PyQt5.QtCore import *
>>> print(QT_VERSION_STR)
5.12.3
>>> print(PYQT_VERSION_STR)
5.12.2
>>> from PyQt5.sip import *
>>> print(SIP_VERSION_STR)
6.5.1

I've had trouble installing PyQt6 from pypi on Ubuntu 18.04, so maybe there will be systems that PyQt5 won't install on from pypi, but it seems safe if it works on CentOS 7.

Yuya Nishihara

unread,
Apr 9, 2022, 6:40:06 AMApr 9
to 'Matt Harbison' via TortoiseHg Developers
On Thu, 7 Apr 2022 22:09:02 -0700 (PDT), 'Matt Harbison' via TortoiseHg Developers wrote:
> On Friday, April 8, 2022 at 12:37:35 AM UTC-4 yu...@tcha.org wrote:
>
> > # HG changeset patch
> > # User Yuya Nishihara <yu...@tcha.org>
> > # Date 1649392573 -32400
> > # Fri Apr 08 13:36:13 2022 +0900
> > # Node ID 59f05bb009e912d107390a0518ac39816b00751c
> > # Parent 9c993052470a9ef0617195c73c087fca6f7fc087
> > doc: bump required Qt/PyQt version to 5.11

Pushed this.

> I just pip installed on CentOS 7 from
> contrib/packaging/venv_py3/requirements-centos7.txt.in, and got
>
> >>> from PyQt5.QtCore import *
> >>> print(QT_VERSION_STR)
> 5.12.3
> >>> print(PYQT_VERSION_STR)
> 5.12.2
> >>> from PyQt5.sip import *
> >>> print(SIP_VERSION_STR)
> 6.5.1
>
> I've had trouble installing PyQt6 from pypi on Ubuntu 18.04, so maybe there
> will be systems that PyQt5 won't install on from pypi, but it seems safe if
> it works on CentOS 7.

Yeah.
Reply all
Reply to author
Forward
0 new messages