RubyRacer Installation Issue

92 views
Skip to first unread message

Srikanth

unread,
Jun 4, 2015, 9:55:22 AM6/4/15
to therub...@googlegroups.com
Hi Everone
 
My end goal is to find interface where i can write / call Ruby code in .JS(Protractor) and vice-versa. .JS code in Ruby File
 
I found that therubyracer is one can be used for this
 
I am getting some problems when i instal rubyracer gem in windows 7 machine eventhough i have python installed with proper environment variables set
 
gem install therubyracer
Temporarily enhancing PATH to include DevKit...
Building native extensions.  This could take a while...
ERROR:  Error installing therubyracer:
        ERROR: Failed to build gem native extension.
    C:/Ruby/bin/ruby.exe extconf.rb
creating Makefile
The system cannot find the path specified.
The system cannot find the path specified.
The system cannot find the path specified.
C:/Ruby/lib/ruby/gems/1.9.1/gems/libv8-3.16.14.7/ext/libv8/builder.rb:68:in `set
up_python!': libv8 requires python 2 to be installed in order to build, but it i
s currently not available (RuntimeError)
        from C:/Ruby/lib/ruby/gems/1.9.1/gems/libv8-3.16.14.7/ext/libv8/builder.
rb:52:in `block in build_libv8!'
        from C:/Ruby/lib/ruby/gems/1.9.1/gems/libv8-3.16.14.7/ext/libv8/builder.
rb:49:in `chdir'
        from C:/Ruby/lib/ruby/gems/1.9.1/gems/libv8-3.16.14.7/ext/libv8/builder.
rb:49:in `build_libv8!'
        from C:/Ruby/lib/ruby/gems/1.9.1/gems/libv8-3.16.14.7/ext/libv8/location
.rb:24:in `install!'
        from extconf.rb:7:in `<main>'

Gem files will remain installed in C:/Ruby/lib/ruby/gems/1.9.1/gems/libv8-3.16.1
4.7 for inspection.
Results logged to C:/Ruby/lib/ruby/gems/1.9.1/gems/libv8-3.16.14.7/ext/libv8/gem
_make.out
 
 
Could someone help me on this.
 
Thanks
Srikanth.K
Reply all
Reply to author
Forward
0 new messages