Build Issues

40 views
Skip to first unread message

Pradeep Kumar Singh

unread,
Aug 15, 2022, 10:33:41 AM8/15/22
to testng-users
  Hi Team,
I am creating a New build and then displaying this error please help me.

[ERROR] Failed to execute goal org.apache.rat:apache-rat-plugin:0.13:check (rat-check) on project demowithMaven: Too many files with unapproved license: 47 See RAT report in: C:\Users\Pradeep Kumar Singh\eclipse-workspaceTraning\demowithMaven\target\rat.txt -> [Help 1]
[ERROR]
[ERROR] To see the full stack trace of the errors, re-run Maven with the -e switch.
[ERROR] Re-run Maven using the -X switch to enable full debug logging.
[ERROR]
[ERROR] For more information about the errors and possible solutions, please read the following articles:
[ERROR] [Help 1] http://cwiki.apache.org/confluence/display/MAVEN/MojoFailureException

Krishnan Mahadevan

unread,
Aug 15, 2022, 11:34:47 AM8/15/22
to testng...@googlegroups.com
The plugin

org.apache.rat:apache-rat-plugin

Is not maintained by TestNG. You might want to look up the documentation of this plugin to understand what causes failures. 




Thanks & Regards
Krishnan Mahadevan

"All the desirable things in life are either illegal, expensive, fattening or in love with someone else!"

From: testng...@googlegroups.com <testng...@googlegroups.com> on behalf of Pradeep Kumar Singh <pradee...@navyuginfo.com>
Sent: Monday, August 15, 2022 12:10:54 PM
To: testng-users <testng...@googlegroups.com>
Subject: [testng-users] Build Issues
 
--
You received this message because you are subscribed to the Google Groups "testng-users" group.
To unsubscribe from this group and stop receiving emails from it, send an email to testng-users...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/testng-users/a1639c61-699e-465b-9303-fcb1e09b8bb3n%40googlegroups.com.

Pradeep Kumar Singh

unread,
Aug 16, 2022, 5:23:30 AM8/16/22
to testng-users
Hello,
Fixed those problems but currently displaying these errors.
If I run "mvn compile" command.

C:\Users\Pradeep Kumar Singh\eclipse-workspaceTraning\demowithMaven>mvn compile
[INFO] Scanning for projects...
[INFO]
[INFO] --------------------< MavenPractices:demowithMaven >--------------------
[INFO] Building Mavenjava 1.0-SNAPSHOT
[INFO] --------------------------------[ jar ]---------------------------------
[INFO]
[INFO] --- maven-resources-plugin:2.6:resources (default-resources) @ demowithMaven ---
[WARNING] Using platform encoding (Cp1252 actually) to copy filtered resources, i.e. build is platform dependent!
[INFO] skip non existing resourceDirectory C:\Users\Pradeep Kumar Singh\eclipse-workspaceTraning\demowithMaven\src\main\resources
[INFO]
[INFO] --- maven-compiler-plugin:3.1:compile (default-compile) @ demowithMaven ---
[INFO] Changes detected - recompiling the module!
[WARNING] File encoding has not been set, using platform encoding Cp1252, i.e. build is platform dependent!
[INFO] Compiling 1 source file to C:\Users\Pradeep Kumar Singh\eclipse-workspaceTraning\demowithMaven\target\classes
[INFO] -------------------------------------------------------------
[ERROR] COMPILATION ERROR :
[INFO] -------------------------------------------------------------
[ERROR] Source option 5 is no longer supported. Use 6 or later.
[ERROR] Target option 1.5 is no longer supported. Use 1.6 or later.
[INFO] 2 errors
[INFO] -------------------------------------------------------------
[INFO] ------------------------------------------------------------------------
[INFO] BUILD FAILURE
[INFO] ------------------------------------------------------------------------
[INFO] Total time:  4.669 s
[INFO] Finished at: 2022-08-16T14:43:53+05:30
[INFO] ------------------------------------------------------------------------
[ERROR] Failed to execute goal org.apache.maven.plugins:maven-compiler-plugin:3.1:compile (default-compile) on project demowithMaven: Compilation failure: Compilation failure:
[ERROR] Source option 5 is no longer supported. Use 6 or later.
[ERROR] Target option 1.5 is no longer supported. Use 1.6 or later.
[ERROR] -> [Help 1]

[ERROR]
[ERROR] To see the full stack trace of the errors, re-run Maven with the -e switch.
[ERROR] Re-run Maven using the -X switch to enable full debug logging.
[ERROR]
[ERROR] For more information about the errors and possible solutions, please read the following articles:
[ERROR] [Help 1] http://cwiki.apache.org/confluence/display/MAVEN/MojoFailureException

C:\Users\Pradeep Kumar Singh\eclipse-workspaceTraning\demowithMaven>

⇜Krishnan Mahadevan⇝

unread,
Aug 16, 2022, 5:25:23 AM8/16/22
to testng...@googlegroups.com
Please fix your Java versions

[ERROR] Source option 5 is no longer supported. Use 6 or later.
[ERROR] Target option 1.5 is no longer supported. Use 1.6 or later.

Thanks & Regards
Krishnan Mahadevan

"All the desirable things in life are either illegal, expensive, fattening or in love with someone else!"

Bharat Gupta

unread,
Aug 16, 2022, 10:30:33 AM8/16/22
to testng...@googlegroups.com
change the JDk version in java build path it will be solved

On Tue, Aug 16, 2022 at 2:53 PM Pradeep Kumar Singh <pradee...@navyuginfo.com> wrote:
Reply all
Reply to author
Forward
0 new messages