TestNG 7.0.1 java.lang.ClassNotFoundException: com.google.inject.Stage

Skip to first unread message

S Sachs

Jan 14, 2020, 2:50:50 AM1/14/20
to testng-dev
Version:   TestNG org.testng.eclipse.feature.group Cedric Beust
Eclipse Platform 4.14.0.v20191210-0610 org.eclipse.platform.feature.group Eclipse.org
Windows 10

I had upgraded/updated TestNG using the Eclipse "Check for Update" feature.
Unfortunately, I cannot run any TestNG Test/Suite anymore.

As suggested, I created a new Java Project, added the TestNG library, and Example1 code.
Which is zipped up and attached to this.

When I tried to run it, I got the same error as with my regular code.

[RemoteTestNG] detected TestNG version 7.0.1
Exception in thread "main" java.lang.NoClassDefFoundError: com/google/inject/Stage
at org.testng.internal.Configuration.<init>(Configuration.java:33)
at org.testng.TestNG.init(TestNG.java:216)
at org.testng.TestNG.<init>(TestNG.java:200)
at org.testng.remote.AbstractRemoteTestNG.<init>(AbstractRemoteTestNG.java:17)
at org.testng.remote.support.RemoteTestNG6_12.<init>(RemoteTestNG6_12.java:18)
at org.testng.remote.support.RemoteTestNGFactory6_12.createRemoteTestNG(RemoteTestNGFactory6_12.java:16)
at org.testng.remote.RemoteTestNG.main(RemoteTestNG.java:67)
Caused by: java.lang.ClassNotFoundException: com.google.inject.Stage
at java.base/jdk.internal.loader.BuiltinClassLoader.loadClass(BuiltinClassLoader.java:604)
at java.base/jdk.internal.loader.ClassLoaders$AppClassLoader.loadClass(ClassLoaders.java:178)
at java.base/java.lang.ClassLoader.loadClass(ClassLoader.java:521)
... 7 more

 If I "downgrade to 6.14.3, it works as expected, but 7.x is having issues for me.

It would seem that com.google.inject.stage (which I am not familiar with) is missing.
Was it a dependency that did not get included?

Cédric Beust ♔

Jan 14, 2020, 3:30:29 AM1/14/20
to testn...@googlegroups.com
Can you try `7.1.1-SNAPSHOT` from the repo https://oss.sonatype.org/content/repositories/snapshots ?


You received this message because you are subscribed to the Google Groups "testng-dev" group.
To unsubscribe from this group and stop receiving emails from it, send an email to testng-dev+...@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/testng-dev/d0ece669-2898-48ad-b9f2-0a7438bafa75%40googlegroups.com.

Julien Herr

Jan 14, 2020, 3:38:33 AM1/14/20
to testng-dev

There is no more snapshot since <text>7.0.0-SNAPSHOT</text><lastModified>2019-08-25 05:24:42.0 UTC</lastModified>

It looks something is wrong in the snapshot publication.

S Sachs

Jan 14, 2020, 11:32:24 AM1/14/20
to testng-dev
I tried, but I only see "Directory listing forbidden"
Reply all
Reply to author
0 new messages