Eclipse install site for TestNG 7.4 is corrupted

36 views
Skip to first unread message

Lee Rhodes

unread,
Feb 6, 2024, 12:18:31 AMFeb 6
to testng-dev
Attempting to install TestNG 7.4 so I can test Java 8 software fails.

installs a compositeContent1237988731.xml file into 
.p2/org.eclipse.equinox.p2.repository/cache/

When Eclipse attempts to read this file it issues the Error:

Unable to read repository at file:/Users/XXX/.p2/org.eclipse.equinox.p2.repository/cache/compositeContent1237988731.xml.  Attribute name "crossorigin" associated with an element type "link" must be followed by the ' = ' character.

Opening the xml file, a misplaced "crossorigin" can be found near the end of line 25.

I think this may be the problem.

Nonetheless,  believe it or not, there are many systems that still need to run on Java 8,
And being able to load TestNG 7.4 into Eclipse is the only way to get Eclipse and TestNG to work now with Java 8.  Unless I have to go to even older TestNG versions!!  

Please fix!



Julien Herr

unread,
Feb 7, 2024, 12:57:27 PMFeb 7
to testng-dev
Hi,

Thanks for the warning.

I'm sad to read some devs are still blocked with Java8 but the team is too small to be able to support old versions and we consider that a company that can pay support for old JDKs, can offer a few times of its devs to support the free and open tools they use.

As you mentioned, the repository is public, and anyone can propose fixes. Feel free to propose yours and we will be happy to accept it.

Please contribute!
Reply all
Reply to author
Forward
0 new messages