Taking a foto at reglar intervals, tasker log says done, but no foto taken (or saved)?

31 views
Skip to first unread message

Peter Hunkeler

unread,
Nov 26, 2021, 4:35:11 AM11/26/21
to Tasker
I've got the need to take a foto at regular intervals, i.e. every 3 minutes: Thought I could do this with my old Samsung J5 (Android 9), so I was looking for an app and found Tasker. I've installed the free version to try this, before buying.

So I created a profile with "time 00.00 to 23:59 every 3 minutes". Then I attached a task with 3 actions to it: 1. beep, 2 take foto, 3. beep.

First the task only had the "take foto" action, but since it doesn't work reliably, I added the beeps.

So, I enable that profile and watch what happens. After hearing hearing the beeps, I check the gallery, and there is a new photo. And so there may be a second, or third time.

Then I leave the phone alone, coming back after an hour. Sadly, there are no fotos from the last hour.

I've tried several times, and I tried with PIN locked phone as well as with no PIN lock. I checked that there is no battery optimization, and than tasker is allowed to run in the backgound, and all the other Android setting  as advise by Tasker -> 3dot menu -> more -> Android settings.

I started the log (run log), and in there, I do see "ok" entries for all three actions, no error messages. But still no photos (after the first interval). I recognize it takes 17 seconds to hear the second beep, so the "take foto" seems to last a bit.

Should this work at all?
What settings would I need to check additionally?
Any other hint?

Any more information I should post here?

taker-02.jpg
taker-01.jpg
taker-04.jpg
taker-03.jpg

Manuel Holz

unread,
Nov 26, 2021, 5:42:46 PM11/26/21
to Tasker
it works fine for me (Android 12). Did you look in the folder "...\DCIM\Tasker". Thats where the photos are saved by standard, and maybe your galery don't like to show them.

Peter Hunkeler

unread,
Nov 27, 2021, 4:56:47 AM11/27/21
to Tasker
Yes, I had a look in all folders under DCIM. Nothing there, except from the first on, or two fotos.
There must be some setting either in Tasker or on Android is wrong, just don't have a clue what it could be.

Tasker, as per log, really think it has taken a foto, but non are found.
Reply all
Reply to author
Forward
0 new messages