Plug In Power - Offer Menu Choice - Car/Home/Night Mode

644 views
Skip to first unread message

konradwalsh

unread,
Aug 9, 2010, 4:23:33 PM8/9/10
to Tasker
Hey folks,

thanks to a lot of help given to me here i decided to post up
something i have done with my HTC Desire using tasker.

I have a set up where I plug in the power cable - either car or home
power
Screen unlocks
A menu pops up and Says Choose car home or night mode

If i press car mode
It says car mode chosen with GPS and BT active
In the background it turns on GPS and bluetooth
brightens the screen up to full
Turns up volume for in call volume and system volume
and then loads the Google car app for navigation whilst driving

Unplug undoes all of the above and brings me back to home screen

Similar idea for Home and NIght mode

Anyway.. if any of you would like a copy of my tasks and profiles or
want to know how i did it, then let me know.

Some of the guys that helped me here with this did say I would into
problems when unplugging to turn everything off. I got around this by
just creating a defaults task as my exit task.

Finally, is there anything I didnt think of? Some way to make all this
even better?

replicant

unread,
Aug 9, 2010, 4:32:12 PM8/9/10
to Tasker
Yes please, this is exactly what I posted I'm doing with some small
variations. Maybe the dialog making you choose which mode is what i'm
missing. Mind posting your profile?

THanks!

konradwalsh

unread,
Aug 9, 2010, 5:22:26 PM8/9/10
to Tasker
Yes of course.. I will do this tomorrow.. heading to bed now.

Robicheaux

unread,
Aug 9, 2010, 6:22:55 PM8/9/10
to Tasker
Oh me too, i´d like a copy.
thank you very much, very helpful.

pntless

unread,
Aug 9, 2010, 10:40:45 PM8/9/10
to Tasker
Would love to get this as well.
Thanks

Nigel Roy

unread,
Aug 10, 2010, 3:58:09 AM8/10/10
to Tasker

I had been thinking of doing this myself but if you already have one
that would be great, would appreciate a copy.

Thanks

BossMan

unread,
Aug 10, 2010, 4:25:25 AM8/10/10
to Tasker
Maybe you could put that in the twiki and link it in this thread?

BR,
A.

konradwalsh

unread,
Aug 10, 2010, 6:05:08 AM8/10/10
to Tasker
Ok.. I will now work on the wiki to include it and post back here when
its done.. if all goes well it'll be ready in 30-60 mins

konradwalsh

unread,
Aug 10, 2010, 6:53:15 AM8/10/10
to Tasker
Ok - Its done

PENT - Are you okay with this? Please let me know if there are issues
with it

http://tasker.wikidot.com/powerplugin


I am open to comments on what you would change and how you may make
it better

Jean-Marc Maury

unread,
Aug 10, 2010, 7:26:54 AM8/10/10
to Tasker
Brilliant! I already have created car/night mode profiles but was
struggling as to how to trigger given that I didn't/can't see the
mechanism to put my Desire (FroYo) into car/desk mode other than
orientation, the menu selection idea upon powering up is simple and
brilliant, I'll modify my scripts to accommodate!

Some ideas (from what I have in mine):
Car mode - upon exiting, launches FourSquare so that I can check-in
upon arrival. I also log the GPS location so that if I need to I can
find the car afterwards. I want to amend this to be able to store a
couple of locations e.g. arriving at an airport car park needs "long
term" storage so that if you go to another destination and hire a car
you will probably need to remember where you parked during your
holiday but not "forget" where it is in the airport!

Night mode - upon exiting, as I'm usually still in bed trying to wake
up!, I play "wake-up" music for 15 minutes (random files from a music
directory) plus auto launch GMail to check overnight messages. Another
mod here would be to choose what gets fired up GMail, Twitter,
LinkedIn or Facebook as I like to check all in the morning anyway

Thanks again for the power menu select inspiration!

konradwalsh

unread,
Aug 10, 2010, 7:35:02 AM8/10/10
to Tasker
Glad you appreciate my work..
to be honest.. I havent developed the task beyond car mode in detail..
I will spend time this week making home mode and night mode better. I
like your ideas. Thanks

Jt

unread,
Aug 15, 2010, 3:16:33 AM8/15/10
to Tasker
Excuse me if you receive this message twice....

I was trying to set this up on my DInc, however when I go to import
the profile I get the following message:error: Import (profile
download from tasker wiki) :ignoring import task with existing name:.
After I exit the app I then get the following error message: Data
integrity problems found and repaired.

Any help would be appreciated.

Thanks in advance.

JT

konradwalsh

unread,
Aug 15, 2010, 9:36:28 AM8/15/10
to Tasker
Hey...
I am not sure but could you try backing up your profiles.. then remove
them all and try importing then.. see if its really a conflict and
something else is wrong?

Shadowex3

unread,
Aug 15, 2010, 11:48:43 PM8/15/10
to Tasker
I'm probably missing the obvious but how did you get the menu dialogue
to begin with? I can only think of creating a Menu Task full of
Perform Tasks with a Stop at the end so the names show up.

Jt

unread,
Aug 16, 2010, 12:52:58 AM8/16/10
to Tasker
I was able to add the profile after backing up and clearing my current
ones. However, I was not able to add my original profiles without
erasing this profile. Fortunately, I only had a couple and they were
able to recreate. Not sure which profile was the culprit but thanks
again for your help.

BossMan

unread,
Aug 16, 2010, 6:44:18 AM8/16/10
to Tasker
One of your profiles/tasks has the same name as a task/profile you
were trying to import. Best way to resolve it:
1) backup your current config and then erase everything,
2) import new profiles/tasks and check/note down their names,
3) erase everything and restore your backup,
4) check your profiles/tasks names and do cross-checking with the
names of the to-be-imported tasks/profiles,
5) modify any conflicting names,
6) import again new profiles/tasks

:-)

BR,
A.

BossMan

unread,
Aug 16, 2010, 6:45:51 AM8/16/10
to Tasker
a) you can download the config and check :)
b) my guess: it was done using Alert->PopupTaskNames action

BR,
A.

konradwalsh

unread,
Aug 16, 2010, 10:55:58 AM8/16/10
to Tasker
Yes.. i have since learned that it would have been better to name teh
tasks with an inclusive random number to ensure they wouldnt
conflict..

Bossman your kinda right..

I managed the menu by create a menu task that lists each option as
perform task..

when its run its pops up a menu with the icon for each task...

jmmaury

unread,
Aug 16, 2010, 2:45:19 PM8/16/10
to Tasker
Nope - that's it exactly...
I did refine my menu though and applied icons to the individual tasks
that appear in the menu. That way I could lose the stop statement but
have representative icons come up instead.

Jeremiah

unread,
Aug 19, 2010, 10:27:46 AM8/19/10
to Tasker
I'm trying to do this from the Wiki instructions..but I don't have a
Tasker/Tasks directory???
> > Perform Tasks with a Stop at the end so the names show up.- Hide quoted text -
>
> - Show quoted text -

Jeremiah

unread,
Aug 19, 2010, 10:42:22 AM8/19/10
to Tasker
Okay re-read the Wiki and realized I needed to create the folder. but
now when I plug in power, i get a popup that says Task doesn't exist -
Mode Menu
> > - Show quoted text -- Hide quoted text -

fullwave2

unread,
Aug 31, 2010, 8:47:17 PM8/31/10
to Tasker
You'll have to excuse me as I am a bit of a newbie with this
application. I followed the wiki completely, creating the necessary
folder and extracted the files to the correct folders. I then
imported the tasks as detailed one by one. Then moved to profiles and
attempted to import the profile. I have not created any profiles
previously or tasks as this particular task was worth the purchase.
Upon attempting to import the profile "Power Plug in" I get the same
error referenced above "ignoring import task of the same name" or
something to that affect as the error runs by a bit too quickly for me
to pick it up. Exiting the application gives a warning of data
integrity errors being repaired.
Is there a correction for this? Since this was the first one I
attempted, I tried uninstalling the tasker app (refund, thank you -
didn't realize that was going to happen), deleted the folders,
reinstalled the application (repurchased) and started fresh. Same
error.

I would really like to use this task. Is there a fix I can apply? I
re-read the comments above but didn't see a solution that I could
understand and apply. I've edited a few XML files in my past but I am
not an expert. Can someone give me the steps to make this work on my
Android X running 2.1?
Thanks.
Bob


konradwalsh

unread,
Sep 1, 2010, 5:54:30 AM9/1/10
to Tasker
hi
you could try and rename the profile filename...

Pent

unread,
Sep 1, 2010, 6:18:02 AM9/1/10
to Tasker
I'll try this myself later and get back to you.

Could you check you have the latest Tasker version though, 1.0.8. (see
Menu / Info / About)

Pent

On Sep 1, 1:47 am, fullwave2 <w8ny...@gmail.com> wrote:

fullwave2

unread,
Sep 1, 2010, 8:49:20 AM9/1/10
to Tasker
Thanks for the responses. I do have version 1.0.8m. I tried a little
debugging last night and was able to get to the point where the icons
appear and you need to select your mode. There were two errors
listed. Once relative to the locale for text to speech. I made sure
text to speech was installed via "accessability" and changed the local
to eng-USA. Still get the error. Also get an error thaat the HTC
World Clock is not installed. Mine is a Moto Droid X so did install
that to fix. Was going to see if there was an edit I needed to do to
adjust the type of clock being called. That's about where I am right
now.
Thanks.
Bob
> > Bob- Hide quoted text -

fullwave2

unread,
Sep 1, 2010, 9:35:14 AM9/1/10
to Tasker
Fixed the speech. There were a couple other places where I needd to
update the locale. Only issue I have is th eHTC World Clock issue
mentioned above.
Tasker is a great app. Definetely worth the money. Hope Froyo 2.2
doesn't break it when it gets pushed in September to the Droid X. I
love the flexibility of making the X do what I want it to do. My wife
uses an X and I constantly get "why can't it do this?". Now it's
"give me your phone sweatheart and I'll see what I can do."
Thanks.
Bob

Pent

unread,
Sep 1, 2010, 2:38:10 PM9/1/10
to Tasker
konrad,

the problem comes when you install the Power Plugin task, and then
afterwards the Profile. The Profile already has the task attached to
it so there's a conflict.

Unfortunately Tasker handles the conflict badly, I'll fix that.

Pent

FReyes

unread,
Sep 1, 2010, 4:17:52 PM9/1/10
to Tasker
I also had problems when I first installed this profile. This, I
believe, is due to how these tasks and profiles are loaded into tasker
when downloaded from the wiki. It was not until I realized that two
tasks (an enter task and an exit task) needed to be "connected" to the
power plug in profile.

Your profile should look like this after you download it and install
it into tasker. You might need to fix it to look like this:

Profile: Power Plug In
Context: Power Plugged in: Task: Power Plug In
Context:Time, from 5:00 Till 22:51: Exit Task: Standard Mode (All Off)

Sometimes, either the context or one of the tasks is missing. The task
will not run properly until fixed.

Sorry my phone is not rooted, otherwise I would post a pic.

The stock car dock program will run, using the task in its as-
downloaded condition. You can change the Run APP operation in the car
mode task to any alternative car dock program. Two alternatives that
are in the Android Market are "Custom Car Home" and "Car Dock". I
prefer CCH as it handles icons better.

Some things I have learned: If you use Sprint Navagation, Tasker will
not be able to modify the media volume from within Tasker. I am still
playing with an app called Volume Toggle. It may be able to interface
with Tasker (has a locale plug-in). Right now I either have to press
the volume up button after sprint navigation starts, or press the
Volume Toggle widget to raise the volume up for sprint navigation.
Google nav. voice sounds too mechanical for me, so I rarely use it

fullwave2

unread,
Sep 1, 2010, 9:20:49 PM9/1/10
to Tasker
Thanks FReyes. I'm finding the issues as well as I play with this.
Sometimes the voice Say commands work and sometimes they don't. I
don't mind th etechnical voice on the Navigate having put up with a
Garmin Nuv 780 which just got recalled by Garmin. Being a bit older,
my ears pick up the harsh sounding voice anyway.
I use a Parrot hands free kit in the car which worked perfectly with
my BlackBerry. Never had to think about it. Just remote started the
truck and by the time I was in the truck, I was already paired and
taking calls through the truck speakers. With the Droid now, at least
when I dock it the routine does turn on my BT which eats more battery
power than the BB did so I normally keep it off, and it also turns on
the GPS, which I don't really need to use but we have three X's in the
family so we keep track of each other via Latitude. Another issue
though is apparently until the BlueTooth is successfully connected,
the navigator voice plays through the earpiece of the X and not the
speaker phone. Maybe there is a need also to insert a step to turn on
the speaker phone prior to opening BT.
Might just be easier to get CCH. This has helped me get up the curve
a bit though with Tasker. Thanks.
Bob

konradwalsh

unread,
Sep 2, 2010, 3:16:17 AM9/2/10
to Tasker
Ok.. well to be honest since I wrote that task/profile weeks ago, I
have learned an enormous amount about taskers abilities and
particularly I am starting to grasp the variables function. I am in
college at the minute and dont have as much time but I hope soon to
rewrite it and see if I can include all your choices..

Keith

unread,
Sep 5, 2010, 2:31:32 PM9/5/10
to Tasker
For some reason the files are not visible by tasker.
I even tried renaming them and taking the ".txt" from the end of the
file name.

Any suggestions on what I'm doing wrong?

Thanks,

Keith
Reply all
Reply to author
Forward
0 new messages