Issue in TaintDroid Build

130 views
Skip to first unread message

Daya Sharma

unread,
Sep 5, 2016, 2:23:09 PM9/5/16
to TaintDroid
Hii,
I am a Computer Science student currently studying malware analysis & tried to install the TaintDroid on my system. Everything gets built perfectly but emulator command doesn't work until a predefined avd image is used with @ i.e.
emulator @devce_name

And on executing $ emulator -kernel kernel-goldfish-xattr-2.6.29 there shows an error as.... Here @4 is an android virtual device name

daya@daya-Vostro-3558:~/tdroid/tdroid-4.3_r1$ emulator -kernel kernel-goldfish-xattr-2.6.29 @4
qemu: linux kernel too old to load a ram disk kernel-goldfish-xattr-2.6.29, /home/daya/android-sdk-linux/system-images/android-18/default/x86//ramdisk.img, qemu.gles=0 qemu=1 console=ttyS0 android.qemud=ttyS1 androidboot.hardware=goldfish clocksource=pit android.checkjni=1 ndns=1
daya@daya-Vostro-3558:~/tdroid/tdroid-4.3_r1$ 

without @4....
daya@daya-Vostro-3558:~/tdroid/tdroid-4.3_r1$ emulator -kernel kernel-goldfish-xattr-2.6.29
emulator: ERROR: No initial system image for this configuration!
daya@daya-Vostro-3558:~/tdroid/tdroid-4.3_r1$

The error seems to be qemu: linux kernel too old to load a ram disk kernel-goldfish-xattr-2.6.29
I have updated my linux kernel from 3.13 ,3.18,4.2,4.4 and tried on all but to no avail.

Please reply with suggestions
Thanks
Daya Sharma

P.S. Sorry for grammatical errors due to english not being my first language....
Reply all
Reply to author
Forward
0 new messages