cannot find any reference on how to troubleshoot taiga

18 views
Skip to first unread message

Samuel Balle

unread,
Sep 7, 2021, 10:26:33 AMSep 7
to taigaio
Hi,
I am evaluating taiga, followed the 30 minutes using the docker method and it worked.
Used it to evaluate usage 2 days.

Then I stopped the PC and restarted it by mistake, and now I get the "Something happened and the Taiga has captured the error to be able to work on it.".

I cannot see how to enquire on the source of the error. I tried to used "docker logs" but I saw nothing on any instance that would help.

Is there any generic troubleshooting guide available to get at least some data to share ?

Samuel Balle

unread,
Sep 9, 2021, 9:41:05 AMSep 9
to taigaio
It took me a while to get through this.

I reinstalled the server, retried the docker way. Restarted again tried the source way. It was still not working.

I finally found the issue. Somehow the install tutorial sets taiga service (taiga-back) on port 8000 where I do not know why the front interface tried to check it on port 8000.
I remapped the service to 8000, changed nginx configuration to also point the API to 8000 and now it works.

Finally to explain to newbies like me that may read this post, your first line of debug is not the server, it is the console of your browser...

Samuel Balle

unread,
Sep 9, 2021, 10:29:54 AMSep 9
to taigaio
Note to the documentation team.
The tutorial specifies to create services for API and ADMIN using port 8001 where the taiga-front has a dist/conf.example.json that we copy in the process states port 8000.
Easy to miss, you should change in one of the two.
Reply all
Reply to author
Forward
0 new messages