Try to compile on Ubuntu 14.04 (LTS)

46 views
Skip to first unread message

Newk

unread,
Feb 23, 2016, 12:16:15 PM2/23/16
to Syndicate Wars Port
Hi, I would love to play this game again as i had tons of fun with it back in 1999.
Great you guys made this!! Much respect for your efforts!

followed these instructions for GNU/Linux:

http://swars.vexillium.org/#doc

i did download and unpacked the swars-master forlder from github into my ~/ (user folder)
..and did already mounted the cd, but it didn't come to installing yet as the compiling fails:

http://pastebin.com/0MhD0prt

can anyone help me help me out?

Cheers!

Newk

unread,
Feb 25, 2016, 9:43:12 AM2/25/16
to Syndicate Wars Port
So.. i can confirm that the fork to github does break compiling for GNU/Linux :(

The good news is i got the original 0.3 port working :D
Great to have this game running on my computer again! 8-)
I had to tinker with the install script tho to add the soundtrack .wav that i ripped manually to the installment as .ogg.
For some reason it did not liked the mounting of multi-session cd.

Can someone confirm that "Tension Music" does not work? (No midi/AdLib emulation/replacement?)
Reply all
Reply to author
Forward
0 new messages