Problemas con la versión 6 de Symfony

26 views
Skip to first unread message

Jesús Clemente Gallart

unread,
Jul 29, 2022, 4:44:06 AM7/29/22
to symfony-es
Buenos días, tengo un problema con la versión 6 de symfony. Os pongo en antecedentes... Se instala correctamente, y aparece la pantalla de bienvenida, pero al crear un controlador (da lo mismo que sea el de usuario o home) me salta el error que os pongo. He reinstalado varias veces, incluso siguiendo las instrucciones de symfony.

Hasta ahora estaba con la versión 5 y 7.4 de PHP
He mirado por internet y hablan de problemas con la versión de PHP, Siguiendo las instrucciones de los foros, he cambiado la versión de XAMPP y del equipo a la 8.0.19.Captura de pantalla.png

Saúl Hernández Arellano

unread,
Aug 25, 2022, 3:42:20 PM8/25/22
to symfony-es

¿Hiciste el   "symfony check:requirements" ?

¿Qué módulos de PHP tienes instalados ??? 

Carlos A Salazar

unread,
Sep 28, 2022, 6:32:54 AM9/28/22
to symfony-es
Parece que te falta algun vendor o bien que no esta cargando correctamente las configuraciones por medio del XML,
quizas es que te falta agregar algo en las configuraciones... 
para symfony 6 usa 7.4 php minimo o bien php 8, 
Eso si..
Primero ten la version correcta de php..
luego inicia el proyecto O instala los Vendors... de lo contrario si cambias de version de php despues del proceso tendras problemas..
prueba eliminar los Vendors completo el composer.lock y el symfony.lock y ya con lo que he dicho el php correcto reinstala todo composer install y checka a ver que si sucede ..
podria ser tambien configuracion o falta de algun .htaccess en el servidor..
Prueba usar symfony server:start 
y tambien si usas el cliente de Symfony podrias probar crear el proyecto desde el CLI de symfony  en vez del composer. el CLI de symfony tiene mas virtudes que  el composer. y chequea muchas mas cosas..
Reply all
Reply to author
Forward
0 new messages