Problema con login

73 views
Skip to first unread message

Jesús Clemente Gallart

unread,
Dec 11, 2021, 7:21:04 AM12/11/21
to symfony-es
Buenos días:
Tengo un problema con un proyecto que he subido al servidor, en local funciona perfectamente, pero en el servidor da error el login (vamos que no hace nada).
La versión de symfony es la 5.3.12 en desarrollo. (dev)

El log...
-----------------
[2021-12-11T11:48:06.249279+00:00] security.DEBUG: Checking support on authenticator. {"firewall_name":"main","authenticator":"App\\Security\\LoginFormAuthenticator"} []
[2021-12-11T11:48:06.250029+00:00] security.DEBUG: Authenticator does not support the request. {"firewall_name":"main","authenticator":"App\\Security\\LoginFormAuthenticator"} []
[2021-12-11T11:48:06.272062+00:00] doctrine.DEBUG: SHOW FULL TABLES WHERE Table_type = 'BASE TABLE' [] []
[2021-12-11T11:48:06.274381+00:00] doctrine.DEBUG: SELECT DATABASE() [] []
-----------
La barra de symfony no indica ningún error. Sólo aparece eso en el log.
He probado...
La base de datos está bien conectada, la aplicación funciona perfectamente si permito usuarios anónimos. 

Y por cierto... no es el primer proyecto que subo a ese servidor.

Manuel Aguirre

unread,
Dec 13, 2021, 3:42:06 PM12/13/21
to symfo...@googlegroups.com
Buenas,

Los logs te están diciendo que el autenticador no soporta el request dado. Eso significa que no se están cumpliendo las condiciones para que el autenticador se active.

Habría que ver el código de tu autenticador para poder ayudarte más, pero así por encima, asumo que tu autenticador espera que el request sea POST, que lleguen
ciertos parámetros en el request y quizás que la URL sea una en específico. Algo de eso no se está cumpliendo.

Como usas Symfony 5.3 asumo que tu autenticador tiene un método support() que es donde debe estar la lógica de lo que te comento más arriba.

Te dejo links de interés a ver si te ayudan a entender mejor qué sucede:


Saludos!

--
--
Has recibido este mensaje porque estás suscrito al grupo "symfony-es" de Google Groups.
Para publicar en este grupo, envía un email a symfo...@googlegroups.com
Para darte de baja, envía un email a symfony-es+...@googlegroups.com
El resto de opciones puedes encontrarlas en http://groups.google.com/group/symfony-es?hl=es

---
Has recibido este mensaje porque estás suscrito al grupo "symfony-es" de Grupos de Google.
Para cancelar la suscripción a este grupo y dejar de recibir sus mensajes, envía un correo electrónico a symfony-es+...@googlegroups.com.
Para ver esta conversación en el sitio web, visita https://groups.google.com/d/msgid/symfony-es/11b73b2c-02c0-4d3b-8a7d-a2a7c157d4bcn%40googlegroups.com.


--

Manuel Aguirre.


manuel_j555 | Desarrollador de Software | Optime Consulting | twitter | github | Sitio web


A menudo unas pocas horas de "Prueba y error" podrán ahorrarte minutos de leer manuales.

Jesús Clemente Gallart

unread,
Dec 15, 2021, 4:04:53 AM12/15/21
to symfony-es
Buenos días:
Ante la imposibilidad de resolver el problema he creado de nuevo toda la lógica del login del usuario y lo he subido. Ahora funciona.

Reply all
Reply to author
Forward
0 new messages